Jump to content


Photo

Smb Shares On Winsrv2003


  • Please log in to reply
7 replies to this topic

#1 tim_41774

tim_41774

    X-S Enthusiast

  • Members
  • 8 posts

Posted 08 September 2003 - 03:08 AM

Problem: Cannot see .jpg files on a Windows 2003 Enterprise server shared (SMB) folder.

I spent a great deal of time working on this today. I wasn't able to find any posts on xbox-scene regarding this issue, so now that I have resolved the problem, hopefully I can share some valuable information. I finally found the solution (posted in a different context), on samba.org.

Solution: Windows Server 2003 is more secure than any of the previous Windows OS's. Windows Server 2003 requires signature of SMB packets by default. In order to disable the digitally signed communications you need to make the following registry hack on your Windows Server 2003:

Key: HKLMSYSTEMCCSServicelanmanserverparameters
Value: RequireSecuritySignature
Content: 0 to disable, 1 to enable

Reboot the server.

Good luck!

#2 funkgroovin

funkgroovin

    X-S Enthusiast

  • Members
  • 1 posts

Posted 09 December 2004 - 07:16 AM

Had a similar problem with XBMC accessing shares on Windows Server 2003. I was outright denied access to the machine. User setup is correct (and super redundant) and I used the registry hack you suggested (no difference).

Frankly, I haven't found much info on this at all and any input would be most appreciated.




#3 hav0k99

hav0k99

    X-S Young Member

  • Members
  • Pip
  • 37 posts

Posted 10 December 2004 - 01:42 AM

how do I enter this into the registry?

#4 ztc

ztc

    X-S Enthusiast

  • Members
  • 12 posts

Posted 10 December 2004 - 10:41 AM

Here is how my system is set up and it works greats. I am running windows 2003 server.

1. Make a user account on your windows machine.
2. Share the folders you want the xbox to use then change the premission for only read only for the xbox user.
3. add the following to your XBMC.xml config file.
<bookmark>
<name>XBMC DISPLAY NAME</name>
<path>smb://WINDOWS ACCOUNT USERNAME:WINDOWS ACCOUNT PASSWORD@IP ADDRESS0/WINDOWS SHARE NAME</path>
</bookmark>

is like

<bookmark>
<name>DVDs</name>
<path>smb://xbox:password@192.168.0.200/DVDs</path>
</bookmark>


I hope this helps

ZT

Edited by ztc, 10 December 2004 - 10:41 AM.


#5 amdhunter

amdhunter

    X-S Enthusiast

  • Members
  • 21 posts

Posted 13 December 2004 - 05:54 PM

Um, maybe I am a little bit late here, but all you have to do is enable the guest account and make sure the folders you want access to have everyone permission.

#6 dacho

dacho

    X-S Enthusiast

  • Members
  • 3 posts

Posted 06 January 2005 - 01:24 AM

i agree all you have to do is enable the guest account

Edited by dacho, 06 January 2005 - 01:36 AM.


#7 jgreeno

jgreeno

    X-S Enthusiast

  • Members
  • 29 posts
  • Xbox Version:v1.6b
  • 360 version:v5.0 (360S - trinity)

Posted 18 March 2005 - 03:26 PM

Do the shares have to be configured special for this?
In other words to I need to go about setting up a "samba" compliant share or will standard windows shares work fine?

#8 RobEn

RobEn

    X-S Enthusiast

  • Members
  • 1 posts

Posted 09 May 2005 - 06:51 PM

Hello!

I have created a new account and I can access the share folder but nothing is displayed. What can I do?

Please help!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users