Jump to content


Photo

Qwix 1.01 Released


  • Please log in to reply
9 replies to this topic

#1 Devenic

Devenic

    Avalaunch Team

  • Moderator
  • PipPip
  • 394 posts
  • Xbox Version:v1.4
  • 360 version:none

Posted 25 November 2003 - 07:03 AM

Happy Thanksgiving, for those in the US. I figured I'd post an update of Qwix to get rid of any open bugs that I know about. There aren't any new features in this release, just bug fixes. New goodies will appear in Qwix 1.1, but this version should be more stable than the first release and will buy me a little more time to work on the fun stuff.

If you changed your settings.ini file based on the tweak I posted last week, you'll probably want to take the buffer settings back out. I reworked the way Qwix uses buffers, and it now uses a default that is twice the size of what Qwix 1.0 used, but is faster overall and actually uses less memory, despite how backwards that sounds.

Note: Please read the Qwix_FAQ.htm file included with Qwix! Even with that file included in the RAR, many of those questions come up all the time.

Qwix 1.01 fixes:
  • Reworked FTP transfer buffers for improved Windows performance during and after transfers, which can also increase transfer speeds (especially boost mode).
  • Changed default transfer buffer size from 512KB to 1MB.
  • Fixed a transfer thread leak which caused various problems with Qwix after transferring an ISO.
  • Fixed a problem that prevented game icons from being downloaded after transferring an ISO.
  • Fixed a problem that prevented batch properties from taking effect if you pushed a button on the toolbar before clicking in any other control first.
  • Made the XBE rename case-sensitive when deciding whether it should rewrite the XBE file or not.
  • Disabled the "Use advanced Avalaunch features" option in the connection editor until the SITE REFRESH command is fixed in Avalaunch. Yes, that's all that the option does. No, it doesn't make transfers slower.
  • Fixed the taskbar disappearing act and an occasional OLE32.DLL access violation, both on Win98/WinME.
  • Fixed a few font and color issues, making things a bit more consistent with certain themes and platforms.
  • Fixed a problem that prevented a transfer to the root directory of an Xbox drive.
  • Fixed a random access violation that was caused by the component used for all the lists and trees in the Qwix user interface.
  • Made the local PC folder browser show the proper folder name for shortcut items like My Network Places shares.
  • Fixed the Rename ISO feature from the Scan Folders right-click (from the Load ISO screen, not Scan Titles).

Edited by Devenic, 25 November 2003 - 06:12 PM.


#2 ReKlaTs

ReKlaTs

    X-S Member

  • Members
  • Pip
  • 87 posts

Posted 25 November 2003 - 05:32 PM

QUOTE (Devenic @ Nov 25 2003, 09:03 AM)
  • Fixed the taskbar disappearing act and an occasional OLE32.DLL access violation, both on Win98/WinME.

  • Boo yah! smile.gif Thanks Devenic

    #3 bartdesign

    bartdesign

      X-S Member

    • Members
    • Pip
    • 100 posts

    Posted 26 November 2003 - 05:19 PM

    I noticed deleting multiple titles in a row can make qwix crash and my cpu gives qwix 50% of my cpu time when crashed. Do i have to restart my xbox to see my game list updated becuase you removed the site refresh or has that command an other purpose. Bucuase it doesn't update my game list after an upload. This release is ages better than 1.0 btw smile.gif Thanks for this great tool. beerchug.gif

    BjB

    #4 r0rs

    r0rs

      X-S Enthusiast

    • Members
    • 3 posts

    Posted 26 November 2003 - 06:26 PM

    How many titles are you talking in a row? I've deleted at least 10 in a row on a several occaisons without any problems. As far as refreshing after you upload, just click the scan button to rescan your titles.

    r0rs

    #5 bartdesign

    bartdesign

      X-S Member

    • Members
    • Pip
    • 100 posts

    Posted 29 November 2003 - 07:29 AM

    Well try this: Select 2 and delete them then quickly select another 2 and delete them too. If gives me an error. Maybe an delete timer should be intergrated-> after 10 sec. you will able to delete again. Also i've tested the new version further. If your hdd is full the box will lock up and qwix will keep running but the transfer rate is falling to 0. When i'm transfering from my 2ghz(winxp) pc i get an avarenge of 7mb/s and i hogs my pc down so badly i can hardy run IE however my cpu usage is like 40 % so it must has something to do with the hdd although it's 7200/133. And on my server a P4 2,4 X with 1024 mb(win2000server) ram it doesn't get above 3mb/s which is very strange apart that it's one switch further connection wise. Also qwix will let ava hang when transfering massive amounts of iso's(50 a 80 gb)and thus giving the draining to 0kb/s sec thing. Overal it is a vast improvement above 1.0. And i'm hoping you can do something with this info. Also the minor calc error occurs and sometime i get the feeling that the avarage isn't correct becuase i'm uploading with 7mb/s current constant and it's giving me a 3mb/s avarenga but it goes noticeable faster that 3mb/s. Despite the few bugs i love qwix to death becuase of it's easy to use interface and the perfect tool for iso management for the box and pc smile.gif thx

    B

    #6 Devenic

    Devenic

      Avalaunch Team

    • Moderator
    • PipPip
    • 394 posts
    • Xbox Version:v1.4
    • 360 version:none

    Posted 29 November 2003 - 03:55 PM

    bartdesign, sorry to hear you're running into so many problems. Qwix goes through a tremendous amount of testing, and none of the testers run into what you see.

    First, you can't select more than one game to delete at a a time. The list won't allow it, intentionally. If you were trying this with Qwix 1.0 and Avalaunch, then I would suspect you turned on the "Use Advanced Avalaunch features" option, which could hang after issuing the SITE REFRESH command. Qwix 1.01 removes that feature until we can get it working.

    The FAQ included with Qwix discusses HDD free space. Basically you need to manage your freespace yourself with Qwix 1.01. It's not a bug exactly...I simply didn't implement a free space check because every dashboard does it differently.

    Are you still seeing your machine turn into a pig with Qwix 1.01? There was a major improvment made to the memory access patterns in 1.01; it no longer freaks out the Windows memory manager. However, Windows is insane about file caching and works very hard with large files like ISOs. The next version of Qwix will have some further tuning options available that allow the Windows file cache to be bypassed completely. Initial results are quite good. There must be some drivers that are especially bad with the file cache because Qwix 1.01 allows my machine to run very smoothly with almost no memory fluctuations, and certainly no hogging.

    I have no idea why your Win2000 server would be so slow. Please consult the FAQ with Qwix 1.01 for some things to check. I have no experience with Win2000 server, and have no plans to really try to tune Qwix for a server environment. wink.gif Servers sometimes are tuned in odd ways that Qwix was not designed or tested for. If you have the ability to simplify the setup to the server, please try that and see what kind of results you get.

    Qwix has been tested many times with batches of up to 120GB without hangs for many users. I would suspect something else (like a full HDD). You don't say what dashboard you're running though. Avalaunch 0.48 or higher?

    The average speed in Qwix is a true average. It takes the total number of bytes over the total number of seconds. The current speed, on the other hand, doesn't bother showing speeds that are below 1KB/s, so it's possible that it keeps showing a speed that is no longer accurate. Normally, those don't occur very often. There must be some other issue at play. This can be anything from a badly fragmented Xbox drive to bad/marginal sectors on the Xbox drive to network issues.

    As far as anything reproducible that has been reported to me, all the bugs have been squashed. I'd love to help with what you're running into, but I simply am unable to reproduce the problems with my 2 Xboxes here on my simple network. Without more information about how to reproduce the problems I can't fix them. Unfortunately, that's the way software development works.

    Glad you like Qwix (despite your issues), and if you come up with any information to help me reproduce these problems please post them here.

    #7 bartdesign

    bartdesign

      X-S Member

    • Members
    • Pip
    • 100 posts

    Posted 29 November 2003 - 04:02 PM

    It isn;t that much of a hassle, it works. I realize that these problems are hard/impossible to track but i wanted you to know that it still doesn't run propely for me. I doesn't matter that it crashes from time to time. Hell it's beta smile.gif The only concern that i have is the fact that 1.01 makes my xp pc slower that 1.0 which is weird becuase the buffer should be optimized. My experiences are far better than worse. I use this app every day and will keep using simply becuase it rox!! Thank you for all your hard work.

    B

    #8 Devenic

    Devenic

      Avalaunch Team

    • Moderator
    • PipPip
    • 394 posts
    • Xbox Version:v1.4
    • 360 version:none

    Posted 29 November 2003 - 04:03 PM

    Stop by the #qwix channel sometime. Maybe we can figure something out.

    #9 bartdesign

    bartdesign

      X-S Member

    • Members
    • Pip
    • 100 posts

    Posted 05 December 2003 - 07:25 AM

    When i have the time, I will.

    Bye

    #10 truBB

    truBB

      X-S Member

    • Members
    • Pip
    • 103 posts
    • Location:Long Beach / Lakewood, California
    • Interests:modding!
    • Xbox Version:v1.6
    • 360 version:v3.0 (falcon)

    Posted 27 August 2004 - 05:30 PM

    Click on "scan titles" then I clicked on the "..." under "FTP folder" of "create iso" while quix was trying to download the icons. I get a "quix error" message, with the following:

    CODE

    Application...
     Start Date      :
     Name/Description:
     Version Number  : 1.0.1.8

    Exception...
     Date   : 08/27/2004 09:38:11
     Address: 00515537
     Module : Qwix.exe
     Type   : EIdProtocolReplyError
     Message: Opening BINARY mode data connection for transfer.  .

    Active Controls...
     Form Class   : TfrmLaunch
     Form Text    : Qwix 1.01
     Control Class: TcxCustomInnerTextEdit
     Control Text :

    Computer...
     Name        :
     Total Memory:
     Free Memory :
     Total Disk  :
     Free Disk   :

    Operating System...
     Type    : MS Windows 2000
     Build # :
     Language:





    0 user(s) are reading this topic

    0 members, 0 guests, 0 anonymous users