Jump to content


Photo

X-ecuter2 Bios + Dragons Lair 3d


  • Please log in to reply
14 replies to this topic

#1 Tek

Tek

    X-S Enthusiast

  • Members
  • 13 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 23 November 2002 - 04:16 AM

There's no forum on BIOS problems/questions here so I thought this would be somewhere I can post this.

I've installed, then flashed my TSOP with an Enigmah FINAL modchip and everything's been working great. I've recently flashed to the new X-ecuter2 BIOS for v1.0 XBOX for the in-game reset feature... very cool btw. wink.gif

I extracted Dragon's Lair 3D to the 40GB hard drive I've replaced and when trying to boot it, it just sits at the 'Evox loading' screen.

Then I decided to flash back to the Evox 2.4 BIOS (it's the last Evox BIOS I had already on the HD) and now the game loads without a hitch.

I just wanted to see if anyone has noticed this before and can confirm it? I want to play this game but I also like the in-game reset. Maybe this information should be given to the guys over at X-ecuter.


#2 Yosco

Yosco

    X-S Young Member

  • Members
  • Pip
  • 51 posts

Posted 24 November 2002 - 08:27 PM

I think I can confirm this, It doesn't work for me with the latest bios, I will re-flash to and older on and post back.

#3 BenJeremy

BenJeremy

    X-S Elysian

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,690 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 24 November 2002 - 08:40 PM

Perhaps the X2 team could put in a "disable IGR" feature intot he next release, monitoring for a certain button combination when loading a game, to disable the auto-patching?

#4 Yosco

Yosco

    X-S Young Member

  • Members
  • Pip
  • 51 posts

Posted 24 November 2002 - 09:30 PM

Confirmed, I have the same prob, But fixed with Evos latest bios. Could be IGR.

#5 ForNeverEnding

ForNeverEnding

    X-S Member

  • Members
  • Pip
  • 115 posts

Posted 24 November 2002 - 09:35 PM

Team x-ecuter has said that a *few* games do not load correctly with the IGR bios...a patch or some other means of fixing the problem is in the making

#6 Cornholio

Cornholio

    X-S Senior Member

  • Members
  • PipPip
  • 288 posts

Posted 25 November 2002 - 03:32 AM

You see, this is why I am not running this BIOS. I think it's not a good idea.

Don't get me wrong, it's a cool feature, and I'm not bashing Team X-ecuter at all. But it's a pretty complex hack, and WILL cause problems with some games - and whenever MS update the XDK it is likely to cause more problems still.

I think a better idea would be to put this code in the neXgen dash, rather than in the BIOS. This would mean that a "disable" option would be very easy to add, and when updates are needed, you don't need to flash your chip - just get a new dash XBE.

No doubt the patched XBE would need to call code in the BIOS - no problem, you'd need the X-ecuter2 BIOS to use this feature still. But it's the code that searches the loading XBE and patches it that's causing the problems, IMO - since that's the code that is likely to change.

Wonder if Team X-ecuter have thought of this possibility ?


#7 oic989

oic989

    X-S Enthusiast

  • Members
  • 11 posts

Posted 25 November 2002 - 03:52 AM

FWIW, I am using the Xecuter 2 bios for v1.0 hardware. The first release, not the final. Dragons Lair loads fine.

It's _SLOW_ as heck, but it loads fine and plays fine. Even from the HD there's a sizeable wait to get started, so much that I thought it wasn't working either.



#8 snakejoe

snakejoe

    X-S Senior Member

  • Members
  • PipPip
  • 187 posts

Posted 25 November 2002 - 04:28 AM

QUOTE (BenJeremy @ Nov 25 2002, 03:40 AM)
Perhaps the X2 team could put in a "disable IGR" feature intot he next release, monitoring for a certain button combination when loading a game, to disable the auto-patching?

The next release will allow you to enable/diable it.
Because team xecuter said the next relase will be the one that can allow you to edit BIOS features by some ini files. But it will be a 512K BIOS.

#9 SniperKilla

SniperKilla

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,519 posts
  • Location:Pittsburgh, PA
  • Xbox Version:v1.0
  • 360 version:v4.0 (jasper)

Posted 25 November 2002 - 06:23 AM

works fine over here and is damn pretty at 1080i

#10 notwork

notwork

    X-S Enthusiast

  • Members
  • 2 posts

Posted 26 November 2002 - 09:54 AM

I had the same issue with Dragons Lair 3D hanging on boot when I used fancbox to customize the 1mb version of the xecuter2 final bios. I then used fancbox to customize the 256kb version and saved it as 1mb to flash my pcbioxx and that fixed the problem. Using the strait 1mb version of the xecuter2 final without custimization worked as well.

#11 rgtaa

rgtaa

    X-S Freak

  • XS-BANNED
  • PipPipPipPipPip
  • 1,096 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 04 December 2002 - 02:59 PM

executer2 v4972 didn't work for dragon's liar 3d or NFL fever 2003 and a few other games!

but! smile.gif

executer2 v4973 does work for all the games! smile.gif

#12 slizzap

slizzap

    X-S Member

  • Members
  • Pip
  • 104 posts

Posted 04 December 2002 - 09:42 PM

QUOTE (rgtaa @ Dec 4 2002, 08:59 AM)
executer2 v4972 didn't work for dragon's liar 3d or NFL fever 2003 and a few other games!

but! smile.gif

executer2 v4973 does work for all the games! smile.gif

Yep, 4973 worked for me also. However I'm having strange issues with Splinter Cell now. I loaded it up and some controls weren't working, then it locked up. I switched back to 4972 and Splinter Cell worked perfectly.

Can anyone else confirm any issues with Splinter Cell and 4973?

#13 Driver

Driver

    X-S Young Member

  • Members
  • Pip
  • 52 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 04 December 2002 - 10:14 PM

Splinter Cell works fine for me with 4973.

#14 b0ink

b0ink

    X-S Genius

  • Members
  • PipPipPipPip
  • 915 posts

Posted 04 December 2002 - 10:59 PM

No problems for me either.

#15 sonic-iso

sonic-iso

    X-S Member

  • Members
  • Pip
  • 132 posts
  • Xbox Version:v1.6
  • 360 version:v1 (xenon)

Posted 04 December 2002 - 11:15 PM

4973 fixed all the problems

good to see they are backing up their releases with a bit of support




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users