Jump to content


Photo

Power Supply Popped.


  • Please log in to reply
4 replies to this topic

#1 gir

gir

    X-S Member

  • Members
  • Pip
  • 100 posts

Posted 12 January 2004 - 02:15 PM

I had just finished flashing the tsop on my sisters xbox. I put the mobo back in the case and reconnected everything but I forgot the HD power cable. I hit the power button and heard a pop and saw a small electrical flash near or under the small light blue cube-shaped thing at the back of the powersuply board. I turned it off, connected the HD power and tried it again. It booted just fine and his been running since. Should I be concerned or not?

Thanks!

#2 chefelf

chefelf

    Brandishing the Triforce of Modding

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPip
  • 7,407 posts
  • Gender:Male
  • Location:New York, NY
  • Interests:Video Games, Web Design, Writing, Cycling, Hardware Modification, Building Computers, Music
  • Xbox Version:v1.3
  • 360 version:unknown

Posted 12 January 2004 - 06:23 PM

Well, there's not much you can do. Just consider yourself lucky, I suppose. smile.gif

#3 jayster50

jayster50

    X-S Enthusiast

  • Members
  • 25 posts

Posted 12 January 2004 - 06:24 PM

It happened once to me after I did a mod on a PS1. Worked perfectly after and still does.

#4 juve

juve

    X-S Member

  • Members
  • Pip
  • 84 posts

Posted 12 January 2004 - 06:27 PM

the molex could have jsut hit the ground or something and caused a spark.

rejoice, for you are truly lucky you didn't fry the whole thing tongue.gif

#5 gir

gir

    X-S Member

  • Members
  • Pip
  • 100 posts

Posted 12 January 2004 - 07:12 PM

WOOT!

THanks Guys!

Now if only i could figure out why none of the crap i burn on these new sony dvd-r's arent readable by anything but I have never had a problem with the fujifilm ones...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users