Jump to content


Photo

Crash On Skin Load!


  • Please log in to reply
7 replies to this topic

#1 skynet_xp

skynet_xp

    X-S Enthusiast

  • Members
  • 2 posts

Posted 19 February 2004 - 06:53 PM

Firstable thanks to Ben for his incredible work.

I have problems when loading some skins, simply MXM Skinner 5.0 crash returning to windows.
So, all skins i have saved dont work again and i cant continue the job.

Please help me.

(windows xp pro with wm9 codecs)

Edited by skynet_xp, 19 February 2004 - 06:55 PM.


#2 geniusalz

geniusalz

    Team MXM

  • Head Moderators
  • PipPipPipPipPip
  • 1,827 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 19 February 2004 - 07:43 PM

First off, make sure that all your videos are encoded in WMV 8 format (not WMV 9)

As for Skinner crashing, send me a copy of the skin (find me on IRC sometime today or tomorrow. #mxm on EFNET)

#3 -FourDoor-

-FourDoor-

    X-S Expert

  • Members
  • PipPipPip
  • 504 posts
  • Location:California
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 19 February 2004 - 08:46 PM

If the skins that are crashing are yours that you made. Make sure that you didn't try to save the new/revised skin over an existing skin directory. I had the same problem before too with MXM crashing on the skins I made because of the exact same problem. I think it also happened when I went through these steps: Load up skinner, create skin, save, then edit current skin, then try to save again either in a new or the current directory. The skin I just created would freeze mxm on loadup. So my way of working with skinner was to Load up skinner, create skin, save to new directory. And if I had to make any edits, I would close skinner, reload the saved skin, make the edit, then save again in a new folder.

Just some feedback for G. This was about 2months ago or so when I worked with skinner for the first time.

#4 geniusalz

geniusalz

    Team MXM

  • Head Moderators
  • PipPipPipPipPip
  • 1,827 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 19 February 2004 - 08:49 PM

Dunno, it shouldn't be crashing at all. But an example skin that crashes Skinner would help fixing this.

#5 -FourDoor-

-FourDoor-

    X-S Expert

  • Members
  • PipPipPip
  • 504 posts
  • Location:California
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 19 February 2004 - 09:06 PM

I'll see if I can recreate the error later this week. It's been a while now since I tried to make my first skin.

#6 skynet_xp

skynet_xp

    X-S Enthusiast

  • Members
  • 2 posts

Posted 19 February 2004 - 11:14 PM

Thank you people!!

At last i found the error!!! MXMXSkinner cut the name of files with a long namefile ("cacho pequeño transparente.png" huh.gif blink.gif ) when write the MXM_SKIN.XML

Maybe suggestion?:
Could Skinner detect errors in the .XML when load a skin and show a message instead of go to hyperspace?

3-4 days to finish my first skin i`ll show you it then. I have ripped the menus of Teminator 2 DVD to do the skin (near 16:9 if you strech the image in a 16:9 TV, deformed in 4:3 TV biggrin.gif )

Sorry for my english....

#7 geniusalz

geniusalz

    Team MXM

  • Head Moderators
  • PipPipPipPipPip
  • 1,827 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 20 February 2004 - 12:59 AM

Seems like the vb FileCopy function can't handle long filenames... weird

#8 flattspott

flattspott

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,787 posts
  • Location:Southern California
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 20 February 2004 - 01:26 AM

This has also happened to me a few times. Like when working on on a skin and I save it. Then if happened to edit the xml file to add unsupported things like the Zpoints when I try to reload load itm it'll give me an error. Not everytime, but sometimes.

That's why I always say make a backup first. wink.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users