Jump to content


Photo

Edit Boxes Not Updateing Value?


  • Please log in to reply
7 replies to this topic

#1 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 26 February 2004 - 08:30 AM

Was Playing around with the simple namechanger scripts and it seems that getting .value xml part from an edit box of a dialog in the new version dosn't get the updated text but still the old one. I tried this on both my IP and Name Changer scripts and the values were the same as before edited I even tried to convert it to the new XML pathing stuff in the latest release and still the same.

Of course it could be I dont know what I'm doing but hey I'll ask anyway

HELP

#2 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 26 February 2004 - 08:41 AM

Ahh never mind figured it out the Dialog XML actually has to have the <value></Value> bit in it in the new wip the old ones didn't matter

#3 BenJeremy

BenJeremy

    X-S Elysian

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,690 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 26 February 2004 - 10:15 AM

Strange. I don't quite understand what the exact issue is here, though.

#4 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 26 February 2004 - 07:33 PM

Its not really an issue just slackness on my part but I'll spell it out for you

In the old wips if you had this

Dialog.XML

<Control Type="editboxsingle" CtrlID="106">
<rect t="160" l="10" b="185" r="390" />
</Control>

and then in you script lines like

XMLSetValue testdialog !.Control:1.Value "%kbInput%"
..
..
..
XMLGetValue testdialog kbInput !.Control:1.Value

It would work OK but in the new wips for that to work you need to actually have the dialog xml like this

<Control Type="editboxsingle" CtrlID="106">
<rect t="160" l="10" b="185" r="390" />
<Value></Value>
</Control>


I guess its not creating/updateing the value like it used to if the mxl tag didn't exist

Hope you understand that


#5 flattspott

flattspott

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,787 posts
  • Location:Southern California
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 February 2004 - 07:49 PM

That's why I do this just incase for any control I use. I add these for them all.

<Selected></Selected>
<Value></Value>
<Enable></Enable>
<Visible></Visible>
<Text></Text>
<Color></Color>
<BackColor></BackColor>
<BorderColor></BorderColor>
<Group></Group>

That way I'm sure all the nodes are there when I try to use them.

#6 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 26 February 2004 - 07:57 PM

By the way the above example would let you set the value but if you try to get the updated text from the edit box it would still be the same as the original value from the xml set line.

Oh and I tried the new way of doing xml and it ws the same also

#7 flattspott

flattspott

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,787 posts
  • Location:Southern California
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 February 2004 - 08:06 PM

Post you script or a link to it and I give it a go so I can understand what your referring too.

#8 Jezz_X

Jezz_X

    X-S Knowledgebase

  • Moderator
  • PipPipPipPipPipPipPipPip
  • 4,531 posts
  • Location:Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 26 February 2004 - 08:19 PM

QUOTE (flattspott @ Feb 26 2004, 10:06 PM)
Post you script or a link to it and I give it a go so I can understand what your referring too.

Nah its OK I fixed it but if you want to see for yourself try downloading and using this one

http://forums.xbox-s...howtopic=174241

The name will always go unchanged

Edited by Jezz_X, 26 February 2004 - 08:21 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users