Jump to content


Photo

Samba (smb) Working On Xbox Windows 98


  • Please log in to reply
6 replies to this topic

#1 MrPhunkee

MrPhunkee

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 508 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 02 April 2004 - 06:24 PM

Hey, I followed some tutorial, but if I want 2 acces smb there comes : acces denied

I use windows 98, in my ntwork enviroment I only see my pc and not the xbox..
And i can't assign a new user..
Does anybody has some experince with this?



#2 notsloth

notsloth

    X-S Young Member

  • Members
  • Pip
  • 56 posts

Posted 02 April 2004 - 06:50 PM

You'll never see your xbox in 'Network Neighbourhood' on your windows PC because XBMC / XBMP (I'm assuming thats what you're trying to use) can only act as an SMB client, not a server.

I think perhaps you'd get more helpfull replies if you posted a little more information about what you've done so far and what it is you're TRYING to do.

#3 MrPhunkee

MrPhunkee

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 508 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 02 April 2004 - 07:29 PM

I know, but my english is not so well, I speak Dutch..

<name>SMB</name>
<!-- you can use the following formats: !-->
<!-- smb://domain;user:password@ip/share/directory/ !-->
<!-- smb://user:password@ip/share/ !-->
<!-- if guest/public access is enabled: !-->
<!-- smb://ip/ !-->
<path>smb://DOMAIN;username:pwd@MyWindowsServer/movies/</path>
</bookmark>

this is the original MediaCenter.xml file

I chanched it 2 this:
<name>SMB</name>
<!-- you can use the following formats: !-->
<!-- smb://xbox;marlon:lientje@192.168.0.2/share/directory/ !-->
<!-- smb://marlon:lientje@192.068.0.2/share/ !-->
<!-- if guest/public access is enabled: !-->
<!-- smb://192.168.0.2/ !-->
<path>smb://xbox;marlon:lientje@Workgroup/movies/</path>
</bookmark>


Maybe it's wrong, I got it from some tutorial

192.168.0.2 is my pc's ip adress, 192.168.0.3 is the ip of the box

I rightmouseclicked on the map movies: share and also my c drive i shared(2 be sure)

In my network, I took a a protocol : Netbui,
a file and printer sharing 4 MS networks

So i think the network thing is propperly installed..

I putted the .xmf file in the box, rebooted and if I click smb in xbmc I get an acces denied.. What went wrong?

I just want 2 stream movies from my pc 2 the xbox

#4 mc_365

mc_365

    X-S Expert

  • Members
  • PipPipPip
  • 739 posts

Posted 02 April 2004 - 10:45 PM

samba does not work with windows 98.

But there should be some workaround. Keep working on it you maybe able to help someone else if you solve this issue.

I believe the root of the problem is Win 98 can not understand the username/password sent to it by the xbox, becuase of some encryption that happens during the access process.

If you know some one with Win XP Pro have them make you a XP networking disk.

When you begin to setup a network with WinXP if gives you an option to make a network setup disk for installing the network protocals on other PCs so they will be compatable with the network.

#5 tslayer

tslayer

    X-S Genius

  • Members
  • PipPipPipPip
  • 965 posts

Posted 03 April 2004 - 01:07 AM

You can enable the clear text password that win98 needs to understand I think.

Edit your win98 registry (backup first) and add the following:

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VNETSUP]
"EnablePlainTextPassword"=dword:00000001


I think that may do it.


Follow the instructions at the following link: http://www.med.nyu.e...n98NTsamba.html

TS



#6 WabidWoveren

WabidWoveren

    X-S Senior Member

  • Members
  • PipPip
  • 288 posts

Posted 03 April 2004 - 01:32 AM

QUOTE (MrPhunkee @ Apr 2 2004, 09:29 PM)

<!-- you can use the following formats: !-->
<!-- smb://xbox;marlon:lientje@192.168.0.2/share/directory/ !-->
<!-- smb://marlon:lientje@192.068.0.2/share/ !-->
<!-- if guest/public access is enabled: !-->
<!-- smb://192.168.0.2/ !-->
<path>smb://xbox;marlon:lientje@Workgroup/movies/</path>
</bookmark>


everything with <!--- is ignored by xbmc, so there is no reason to fill it in. Also is your domain called xbox, and your computer name called movies?

try this
CODE
<path>smb://marlon:lientje@192.068.0.2/share/</path>


#7 MrPhunkee

MrPhunkee

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 508 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 04 April 2004 - 09:58 AM

Thanks guys, I setted my path that way en inserted that EnablePlainTextPassword in the wright direction, but it still won't work.. You can see that he's searching and then again, acces denied.. So I think it just won't work with win 98. 2 bad, relax xstream doens't work either with it sad.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users