Jump to content


Photo

Mxm Wip Releases


  • Please log in to reply
701 replies to this topic

#691 BenJeremy

BenJeremy

    X-S Elysian

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,690 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 16 September 2004 - 03:39 AM

Anybody try it out?

I haven't had time to do a network settings script.

#692 Yuyu

Yuyu

    X-S Spirit Detective

  • Moderator
  • PipPipPipPipPip
  • 1,231 posts
  • Location:Belleville, IL
  • Interests:Football (Soccer) ... Umm, Xbox?
  • Xbox Version:v1.1
  • 360 version:v2 (zephyr)

Posted 16 September 2004 - 04:31 AM

I'll try it out in the morning before school wink.gif

#693 geniusalz

geniusalz

    Team MXM

  • Head Moderators
  • PipPipPipPipPip
  • 1,827 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 22 September 2004 - 04:09 AM

Between 9-hour sport matches and university back on, I finally managed to get some time to try out the new build.

Got to say, the skin switching is amazing. No hiccups so far (I tried about 5 different skins at a time), and the transitions between skins are flawless. I especially like the fade, and how it eliminates the usual flickering/resizing that happens when changing skins in just about any program I can think of.

kudos pop.gif

BTW, I'll look into the network stuff later. Any ideas on how to auto-reset network settings when network cable is plugged in/pulled out?

Edited by geniusalz, 22 September 2004 - 04:12 AM.


#694 chilin_dude

chilin_dude

    X-S Knowledgebase

  • Members
  • PipPipPipPipPipPipPipPip
  • 4,945 posts
  • Location:USA
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 27 September 2004 - 10:42 PM

Just tried it out BJ, couple of comments:

1. The skin switching is EXTREMELY nice, i too love how it fades into the new skin, I changed between 6-7 skins with no problems... It was so nice not to have to restart, now we only need previews of the skins wink.gif .

2. Love the new skins that are included, I take it you made them, they are very good, especially the animated robot! I love the way it shoots when you are loading something!

Couple of non-Wip comments.
Tonight I was trying to get my xbox to see F:\ I enabled partitining using the system menu, but everytime I rebooted it went back to 'enable partitioning'=No.

So I did it through Evo-x. However I then rebooted and MXM saw no F:\ which was weird... I went through all the settings and couldn't see anything... then it hit me after 1 hour of fiddling... When I had used the mxm patcher I'd clicked to disable F on startup. So I wonder if its possible to add re-enabling G and F in the menu? or simply stating that they are currently disabled?

Another thing is that MXM ALWAYS says that it is in Safemode - Which is kind of weird... Is there any reason for this? My time/date is always set and the xbox is left plugged in...


Thanks beerchug.gif

#695 flattspott

flattspott

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,787 posts
  • Location:Southern California
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 28 September 2004 - 02:25 AM

QUOTE
Love the new skins that are included, I take it you made them, they are very good, especially the animated robot! I love the way it shoots when you are loading something!



Nope BJ didn't make the cheesy Robo skins... I did laugh.gif
Not to mention that they've been there for quite some time now.

#696 chilin_dude

chilin_dude

    X-S Knowledgebase

  • Members
  • PipPipPipPipPipPipPipPip
  • 4,945 posts
  • Location:USA
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 28 September 2004 - 07:47 AM

QUOTE (flattspott @ Sep 28 2004, 02:28 AM)


Nope BJ didn't make the cheesy Robo skins... I did laugh.gif
Not to mention that they've been there for quite some time now.

Shows that I haven't been looking carefully enough... Good work, the loading screen absoloutley rocks!

#697 SumDumGuy3

SumDumGuy3

    X-S Young Member

  • Members
  • Pip
  • 53 posts

Posted 02 October 2004 - 11:16 PM

ok, incoming Bug Report

This is a rather simplistic script, but I believe it gathers enough information. This Bug is related to math. I will try to spend some time doing some more comprehensive math function coverage. However I was trying to do some division and ran into some problems. I tried different functions and came out with other problems so I wrote this simple script to gather information about the division functions. This includes using Div, FDiv, Mod, Set Varname (No/No) and Set Varname (No%No). Below is the results and below that is the actual script used.

Edit: I guess I could go ahead and state what is derived from the information below as well... though its pretty obvious from looking at it.

Div Does Not appear to work correctly.
FDiv Does Not appear to work correctly.
Mod Does appear to work correctly.
Set Varname (/) Does appear to work correctly.
and
Set Varname (%) Does appear to work correctly.


Hope this helps

CODE

Div 4  2 is   4
FDiv 4  2 is   4.000000
Mod 4  2 is   0
Set SizeOfDrv (4/2) is  2
Set SizeOfDrv (4Mod2) is  0

Div 5  2 is   4
FDiv 5  2 is   5.000000
Mod 5  2 is   1
Set SizeOfDrv (5/2) is  2.5
Set SizeOfDrv (5Mod2) is  1

Div 2048  1024 is   2048
FDiv 2048  1024 is   2048.000000
Mod 2048  1024 is   0
Set SizeOfDrv (2048/1024) is  2
Set SizeOfDrv (2048Mod1024) is 0

Div 2560  1024 is   2048
FDiv 2560  1024 is   2560.00000
Mod 2560  1024 is   512
Set SizeOfDrv (2560/1024) is  2.500000
Set SizeOfDrv (2560Mod1024) is 512


CODE
Set   SizeOfDrv 4
Div   SizeOfDrv 2
Set   OutPut  "Div 4 2 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 4
FDiv  SizeOfDrv 2
Set   OutPut  "%OutPut%FDiv 4 2 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 4
Mod   SizeOfDrv 2
Set   OutPut  "%OutPut%Mod 4 2 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 4
Set   SizeOfDrv %(SizeOfDrv/2)%
Set   OutPut  "%OutPut%Set SizeOfDrv (4/2) is %SizeOfDrv%$eol$"
Set   SizeOfDrv 4
Set   SizeOfDrv %(SizeOfDrv%2)%
Set   OutPut  "%OutPut%Set SizeOfDrv (4Mod2) is %SizeOfDrv%$eol$$eol$"
Set   SizeOfDrv 5
Div   SizeOfDrv 2
Set   OutPut  "%OutPut%Div 5 2 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 5
FDiv  SizeOfDrv 2
Set   OutPut  "%OutPut%FDiv 5 2 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 5
Mod   SizeOfDrv 2
Set   OutPut  "%OutPut%Mod 5 2 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 5
Set   SizeOfDrv %(SizeOfDrv/2)%
Set   OutPut  "%OutPut%Set SizeOfDrv (5/2) is %SizeOfDrv%$eol$"
Set   SizeOfDrv 5
Set   SizeOfDrv %(SizeOfDrv%2)%
Set   OutPut  "%OutPut%Set SizeOfDrv (5Mod2) is %SizeOfDrv%$eol$$eol$"
Set   SizeOfDrv 2048
Div   SizeOfDrv 1024
Set   OutPut2  "Div 2048 1024 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 2048
FDiv  SizeOfDrv 1024
Set   OutPut2  "%OutPut2%FDiv 2048 1024 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 2048
Mod   SizeOfDrv 1024
Set   OutPut2  "%OutPut2%Mod 2048 1024 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 2048
Set   SizeOfDrv %(SizeOfDrv/1024)%
Set   OutPut2  "%OutPut2%Set SizeOfDrv (2048/1024) is %SizeOfDrv%$eol$"
Set   SizeOfDrv 2048
Set   SizeOfDrv %(SizeOfDrv%1024)%
Set   OutPut2  "%OutPut2%Set SizeOfDrv (2048Mod1024) is %SizeOfDrv%$eol$$eol$"
Set   SizeOfDrv 2560
Div   SizeOfDrv 1024
Set   OutPut2  "%OutPut2%Div 2560 1024 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 2560
FDiv  SizeOfDrv 1024
Set   OutPut2  "%OutPut2%FDiv 2560 1024 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 2560
Mod   SizeOfDrv 1024
Set   OutPut2  "%OutPut2%Mod 2560 1024 is %SizeOfDrv%$eol$"
Set   SizeOfDrv 2560
Set   SizeOfDrv %(SizeOfDrv/1024)%
Set   OutPut2  "%OutPut2%Set SizeOfDrv (2560/1024) is %SizeOfDrv%$eol$"
Set   SizeOfDrv 2560
Set   SizeOfDrv %(SizeOfDrv%1024)%
Set   OutPut2  "%OutPut2%Set SizeOfDrv (2560Mod1024) is %SizeOfDrv%$eol$$eol$"
BeginDraw  UseCurrent
MessageBox  "%OutPut%"
EndDraw
Input
BeginDraw  UseCurrent
MessageBox  "%OutPut2%"
EndDraw
Input


Let me know if there is something more I need to provide to help isolate this one.

Thanks,
SDG

Edited by SumDumGuy3, 02 October 2004 - 11:21 PM.


#698 thetruethugg

thetruethugg

    X-S Expert

  • Members
  • PipPipPip
  • 638 posts
  • Xbox Version:v1.0

Posted 21 October 2004 - 10:34 PM

In the latest WIP (and maybe a few back now that I think about it), MXM always adds the automenu.. I don't use automenu, but MXM appends it to the end of my normal menu, no matter what. It's not that big of a deal, just kind of annoying. Everything is set to 'off' in the system menu for automenu, it's been that way for over a year, never changed, it just started adding the shit sometime, awhile ago, but I never paid any attention to it, then I relized, hey it might be a bug and you should know. wink.gif

I have tried changing it from app & game to drive, which does change it, but it never goes away.

#699 chilin_dude

chilin_dude

    X-S Knowledgebase

  • Members
  • PipPipPipPipPipPipPipPip
  • 4,945 posts
  • Location:USA
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 22 October 2004 - 11:01 AM

QUOTE (thetruethugg @ Oct 21 2004, 10:37 PM)
In the latest WIP (and maybe a few back now that I think about it), MXM always adds the automenu.. I don't use automenu, but MXM appends it to the end of my normal menu, no matter what. It's not that big of a deal, just kind of annoying. Everything is set to 'off' in the system menu for automenu, it's been that way for over a year, never changed, it just started adding the shit sometime, awhile ago, but I never paid any attention to it, then I relized, hey it might be a bug and you should know. wink.gif

I have tried changing it from app & game to drive, which does change it, but it never goes away.

Yes, I too found that out when I tested it.

#700 jlm5151

jlm5151

    X-S Genius

  • Members
  • PipPipPipPip
  • 793 posts
  • Xbox Version:v1.4
  • 360 version:v1 (xenon)

Posted 22 October 2004 - 10:28 PM

Looks like I have catching up to do.... tongue.gif

#701 geniusalz

geniusalz

    Team MXM

  • Head Moderators
  • PipPipPipPipPip
  • 1,827 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 24 October 2004 - 02:26 AM

Welcome back cool.gif

#702 chilin_dude

chilin_dude

    X-S Knowledgebase

  • Members
  • PipPipPipPipPipPipPipPip
  • 4,945 posts
  • Location:USA
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 03 December 2004 - 07:47 PM

*Sings*
Come back....
Baby come back....
wink.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users