Jump to content


Photo

How Do I Get Thumbnails To Work?


  • Please log in to reply
13 replies to this topic

#1 dokworm

dokworm

    X-S Expert

  • Members
  • PipPipPip
  • 744 posts

Posted 12 May 2004 - 09:20 PM

I know everyone will say 'search', but search doesn't work during the hours I have internet access!

I would like to have my icons for movies, and for music come up as the covers of the DVD's or as a screenshot from the film.
In the old days with XBMP, you just had to grab a screenshot - nice and easy. Now I can't work it out at all.
BTW. I don't have internet access available at home where my xbox is

Surely this is something that most people wanna do, and should be *really* easy to do?!?! (I'm hoping it is and that I am just stoopid)

Any help well appreciated. I hven't used XBMC as I had been happy on XBMP, but the latest version looks so sweet, I just gotta get into it.
Thanks

-Worm

#2 ace-of_spades

ace-of_spades

    X-S Senior Member

  • Members
  • PipPip
  • 176 posts
  • Location:CANADA YEAA!

Posted 12 May 2004 - 09:41 PM

For album cover thumbs, put the album cover inside the folder that the songs are in, and name it "folder.jpg". I have no idea how to generate thumbs for movies, so someone else will have to answer that one. And as for pictures just look to the left and there is an option to generate thumbs.

#3 dokworm

dokworm

    X-S Expert

  • Members
  • PipPipPip
  • 744 posts

Posted 12 May 2004 - 10:01 PM

Wow thanks!
(BTW to screenshot a movie you click the left thumbstick I think)
For the albums, that sounds easy enough.

I am confused as what to do with the movies though as they are all in one folder?
So do I name the thumbs the same name as the movie or something???

#4 ace-of_spades

ace-of_spades

    X-S Senior Member

  • Members
  • PipPip
  • 176 posts
  • Location:CANADA YEAA!

Posted 13 May 2004 - 01:11 AM

yea thats the part i dont get, i have no idea where to put the thumbs.... wink.gif

#5 dokworm

dokworm

    X-S Expert

  • Members
  • PipPipPip
  • 744 posts

Posted 14 May 2004 - 03:56 PM

So no one knows huh?

#6 dcnigma

dcnigma

    X-S Expert

  • Members
  • PipPipPip
  • 667 posts
  • Location:Belgium
  • Interests:XBOX-scene ,Dreamcast-scene, mod-scene<br />If you can hack it it interest me
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 14 May 2004 - 09:11 PM

i did that a few times but never found the tumbs


#7 C-5

C-5

    X-S Member

  • Members
  • Pip
  • 119 posts

Posted 15 May 2004 - 01:56 AM

AS long as you can pull the correct movie info from imdb using XBMC, you can follow these simple steps to add the thumbs yourself. If you cannot pull the movie info at all... this will not work.

Also FYI the movie thumbs go in $HOME\thumbs\imdb

- Go to imdb.com and look up the movie
- Copy the imdb number from the address bar... (ie In http://www.imdb.com/title/tt0338526/ ... copy tt0338526)
- right click on the thumb and save as "imdbtt???????.jpg" (ie. imdbtt0338526.jpg)
- ftp that jpg to the $HOME\thumbs\imdb directory. (ie. E:\apps\xbmc\thumbs\imdb\"


I use this same procedure to add thumbs to movies that do not even have thumbs on imdb. You just got to name the thumb file with the correct imdb number.

EDIT - Also, if you "SCAN" for thumbs after ftp'ing thumbs... the scan will delete all that you have manually uploaded. Use white button...

Edited by C-5, 15 May 2004 - 02:00 AM.


#8 dokworm

dokworm

    X-S Expert

  • Members
  • PipPipPip
  • 744 posts

Posted 15 May 2004 - 04:02 AM

Wow , Thanks!
I gotta say that really sucks though. Another example of 'added functionality and ease of use' that actually makes it a whole lot harder to use.

It would be cool to just be able to have a .jpg named the same as the .avi file or whatever and it would pick it up.
I liked the old XBMP feature where a screenshot would automagically make the thumbnail appear - real easy!

I guess I am going to have to mess with the source code and change it. Will wait until they have finished the round of bugfixes on this version and then give it a shot.
Thanks to everyone that responded!

-Worm

#9 dokworm

dokworm

    X-S Expert

  • Members
  • PipPipPip
  • 744 posts

Posted 17 May 2004 - 01:04 AM

So if you don't have an internet connection then you can't have thumbnails???
That sux sad.gif

#10 Toto666

Toto666

    X-S Enthusiast

  • Members
  • 2 posts

Posted 17 May 2004 - 11:32 AM

I found this simple way of adding thumbnails for my video files located on my pc (not xbox). I using samba to play movies located on my with the xbox.
So here it comes :
1 - Get a picture you want as a thumbnail.
2 - Convert it to a 96x96 pixels jpg.
3 - Rename your newly created picture with the name of your video file but with the .tbn extension. (ex: totoro.avi -> totoro.tbn)
4 - Start xbmc and browse to the directory where your video and tbn files are located.
5 - Your video file shoul appear with your thumbnail. Xbmc also copies the thumbnail to its thumbs dir so you don't need the .tbn file anymore.

I don't know if this works if your video files are stored locally on the xbox.

#11 dokworm

dokworm

    X-S Expert

  • Members
  • PipPipPip
  • 744 posts

Posted 17 May 2004 - 09:09 PM

I'll give that a try!

Thanks!

#12 yantao

yantao

    X-S Enthusiast

  • Members
  • 4 posts

Posted 18 May 2004 - 03:56 AM

I remembered the last time when I am using XBMP, it's easier.

1) Mapped the same path for both "Pictures" & "Videos"
2) Start up XBMP & access the "Pictures" folders
3) Use the "Generate Thumbnails" functions for "Pictures" to automatically create the thumbnails for all the images file (*Image must have the same filename as the Video filename)
4) Exit to Menu & access "Videos" folder
5) All the thumbnails for the Videos are done.

But with the recent releases, I am unable to get the thumbnails stored in the "thumbs" folder. I am using the standard "$Home\thumbs" parameters in my xml file. sad.gif

#13 JammDDR

JammDDR

    X-S Member

  • Members
  • Pip
  • 139 posts
  • Xbox Version:v1.3
  • 360 version:v1 (xenon)

Posted 18 May 2004 - 04:06 AM

Upgrade to the 16-05-2004 build. The thumbnail bug has finally been fixed in this build.

#14 yantao

yantao

    X-S Enthusiast

  • Members
  • 4 posts

Posted 18 May 2004 - 05:13 AM

Thanks man. Will try it tonight. biggrin.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users