Jump to content


Photo

The “ultimate Dashboard Exploit” Aka Ude


  • Please log in to reply
1266 replies to this topic

#1261 krayzie

krayzie

    X-S Elysian

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,340 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 26 November 2004 - 11:13 AM

wouldn't it be the same kind of call the kernel makes when the clock is dead and making the xboxdash.xbe(update.xbe) boot like normal? If it doesn't then we might indeed have a problem. Anyone feels like testing?

#1262 berret

berret

    X-S Enthusiast

  • Members
  • 4 posts

Posted 26 November 2004 - 11:23 AM

YES!!!!!!!!!!!!!!!

The first time i've set language "ENGLISH" (if i leave Italian it doesn't work).
After that i would set Italian (but if i change it stop working).


I've solve using 2 "S" file, but there was another prob.
The UDE installer put the files in c root so when i've put s files in folder "fonts" the sistem stop working.
So, i've move also the files bert and arnie in folder "fonts":

fonts\bert.xtf
ernie.xtf
s.xtf
s1.xtf


And all work!!!

#1263 PedrosPad

PedrosPad

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,859 posts
  • Location:UK
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 26 November 2004 - 11:49 AM

QUOTE (krayzie @ Nov 26 2004, 12:16 PM)
wouldn't it be the same kind of call the kernel makes when the clock is dead and making the xboxdash.xbe(update.xbe) boot like normal? If it doesn't then we might indeed have a problem. Anyone feels like testing?

We suspect it's the game xbe on the media in the DVD drive that's performing the check (since it knows how many blocks it needs), and then launching the C:\xboxdash.xbe MS Dashboard. In which case I suspect the C:\xboxdash.xbe would be launched in a memory layout different from that of a BIOS boot (same problem double-dashing had), causing the font exploit to misbehave.

So pop out the media, reboot, and all should be well. But go and free some space on drive E smile.gif.

I don't believe this is a serious issue.

Edited by PedrosPad, 26 November 2004 - 11:52 AM.


#1264 PedrosPad

PedrosPad

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,859 posts
  • Location:UK
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 26 November 2004 - 11:55 AM

QUOTE (berret @ Nov 26 2004, 12:26 PM)
YES!!!!!!!!!!!!!!!

The first time i've set language "ENGLISH" (if i leave Italian it doesn't work).
After that i would set Italian (but if i change it stop working).


I've solve using 2 "S" file, but there was another prob.
The UDE installer put the files in c root so when i've put s files in folder "fonts" the sistem stop working.
So, i've move also the files bert and arnie in folder "fonts":

fonts\bert.xtf
        ernie.xtf
        s.xtf
        s1.xtf


And all work!!!


Yes, the fonts should all be in the same location.

Congrats. beerchug.gif

Edited by PedrosPad, 26 November 2004 - 11:57 AM.


#1265 krayzie

krayzie

    X-S Elysian

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,340 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 26 November 2004 - 03:04 PM

QUOTE (PedrosPad @ Nov 26 2004, 12:52 PM)
We suspect it's the game xbe on the media in the DVD drive that's performing the check (since it knows how many blocks it needs), and then launching the C:\xboxdash.xbe MS Dashboard. In which case I suspect the C:\xboxdash.xbe would be launched in a memory layout different from that of a BIOS boot (same problem double-dashing had), causing the font exploit to misbehave.

So pop out the media, reboot, and all should be well. But go and free some space on drive E smile.gif.

I don't believe this is a serious issue.

I see. If it's in the game itself it isn't a big issue. But indeed nice to know.

#1266 PedrosPad

PedrosPad

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,859 posts
  • Location:UK
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 27 November 2004 - 12:20 AM

QUOTE (PedrosPad @ Nov 26 2004, 11:58 AM)
I took an interesting support IM call the other night that could have an impact on UDE/UXE. The symptom was that the XBOX refused to boot any games (inc. originals), and would only run the MSDashboard (this particular user wasn't using a boot exploit).

At first this sounded like an unset clock, but after eliminating that, we found that it was caused by too few blocks left on the E drive. It would appear that in when E is near full, the user it taken directly to the MSDashboard's GameSav management screen - to encourage you to delete some.

Since UDE/UXE replaces the original C:\xboxdash.xbe MSDashboard I'm unsure how it would react to this. I suspect a continuous reboot, or lock up. But I suspect that if you remove the media, and boot from the HDD all will be well.

This post is just advice in case anyone else experiences this.

I found a few minutes to test this.

I restored the original M$Dash D:5690 (latest), and filled up the E drive.

Booted an original copy of NFL Fever 2003, and after the start up movies, up popped a box saying that not enough blocks were free on the HDD, and press 'A' to enter the Dashboard. I did so (there is no other option), and the MS Dash appeared, conveniently already on the Dashboard GameSav maintenance screen. So this proved the environment.

I then installed UXE, checked it worked, and then again booted NFL Fever 2003. Same screen about too few blocks appeared, except this time when I pressed ‘A’, I simply got a black screen, and the XBOX froze – the anticipated result. Popped the game out of the DVD-tray and rebooted, UXE ran fine, and up came Evox.

So this issue of UXE and a full E drive is something to be aware of, but nothing to be concerned about.

#1267 t0welie

t0welie

    X-S Enthusiast

  • Members
  • 2 posts

Posted 14 December 2004 - 09:49 AM

excuse me for my noobness, but how the heck I can put the xbe file in the E drive when there is no E drive ???? I use HDDdriver, should I use some other program ? Everything else I've done excatly like in the guide, but I can't see no E drive !
PS. Need help ASAP

thx for advance t0welie beerchug.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users