Jump to content


Photo

How Do I Flash My Tsop?


  • Please log in to reply
13 replies to this topic

#1 brankota

brankota

    X-S Enthusiast

  • Members
  • 13 posts

Posted 03 January 2003 - 08:00 AM

I have a v1.1 Xbox and Aladdin modchip (Executer2 4974 bios)

How do I go about flashing my TSOP? Do I just disable the modchip while xbox is running by "cutting" the D0 to disable the mod and using EvoX to flash it?

If I try now with mod on there it gets stuck on "Erasing." stage.

#2 CaliSurfer008

CaliSurfer008

    X-S Knowledgebase

  • Members
  • PipPipPipPipPipPipPipPip
  • 4,458 posts
  • Interests:Brahm is a whore
  • Xbox Version:v1.0

Posted 03 January 2003 - 09:18 AM

1 word: TUTORIALS!

#3 brankota

brankota

    X-S Enthusiast

  • Members
  • 13 posts

Posted 03 January 2003 - 09:34 AM

there is nothing about this type of mod in the tutorials, thats why Im asking here. tongue.gif

Tutorials have guide for matrix and for a homebrew mod, both of which (procedures) are different to aladdin chip.

#4 brankota

brankota

    X-S Enthusiast

  • Members
  • 13 posts

Posted 04 January 2003 - 01:35 AM

Come on, anyone?

Do you know at least how to disable the chip? Will cutting D0 do the trick?

#5 majik655

majik655

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,525 posts
  • Location:Portland, Oregon
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 04 January 2003 - 01:46 AM

uhhh...

Can 1.1 even be TSOP flashed??

I don't think it can yet .

Aaaand if you already tried....and it actually erased it? or even part of it..heh good luck ...hopefully it didn't touch it yet cuz if it did you are screwed and stuck with your chip.

#6 brankota

brankota

    X-S Enthusiast

  • Members
  • 13 posts

Posted 04 January 2003 - 03:06 AM

OK, I tried cutting the D0, and that disables the modchip. I soldered 2 bridges as per flashing TSOP tutorial to enable write access to it. Still gets stuck on Erasing. and sits there forever, it doesnt actualy eraze it.

Um, I believe EvoX D6 bios supports Xbox v1.1 and thats the bios Im trying to flash it with.

#7 brywalker

brywalker

    X-S X-perience

  • Members
  • PipPip
  • 366 posts

Posted 05 January 2003 - 02:23 AM

I don't see why this wouldn't work.

Make sure you are using the right program to flash (NOT EVOX!) and make sure that the chip is completely disabled. IE: completely remove it.

I haven't tried it yet, I am still waiting for my X2L, but logic says there is no difference hardware-wise that would impede the ability to do this.

Edited by brywalker, 05 January 2003 - 02:25 AM.


#8 brankota

brankota

    X-S Enthusiast

  • Members
  • 13 posts

Posted 05 January 2003 - 08:03 AM

um, whats the right program? Why not EvoX?

#9 obiwan

obiwan

    X-S Senior Member

  • Members
  • PipPip
  • 175 posts

Posted 05 January 2003 - 04:38 PM

its been said 100 times up to now

ONLY MATRIX CHIPS CAN FLASH THE TSOP FROM LPC!

I WONT EXPLAIN WHY

LOOK IT UP IN THE FORUMS

#10 brywalker

brywalker

    X-S X-perience

  • Members
  • PipPip
  • 366 posts

Posted 05 January 2003 - 05:44 PM

brankota:

Check your PM.

#11 brankota

brankota

    X-S Enthusiast

  • Members
  • 13 posts

Posted 06 January 2003 - 04:40 AM

QUOTE (obiwan @ Jan 5 2003, 04:38 PM)
its been said 100 times up to now

ONLY MATRIX CHIPS CAN FLASH THE TSOP FROM LPC!

I WONT EXPLAIN WHY

LOOK IT UP IN THE FORUMS

and before the Matrix flash guide was done, everyone KNEW you couldnt flash it with matrix, and long time ago everyone knew earth was flat....

It has to be a way of doing it, the question is how.

#12 Nakor

Nakor

    X-S Expert

  • Members
  • PipPipPip
  • 542 posts
  • Location:Sydney, NSW, Australia

Posted 06 January 2003 - 05:30 AM

To flash from the mod you need to have some form of control on the d0 line. It needs to oscilate at the right frequency. No other mod has this capability.

#13 brywalker

brywalker

    X-S X-perience

  • Members
  • PipPip
  • 366 posts

Posted 06 January 2003 - 07:27 AM

Not flashing from the mod.

Disabling/removing the chip after the software has booted. Therefore the unsigned code is still able to be run, and when running the program the modchip doesn't try to "accept" the flash. It goes right to the TSOP.

Same thing we did with the enigmahs.

Am I alone in the universe here?

Edited by brywalker, 06 January 2003 - 07:27 AM.


#14 Avolo

Avolo

    X-S Enthusiast

  • Members
  • 9 posts

Posted 14 January 2003 - 05:18 PM

Disabling the modchip and then flashing the tsop worked fine with Enigmah since it didn't replace the tsop, it "just" patched selected pieces of the bios in real-time. So when it was disabled you still had the same tsop active (the original one) and could flash it.

Matrix, on the other hand, is an LPC-modchip which disables the original tsop (grounding the d0-line) thereby tricking the xbox to try using the LPC-interface instead (which is probably there for debug-reasons since it clearly says so on the xb motherboard) and if found; the bios will be read from this chip instead.

So; what happens when an LPC-modchip, like Matrix, is disabled after booting EvolutionX with flashing in mind...? Well; nothing...neighter the LPC-chip, nor the original tsop can be accessed causing the "Erasing..."-screen to hang...

At least that is what used to happen before some clever guys designed the evox_matrix-tsop-flash-bios which, by software, enables access to the tsop when the d0-line goes back to normal (thereby disabling the lpc-mod).

What seems to be the problem is that the same clever guys hasn't released a new version of their nice bios so that it can work on v1.1 boxes and that is what me, and presumably a few other guys, are patiently waiting for...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users