Jump to content


Photo

Powers Supply Problem?-please Help


  • Please log in to reply
3 replies to this topic

#1 digby

digby

    X-S Enthusiast

  • Members
  • 1 posts

Posted 25 May 2004 - 05:11 AM

xbox problem
i have a version 1.0 us xbox,which unfortunately i blew the PSU up by forgetting one day to use the step down convertor, bang and puff of smoke !

anyway i ordered a replacement psu from lik-sang (with switchable voltage options) carefully opened the xbox up (what a job!) ,replaced the power supply,plugged it in to the hard drive and motherboard and nothing?,no power at all,no fan or light?

any ideas or has my xbox had it?







#2 opjose

opjose

    X-S Transcendental

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 6,809 posts

Posted 25 May 2004 - 06:01 AM

Start by double checking your work.

Did you forget anything obvious, yellow wire to DVD, etc.

Is the PSU switched properly for your AC?

USUALLY if the supply went from overvoltage, your Xbox SHOULD otherwise be ok.

#3 yigga

yigga

    X-S Senior Member

  • Members
  • PipPip
  • 174 posts

Posted 25 May 2004 - 09:47 AM

QUOTE (digby @ May 25 2004, 07:11 AM)
... i blew the PSU up by forgetting one day to use the step down convertor, bang and puff of smoke ...

ya sure it wasnt the mobo what made the smoke? ohmy.gif

#4 opjose

opjose

    X-S Transcendental

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 6,809 posts

Posted 25 May 2004 - 10:24 AM

QUOTE (yigga @ May 25 2004, 10:47 AM)
ya sure it wasnt the mobo what made the smoke? ohmy.gif

It's possible, but usually the transformer or rectifiers would go first, followed by the regulators, before the the overvoltage gets to the motherboard.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users