Jump to content


Photo

Ux Architect


  • This topic is locked This topic is locked
549 replies to this topic

#1 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 31 May 2004 - 01:12 AM

I would never shamefully ask for a beta of UnleashX, so if any the official beta testers out ther could test my UXArchitect beta, please PM me. I want to make sure I can boast full support for the new UnleashX version.....when released wink.gif

Oh BTW, Ive uploaded my beta to bloodymary's FTP...once I get word, I will PM the people who requested to beta test UXArchitect with the link.

I will not disclose final features or screenshots.....cuz im waiting to add a major feature, im just waiting for "permission" on a huge request I asked of BlazeD. I hope I get the go-ahead.

I will say this.....UX skinning will never be the same.

Hectobleezy

#2 BloodyMary

BloodyMary

    X-S X-perience

  • Members
  • PipPip
  • 357 posts
  • Xbox Version:unk

Posted 31 May 2004 - 01:49 AM

I just spent a half hour messing with this... and let me tell you... this is going to blow the UnleashX skinners we have seen totally away. I have given Hectobleezy the information for the beta testers and hopefully they will have their hands on it within the next day or two...

Too tired for now... I'll just say...

Great job Hectobleezy... beerchug.gif



#3 PaCMaYNE

PaCMaYNE

    X-S X-perience

  • Members
  • PipPip
  • 397 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 31 May 2004 - 02:05 AM

im too anxious,,, enough with the hype,,, now now now now

#4 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 31 May 2004 - 02:24 AM

QUOTE (PaCMaYNE @ May 30 2004, 08:05 PM)
im too anxious,,, enough with the hype,,, now now now now

HAHAHAHHA, ok ok....you got mail.

Bloodymary already reported a bug when trying to "save to disk" im looking into it now.

Before you start skinning.....go to UXSettings and SET & TEST your ftp settings. that unlocks the capability to save to the xbox. I cant stress that enough.

Please report any bugs.

Edited by Hectobleezy, 31 May 2004 - 02:28 AM.


#5 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 31 May 2004 - 02:57 AM

Ok the bug with the saving is this.

C1.C1Zip.dll is in the wrong folder. (this is the file required to zip)

the installer is placing that dll in...

C:\Program Files\Blee Zee Inc\UXArchitect\System

it should be in...

C:\Program Files\Blee Zee Inc\UXArchitect

BTW, make sure you have windows explorer set to view hidden files. C1.C1Zip.dll is set as hidden. just copy it over to the correct folder and you will be fine.

the next beta will have that fixed.

#6 pdottz

pdottz

    X-S Genius

  • Members
  • PipPipPipPip
  • 757 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 31 May 2004 - 03:04 AM

sweet, can't wait to test this.

#7 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 31 May 2004 - 03:07 AM

QUOTE (pdottz @ May 30 2004, 09:04 PM)
sweet, can't wait to test this.

Check your PM

#8 WaRnINg|

WaRnINg|

    X-S Genius

  • Members
  • PipPipPipPip
  • 904 posts
  • Xbox Version:v1.1

Posted 31 May 2004 - 03:15 AM

SO whats up can i try this out..

Ive been waiting for so long and the time has come :-D


#9 pdottz

pdottz

    X-S Genius

  • Members
  • PipPipPipPip
  • 757 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 31 May 2004 - 04:03 AM

Hecto.
should I post bugs here? cause I found one that probably qualifies as a bug.
anyways here it is.

Under the tab -Colors-

-Dialog-

I choose -CAPTION_TEXTCOLOR- and choose the color red. worked fine.
now say I chose -CAPTION_BACKCOLOR- the color picker box still stays red but the -CAPTION_BACKCOLOR- does not change to the color red. you can't tell which item actually is -CAPTION_BACKCOLOR- until you choose another color.

People like me that don't know what all the tags mean might get confused when they don't see the color change and see it as a bug.

I don't know if it was intentional, if it was it wouldn't have to be changed, you could just point it out in the readme. Then again, readme's hardly ever get read. smile.gif

#10 pdottz

pdottz

    X-S Genius

  • Members
  • PipPipPipPip
  • 757 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 31 May 2004 - 04:33 AM

MenuFont and InfoFont get saved in the skin.xml folder with whatever font you choose for each. However, in architect, when you choose a font for MenuFont and then check the box for InfoFont, it stays the same as whatever was choosen for MenuFont and vice versa, but it gets saved separately in the skin.xml ie. Menufont = gothic and InfoFont = arial.

-skins like Electric play previews and show game icons in a circle. cause the image is overlayed with a circle png. can you do this in uxarchitect.

-I made a rectangle using shape. made the rectangle pink so I could see the words I put over it. now when I put say CHIPID and C_FREEMB it makes the pink parts of the rectangle clear. meaning I can see the background image behind it. when I load it with ux 0.310229a the rectangle is completely pink and no part of it is clear and the words show up fine. in short, tongue.gif it shows it wrong in the preview of uxa and it shows it fine on the xbox.

-I started a skin and then went to UXA setting. I couldnt continue working on my skin unless I clicked on NEW. but you already mentioned that in your post hehe so that was my fault.

-after my uxa settings where set I started a new skin and then clicked on UXA settings to see how to up it to my xbox, I didnt upload it and clicked on NEW and uxa crashed.

despite all these little issues, this is one awesome skinner, I was able to complete my skin with it much easier than by hand or the other current skinners currently out.


here's the crash box.

-------
C:\program files\blee zee inc\uxarchitect\temp\furibg.png

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileNotFoundException: C:\Program Files\Blee Zee Inc\UXArchitect\Temp\furibg.png
at System.Drawing.Image.FromFile(String filename, Boolean useEmbeddedColorManagement)
at System.Drawing.Image.FromFile(String filename)
at UXArchitect.Module1.Thumbnail(String& Imga)
at UXArchitect.frmMain.cmbMIV_SelectedIndexChanged(Object sender, EventArgs e)
at System.Windows.Forms.ComboBox.OnSelectedIndexChanged(EventArgs e)
at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value)
at UXArchitect.frmMain.resetcanvas()
at UXArchitect.frmMain.ToolBar_ButtonClick(Object sender, ToolBarButtonClickEventArgs e)
at System.Windows.Forms.ToolBar.OnButtonClick(ToolBarButtonClickEventArgs e)
at System.Windows.Forms.ToolBar.WmReflectCommand(Message& m)
at System.Windows.Forms.ToolBar.WndProc(Message& m)
at System.Windows.Forms.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/MS.net/framework/v1.1.4322/mscorlib.dll
----------------------------------------
UXArchitect
Assembly Version: 1.0.1611.32736
Win32 Version: 1.0.1611.32736
CodeBase: file:///C:/Program%20Files/Blee%20Zee%20Inc/UXArchitect/UXArchitect.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/system.windows.forms/1.0.5000.0__b77a5c561934e089/system.windows.forms.dll
----------------------------------------
System
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/system/1.0.5000.0__b77a5c561934e089/system.dll
----------------------------------------
System.Drawing
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/system.drawing/1.0.5000.0__b03f5f7f11d50a3a/system.drawing.dll
----------------------------------------
MS.VisualBasic
Assembly Version: 7.0.5000.0
Win32 Version: 7.10.3052.4
CodeBase: file:///c:/windows/assembly/gac/MS.visualbasic/7.0.5000.0__b03f5f7f11d50a3a/MS.visualbasic.dll
----------------------------------------
Accessibility
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/accessibility/1.0.5000.0__b03f5f7f11d50a3a/accessibility.dll
----------------------------------------
System.Design
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/system.design/1.0.5000.0__b03f5f7f11d50a3a/system.design.dll
----------------------------------------
System.Xml
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/system.xml/1.0.5000.0__b77a5c561934e089/system.xml.dll
----------------------------------------
C1.C1Zip
Assembly Version: 1.1.20023.5
Win32 Version: 1.1.20032.16
CodeBase: file:///C:/Program%20Files/Blee%20Zee%20Inc/UXArchitect/C1.C1Zip.DLL
----------------------------------------

************** JIT Debugging **************
To enable just in time (JIT) debugging, the config file for this
application or machine (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the machine
rather than being handled by this dialog.

------------------

Edited by pdottz, 31 May 2004 - 04:37 AM.


#11 PaCMaYNE

PaCMaYNE

    X-S X-perience

  • Members
  • PipPip
  • 397 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 31 May 2004 - 04:50 AM

ok i just got it, and after 5 min of looking around,, i just have to say insane work,,

very nicely done as the final will noo doubt be the BEST skinner on UX if not the best skinner i have used yet XB related,, good job,, ill create tonight and report what i find

good job mayne beerchug.gif

they really need more emoticons

#12 unleashx

unleashx

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,330 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 31 May 2004 - 05:06 AM

Where can I get this? smile.gif

#13 koldfuzion

koldfuzion

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,480 posts

Posted 31 May 2004 - 05:14 AM

hehe unleashx asking to be a beta tester? hehehe isnt that full circle!

#14 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 31 May 2004 - 05:18 AM

@pdottz, I thought i squashed that color bug. Thats happening because of the "Colors Theme" feature. it sometimes doesnt display the correct color.....till like you said...you move to another item and then back. I know the exact reason why, I can fix that.

Now about the shapes and text. That is NOT a bug. This is actually an issue with the way VB.NET handles transparent images (.png files) it will show a "fake" transparency...wich means it wont show any picture, shape, text(any control) below it... BUT it will show the main background. unless your a programer, its hard to explain how "child" controls get added to "parent" controls. I guess i can add some code to only drag and drop the labels onto shapes and images. that would illiminate that issue. thats the main reason why the main background video is not enabled.

Yes you can over layother images on top of the icon..but again it will not display correctly on the canvas, but it will display fine on the xbox

about having to press "new" to get out of UXSettings....that button is a toggle button, so simply click on UXsettings again and it will display the other tabs

About the font issues. I tried it on both my computers...and they work fine. i tried flip flopping between custom and normal...eachtime the display the correct font. i will look into it some more....im glad its just a UXA issue and everything ends up fine on the box


now about that "NEW" command. i dont like it. i basicly kill the program and then re-initiallize the whole program(i should have did it better). Ive never had it crash, but it did sum funky things to the labels, textboxes and such. I will run thru the whole thing and do it dfrntly.

I checked that error.
System.IO.FileNotFoundException: C:\Program Files\Blee Zee Inc\UXArchitect\Temp\furibg.png

what where you using furibg.png for? that error means when you selected to either add a custom image or mainbackground it DIDNOT copy the file over...it may have been in use by another program(photoshop maybe) and couldnt get copied. i will add a file check routing to make sure that the file is ther before uploading.......but thats a new one on me..


Thanks for the reports

Edited by Hectobleezy, 31 May 2004 - 05:45 AM.


#15 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 31 May 2004 - 05:26 AM

QUOTE (unleashx @ May 30 2004, 11:06 PM)
Where can I get this? smile.gif

I just sent you a PM, UXArchitect wouldnt exist if it werent for you. Thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users