Jump to content


Photo

I'm Close, Ude, Pbl, What Next....


  • Please log in to reply
5 replies to this topic

#1 wexus6

wexus6

    X-S Enthusiast

  • Members
  • 12 posts

Posted 17 June 2004 - 02:43 PM

I think UDE is working. I'm booting into the PBL 1.4.1 and it asks me to choose a BIOS.
ON /E/BIOS/ I put in 4983.67_noani.bin and renamed it to xboxrom.bin. On the PBL selection screen "xboxrom.bin shows up in 3 different size fonts and I can't scroll them. I choose "a" on the keypad and a couple of lines of text flash by and the screen goes black. I can reboot and do the same. Questions....
1.Does this indicate that I haven't soldered the jumpers corectly?
2.Have I chosen the wrog BIOS?
3.I havn't loaded anything else yet, I was hoping to to load the evox self booting disk after the bios is flashed. Is this a working method or do I need to load evox dash files now before the flash occurs.
4. Is the flash a one time process? or will PBL load up everytime I start the xbox. I hoping to run media center and would like it to boot directly into that.
Thanks for you help.....

#2 Angerwound

Angerwound

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,719 posts
  • Location:Hell
  • Xbox Version:v1.0
  • 360 version:none

Posted 17 June 2004 - 03:00 PM

QUOTE (wexus6 @ Jun 17 2004, 04:43 PM)
1.Does this indicate that I haven't soldered the jumpers corectly?


Can I ask why you soldered anything if you were attempting a softmod?
Soldering is only required if you plan to flash your tsop.

#3 Grospolina

Grospolina

    X-S Expert

  • Members
  • PipPipPip
  • 642 posts
  • Xbox Version:v1.1

Posted 17 June 2004 - 03:01 PM

You've got things confused. Phoenix BIOS Loader does NOT flash your BIOS. It loads a debug BIOS into RAM, which can then be act like a BIOS flash or mod chip.

1. PBL has nothing to do with jumpers, because it doesn't flash the BIOS.
2. You do have the wrong BIOS. PBL needs a BIOS that is bootable-from-media (BFM).
3. You should put your dash in your C: drive. Since you want to use XBMC, you should rename it to C:\avalaunch.xbe ot C:\evoxdash.xbe. Alternatively, you could use XBtool to modify the XBE startup list in the BFM BIOS.
4. PBL will need to run every time you start up.

Check the Checklists in my sig for more pointers.

If you really want to flash the BIOS (which is a one-time thing) instead of using PBL, then you should check the TSOP Flashing forum. This requires the jumpers to be soldered, as well as a flashing program (EvoX or raincoat), and a non-BFM BIOS (do NOT flash a BFM BIOS!).

#4 wexus6

wexus6

    X-S Enthusiast

  • Members
  • 12 posts

Posted 17 June 2004 - 07:17 PM

I've now tried to install 2 different BFM Bios' and neither have worked. They start to boot and stop at the line where it says "deflating 2bl entry point". I think it says "deflating" but I can't read the first word because it's cut off on my TV screen.
The 2 bios' are:
EvoXD6_EjectFix_bfm.bin and X2_4978_BFM.bin

I've renamed both and installed them on E/BIOS/xboxrom.bin
I'm not sure about bios size, does it matter with a BFM?

I also installed on C
evox.ini(edited network settings)
evoxdash.xbe
Bios(folder)<---do these folders go on /C ?
skin(folder)
Trainers(folder)

Do I need to do anything with the RC4 Key?

Everything I can find about flashing the TSOP describes scenerios with mod chips, can I flash the TSOP after launching PBL and EVOX. Will I then (with some setup) be able to boot directly into XBMC?

Thanks again....


#5 krayzie

krayzie

    X-S Elysian

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,340 posts
  • Gender:Male
  • Xbox Version:unk
  • 360 version:unknown

Posted 17 June 2004 - 08:06 PM

yeah you need the rc4 key and eeprom keys. also I thought the folder pbl uses is called bioses and not bios. The bios folder placed on c is used for the bioses evox uses to flash. After you installed the exploit you probably can flash your chip (depending on your bios chip)but there are lots of easier ways to get to evox to flash without pbl. If you want to flash your tsop why don't you head over to the tsop section instead of the exploit section.

#6 Grospolina

Grospolina

    X-S Expert

  • Members
  • PipPipPip
  • 642 posts
  • Xbox Version:v1.1

Posted 17 June 2004 - 08:07 PM

Answers:
- It's "Calculating 2bl entry point"
- Size doesn't matter with BFM. 256KB is fine.
- Your folders seem fine
- You need the correct RC4 key and EEPROM key in your boot.cfg. If they are all 0x00, then they are missing.

And yes, you can flash the TSOP after loading EvoX. You don't even need PBL to do that (just sign evoxdash.xbe, rename it to default.xbe, and install all files to E:\).

However, you still have to know what TSOP you have, and what you can use to flash it:
Sharp (1MB) - special jumper method, raincoat only
Winbond (256KB) - raincoat only
All others - EvoX or raincoat

Of course, you have to have the correct definitions in your evox.ini/raincoat.cfg file.

EvoX and raincoat 0.7 support auto-sizing, so you can supply it with a 256KB BIOS. However, raincoat 0.5 doesn't, so you need the correct size!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users