Jump to content


Photo

Ux Architect


  • Please log in to reply
223 replies to this topic

#1 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 21 June 2004 - 05:19 AM

Ok guys, UX Architect is finally done. I hope it was worth the wait. Get it here.

This is the main limitation of UXA, the preview canvas is not 100% perfect. This is a vb.net limitation. I will continue to work on this.

Also, I didnt finish the tool tips. The option to turn it on and off is ther, however I disabled the code till im done with all the docs.

Edited by Hectobleezy, 21 June 2004 - 07:38 AM.


#2 vintage_guitar

vintage_guitar

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,441 posts
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 21 June 2004 - 05:48 AM

when you use Item editor, and try to change the size or location, you must highlight the number and backspace to delete it, as opposed to just pushing it. And it claims there is a problem with all of my skin.xml files, even though there isn't

Edited by vintage_guitar, 21 June 2004 - 05:48 AM.


#3 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 21 June 2004 - 06:00 AM

QUOTE (vintage_guitar @ Jun 20 2004, 11:48 PM)
when you use Item editor, and try to change the size or location, you must highlight the number and backspace to delete it, as opposed to just pushing it. And it claims there is a problem with all of my skin.xml files, even though there isn't

I had to block out the textboxes so only numbers could be added. you can also click on the coordinates then use your "+" and "-" buttons on your keyboard to adjust.

The importer will never be 100% perfect. Ive had people send me skin.xml's files, telling me that uxa wont read it, that it is a good file. Everytime ther was a problem with the skin. I tested almost every skin out ther. I could sit here and go down the list of all the jacked up skins out ther. Skins made with notepad are the worst. Importing releashed skins should work.

Shit. sumthing tells me the bug reports are gonna come rolling in.

#4 G3iST

G3iST

    X-S Enthusiast

  • Members
  • 27 posts

Posted 21 June 2004 - 06:06 AM

is it possible to have a blue version??

#5 vintage_guitar

vintage_guitar

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,441 posts
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 21 June 2004 - 06:07 AM

When you set the size of an object, (say a round box), if you immidiately set the size to numbers(Before you manually resize it), it will be blurred weirdly , and you must manually rezise it, THEN put in the numbers for it to appear correctly. I don't know if it is just appearance on the editor or if it would really blurr the object.

Hey man if there's alot of bugs, oh well, this is the FIRST public release, and no other skinner comes close. It's already the best skinner I've used. Very professional! Even an installer

Edited by vintage_guitar, 21 June 2004 - 06:11 AM.


#6 vintage_guitar

vintage_guitar

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,441 posts
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 21 June 2004 - 06:07 AM

QUOTE (G3iST @ Jun 21 2004, 02:06 AM)
is it possible to have a blue version??

what are you talking about

#7 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 21 June 2004 - 06:11 AM

QUOTE (vintage_guitar @ Jun 20 2004, 11:48 PM)
when you use Item editor, and try to change the size or location, you must highlight the number and backspace to delete it, as opposed to just pushing it. And it claims there is a problem with all of my skin.xml files, even though there isn't

I found the import bug. It has to do with the loading screen image. If your importing a skin that uses a loading screen, it wont crash, if you import a skin without a loading screen image or if the skin.xml points to an image thats not included with the zip...CRASH.

#8 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 21 June 2004 - 06:13 AM

QUOTE (vintage_guitar @ Jun 21 2004, 12:07 AM)
When you set the size of an object, (say a round box), if you immidiately set the size to numbers(Before you manually resize it), it will be blurred weirdly , and you must manually rezise it, THEN put in the numbers for it to appear correctly. I don't know if it is just appearance on the editor or if it would really blurr the object.

Hey man if there's alot of bugs, oh well, this is the FIRST public release, and no other skinner comes close. It's already the best skinner I've used. Very professional! Even an installer

I mess with the images in memory, however the main image is never touched in anyway. Its a display issue.

I checked your report. Its nuthing serious. Let me explain. Shapes are not drawn on the canvas. I first create a bitmap(in memory) draw the shape onto it and then display it. I make UXA redraw that bitmap when you resize it so it looks right. With the coordinates, Im not redrawing the shape, Its simply "stretching" the image. Again this is nuthing serious, as it will show up perfect on your xbox. I already fixed it. Once the UXA website is running, then any updates will be available ther.

Edited by Hectobleezy, 21 June 2004 - 06:20 AM.


#9 vintage_guitar

vintage_guitar

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,441 posts
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 21 June 2004 - 06:23 AM

when i export a file as a zip..it claims it is corrupt, and doesn't work, however, the project is all there in it's entirety when i export unzipped, and works

#10 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 21 June 2004 - 06:34 AM

QUOTE (vintage_guitar @ Jun 21 2004, 12:07 AM)
Hey man if there's alot of bugs, oh well, this is the FIRST public release, and no other skinner comes close. It's already the best skinner I've used. Very professional! Even an installer

Thanks. I worked hard. But I know I will never please everyone. I expect UXA and myself to get bashed hard.

All I can say is that UXA is free, Im not making any money from this. If people like it, then cool. If people dont like, then ask for a refund. biggrin.gif

#11 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 21 June 2004 - 06:35 AM

QUOTE (vintage_guitar @ Jun 21 2004, 12:23 AM)
when i export a file as a zip..it claims it is corrupt, and doesn't work, however, the project is all there in it's entirety when i export unzipped, and works

so the zip is corrupt?

#12 vintage_guitar

vintage_guitar

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,441 posts
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 21 June 2004 - 06:49 AM

QUOTE (Hectobleezy @ Jun 21 2004, 02:35 AM)
so the zip is corrupt?

Winzip 9.0 wouldn't open the file..however WinRar did, BUT it's missing 1 file. The ORB picture i put in the project.

#13 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 21 June 2004 - 07:02 AM

QUOTE (vintage_guitar @ Jun 21 2004, 12:49 AM)
it's missing 1 file. The ORB picture i put in the project.

Holly shit, I can beleive that I and my testers didnt catch that one. Just an FYI, it wont copy over the globe either. Its fixed now

Once Argoyle has the site going. I will post an update. Thats an urgent one.

About the zip, Im still using winzip 8.1, but the zip dll is a comercial quality dll. I dont know if ComponentOne has an update to work with winzip 9........

thanks vintage_guitar for helping, I appreciate it.

#14 vintage_guitar

vintage_guitar

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,441 posts
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 21 June 2004 - 07:08 AM

no problem.. and as i was saving my projects(As *.UXA)..it never copied the ORB picture either, and gave me an error upon opening(every single time). also..when i load up the XML for the file i created from scratch with this program..the visual items i put it aren't showing up..like..IP..and DATE/TIME..and they ARE in the XML..weird..as well as reversing the order of my "Free Menu Items" from 1-2-3-4-5 in vertical ascending order..too 5-4-3-2-1 descending order..weird..

Edited by vintage_guitar, 21 June 2004 - 07:18 AM.


#15 Hectobleezy

Hectobleezy

    X-S X-perience

  • Members
  • PipPip
  • 452 posts

Posted 21 June 2004 - 07:18 AM

QUOTE (vintage_guitar @ Jun 21 2004, 01:08 AM)
the visual items i put it aren't showing up..like..IP..and DATE/TIME..and they ARE in the XML..weird..as well as reversing the order of my "Free Menu Items" from 1-2-3-4-5 in vertical ascending order..too 5-4-3-2-1 descending order..weird

You might have accidently hid them when adding an image. click on the image and select "send to back". Try not to use large images. the "electric" skin is a good example of what not to do, most of its images are 640x480, thats a waste of space and xbox resources. Use smaller images if possible.

About the free menu, that should work. it may write them in reverse order on the xml, but when loaded onto the xbox, it works (i just tried it)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users