Jump to content


Photo

Kegsx Current Discussion


  • This topic is locked This topic is locked
5 replies to this topic

#1 XPort

XPort

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,873 posts
  • Xbox Version:unk

Posted 28 August 2004 - 06:11 PM

This is the main discussion thread for the most recent version of KegsX.

Use this thread to do any of the following:

Ask a question about KegsX
Report a bug about KegsX
Submit a feature request for KegsX

Do not use this thread to post about projects other than KegsX.
Do not post questions/bug reports/feature requests without first reading the FAQs for KegsX.
Do not ask where these projects can be downloaded.

Rule violators will get one warning. After that, you will be temporarily or permanently banned depending on the situation. I'm sorry if that sounds harsh, but it has taken me a cumulatively long time to write the FAQs for these projects. If you cannot do me the courtesy of taking the time to read them, then I do not want you posting here.

This thread will be pruned/cleaned periodically. If you had a question in this thread and it is now gone, then it was either in violation of the rules or your answer can now be found in the FAQs section.


#2 iphopper

iphopper

    X-S Enthusiast

  • Members
  • 26 posts

Posted 02 September 2004 - 09:30 PM

gotta question for ya xport. or anyone else that might know something.

kegsx has been awesome for me. plays oregon trail just fine, as well as other .bin files.

though, it has yet to play any .dsk for me. in particular, i'm talking about other MECC titles in the vain of oregon trail, like number munchers, odell lake and other edutainment titles.

i see on some screenies on the xport site that dsk images are listed and i assume work. i've tested my .dsk files in other apple emus for pc, and seem to run ok (i mainly use applewin).

does kegsx indeed support dsk, just not the ones i have? or do i need to do something to configure kegsx to play these files?

thanks
ip


oh...Fuckin great work so far xport, keep it up biggrin.gif

#3 andysmile

andysmile

    X-S Enthusiast

  • Members
  • 1 posts

Posted 15 September 2004 - 07:12 AM

I am using KegsX to run my written old-school's program in Basic by Apple II.

I find that after running for a while, it breaks and prompts an out of memory error in line no. xxxx.

I have used AppleWin in PC to run the same program and no error is found.

Would you advise how to solve the problem?

Regards

Andysmile

#4 IronChefAmerica

IronChefAmerica

    X-S Enthusiast

  • Members
  • 11 posts

Posted 23 September 2004 - 06:10 PM

I've been trying to two weeks to get consistent USB mouse support, and have not been able. I'm using a MS USB mouse (not a Ps2-USB converter) plugged inot the controller port. Some games it works fine (Sea Strike), some games it is not recognized (Tass Times), and a lot of games, the mouse gives erratic performance (Zany Golf).

Additionally, joystick support seems similarily flawed when it comes to directional control.

I've dug through all the FAQs, Docs and readmes. I've played with every conceivable setting.

Is this a known glitch in the emulator, or is there a better way to get consistent performance from the input devices?

#5 slumberpod77

slumberpod77

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,478 posts
  • Location:Portland, Oregon
  • Interests:music, music, music, computers, audio engineering, gaming, code monkeying, music again
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 04 January 2005 - 11:32 AM

hey man, this one is a real trip down memory lane!

i wanted to point out one thing i found troublesome and also request a feature.
lemme first clarify. my family has/had an Apple IIC, and so that's what i was looking to play in emulated form recently. having already been familiar with the many other Xport projects, i decided to give the port of KEGs a shot. being unfamilair with the IIGS, i wasn't up on how to get it to boot IIC/IIE stuff. apparently going back to the original IIGS, you have to go into the system Control Panel to the Slots menu and set the system to boot from a 5.25" slot and then put your disks in that slot to get them to auto-run properly. if you don't do this, you'll be starring at the ] prompt trying to remember your DOS 3.3 commands like i was at first. this little tidbit seems to be the key to get KEGs to run the old IIC and IIE .dsk files. once i set the system to boot Slot 6 all the time, i was able to run just about every game i tried, with the usual Xport nice interface to boot smile.gif

the only constructive criticism i had was in the manner the graphics are rendered. specifically, it seems like your emulator throws up blue on regions of the screen which have no signal/no color. i'm not sure if that's part of the IIGS itself, something you're debugging, or intentional, but i gotta say, a lot of the old text games are really hard on the eyes with white text on a blue background. i figure you might be able to put an option to have these regions rendered as black to make the whole thing more old-school friendly.
i haven't tried USB stuff or running my System 6 harddisk image yet, but i'll give them a go soon...
Xport rules! you know, thanks to you, we barely ever play actual Xbox games on our Xbox smile.gif

#6 oregono

oregono

    X-S Enthusiast

  • Members
  • 7 posts

Posted 01 April 2006 - 08:25 AM

awsome work man. Im looking forward to playing number munchers.

My question is about running a game. I have switched my nm game to use :slot 6 as noted in the readme. when i go to run the game however, i get a screen "check startup device". Where can i change the startup device?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users