Jump to content


Photo

Winuaex Current Discussion


  • This topic is locked This topic is locked
129 replies to this topic

#1 XPort

XPort

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,873 posts
  • Xbox Version:unk

Posted 28 August 2004 - 06:14 PM

This is the main discussion thread for the most recent version of WinUAEX.

Use this thread to do any of the following:

Ask a question about WinUAEX
Report a bug about WinUAEX
Submit a feature request for WinUAEX

Do not use this thread to post about projects other than WinUAEX.
Do not post questions/bug reports/feature requests without first reading the FAQs for WinUAEX.
Do not ask where these projects can be downloaded.

Rule violators will get one warning. After that, you will be temporarily or permanently banned depending on the situation. I'm sorry if that sounds harsh, but it has taken me a cumulatively long time to write the FAQs for these projects. If you cannot do me the courtesy of taking the time to read them, then I do not want you posting here.

This thread will be pruned/cleaned periodically. If you had a question in this thread and it is now gone, then it was either in violation of the rules or your answer can now be found in the FAQs section.


#2 XPort

XPort

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,873 posts
  • Xbox Version:unk

Posted 01 November 2004 - 03:17 PM

WinUAEX Amiga Emulator port for XBox v8

What's New:

- Support for 2 mice

- Can assign any mouse/joystick to either L/R analog stick

- Settings are now saved when you launch real CDs

- Will switch to PAL50/PAL60 mode for PAL users depending on if you have
selected PAL50/PAL60 from the Game Configuration menu. No effect for NTSC
users.

- Upload/Download configurations to/from xport.xbox-scene.com via GUI



==============================
Upload/Download Configurations
==============================

This is a new GUI feature that allows you to share your configuration files with
the rest of the world.

At the time of this version, there are only a few configuration files available
on the website. Once you have a game tweaked and working well, please take a few
moments to upload the configuration. This is as simple as selecting the "Upload"
option on the Game Configuration menu. Downloading a configuration can be
accomplished in very much the same manner by selecting the "Download" option.

When uploading a configuration please use a name that is as descriptive as possible.
For example, if the version you are using is AGA, please note it. If the version
you are using is cracked by a specific group, please note that as well.


Stella, Gnuboy, SMSPlus, FCEUltra, HUGO, NeoPop, DGen, Bochs, HUGO-CD,
FMSXBox, Bliss, WinSTon, Gens, Z26X, StepmaniaX, PCSXBox, XBoyAdvance,
DOSXBox, AtariXLBox, MirrorMagicX, KoboX, MaelstromX, MarblesX, Vice64X,
Vice20X, VicePETX, KegsX, XPired, AdamX, WonderSwanX, BeatsOfRageX,
PowermangaX, LynxBox, BlueMSXBox, GladiatorX, AmphetamineX, StarfighterX,
PachiX, BlobWarsX, OdysseyX, ArnoldX, X68000X, WinUAEX
what's next?

Enjoy!


#3 kvajnto

kvajnto

    X-S Expert

  • Members
  • PipPipPip
  • 593 posts

Posted 02 November 2004 - 02:12 AM

Thanks for the update.

A minor problem though. When I try change software filter by pressing right thumb -> video settings -> software filter (or whatever it is =)) and then press B a few times to return to the game, I still have the settings menu on my screen. I can control the game, but there is no video. When changing back to no filter it runs fine again. Something similar happends in dosxbox, although not exactly the same. I don't see the settings menu, but the screen gets all messed up. I admit that I have a very few games to test though (giana sisters on winuaex and skyroads on dosxbox to be exakt =)).

I tried changing the filters in pcsxbox too, but I didn't have any trouble there (only tried raiden project and SOTN though).

#4 kimota2004

kimota2004

    X-S X-perience

  • Members
  • PipPip
  • 368 posts
  • Location:UK
  • Xbox Version:v1.6
  • 360 version:none

Posted 02 November 2004 - 06:27 PM

Thanks a lot for the update XPort. love.gif

I believe the problem you're having there with the software filters not working is because they don't exist. XPort had to remove them due to the memory restrictions I think.




#5 kvajnto

kvajnto

    X-S Expert

  • Members
  • PipPipPip
  • 593 posts

Posted 02 November 2004 - 06:51 PM

Oh. Okay. That explains quite a bit =)

#6 Tanas

Tanas

    X-S X-perience

  • Members
  • PipPip
  • 304 posts

Posted 03 November 2004 - 02:32 AM

Thanks for the update.

It would be really nice to see the bug fixed in the CD32 emulation, where the screen stays black and all you can hear is the music.

#7 w4tcher

w4tcher

    X-S Enthusiast

  • Members
  • 20 posts

Posted 03 November 2004 - 06:26 PM

where Exactly is this feature "Upload/Download configurations to/from xport.xbox-scene.com via GUI" I cant seem to find it anywhere sad.gif.

Oh yeah nice work wink.gif

#8 gotodengo

gotodengo

    X-S Enthusiast

  • Members
  • 12 posts

Posted 07 November 2004 - 01:48 AM

I rarely post and usually stay on-topic and concise. Tonight however, I'm gonna ramble. I want to thank you guys, whoever ported WinUAE to the Xbox. I'll thank the guys who did the original WinUAE somtime when I go to their site. I haven't even installed it yet but I just know how jazzed I'm gonna be when I do. See I just got finished installing Slayer's 2.6 auto-intaller and lots of Xbox games. Slayer's project is just phenomenal. So are all the apps included. EvoltionX? Avalaunch? Awesome. Other tools like SimpleXISO too. Just awesome.

Then I got to MAMEoX. Whoa. Holy Cow. Nearly the entire history of gaming at my fingertips -- like being able to play with all the exhibits at the Smithsonian Institution. Then I got to NeoGenesis. More of the same. Hard to believe the artistry that went in to creating these packages. I'm just guessing WinUAEX is gonna be the same and it'll be really nice for me. I can't wait to see the Amiga games from Psygnosis that I haven't seen in 10 years.

I was an officer in the USAF in 1990 when I got my first personal computer. It was the era of 386s (just prior to the introducition of the 486) and I had something most people had never heard of: An Amiga 3000. It came with a 32-bit operating system, pre-emptive mulitasking, plug and play (MS hadn't coined that term yet though), and an on board bus-mastering SCSI controller. It had a logical, fast GUI with a quick and powerful command line interface and a version of REXX for inter-process communication. My collection of goodies included paint, 3-D modeling, image capture, animation overlaying live video, and music composition software ... at home ... on a lieutenant's pay. This was not something you could do in the i386 world at the time.

Then I'd get up in the morning and go to work. Windows 3.1. I think brain-dead is the right word. Unfortunately, the engineers that created the Amiga hardware and OS (Google for Jay Miner, the Amiga's inventor if you're interested), had been acquired by a brain-dead company. Commodore Business Machines, in decline from their Commodore 64 and 128 days, was at the mercy of two money-grubbing suits (I think their names were Irving Gould and Mehdi Ali), totally lacking tech-savy, who put all their effort into building crappy Wintel machines that drove the company to bankruptcy. They hauled cash out of the company at a rate far exceeding that of Apple's top execs (who ran a much bigger company) putting almost nothing into advertising for the Amiga.

Enough rambling. My point is this. I can't believe everyone doesn't have a modded Xbox. I guess it's a good thing because there might be a much stronger attempt to prevent people running unsigned code if more people knew about its capabilities. It's the nature of digital technology to give us the entire history of gaming on one box and it's a new thing. Humans often have a hard time with change. Be ready for further assaults on your freedom to run code of your choice on machines of your choice in the coming years. The cure for 1984 is 1776. I wish I made that up but I saw it on Slashdot. Thanks again for WinUAEX.

Edited by gotodengo, 07 November 2004 - 02:24 AM.


#9 pagancow

pagancow

    X-S Young Member

  • Members
  • Pip
  • 41 posts

Posted 07 November 2004 - 06:49 PM

I'm having a configuration issue. I cannot push any buttons or anything (only analog stick works in my emu)


Edit : n/m I found the problem (Config not stored in Udata Tdata)

I would add this to the FAQ.


Edited by pagancow, 07 November 2004 - 08:20 PM.


#10 BornSlippy

BornSlippy

    X-S Enthusiast

  • Members
  • 11 posts

Posted 20 November 2004 - 03:34 PM

I'm having a little trouble with WinUAEX and maybe you guys can help.

I'm using roms that are on DVD(pretty much every amiga game split between about 4-5 DVDs)anyway they are in folders (e.g A,B,C...you get the idea).The actual emulator is on the Xbox.Well about half of the games are fine and run perfectly but some just dont run and just come up the startup screen(hand with disk or disk inserting), I have tried running these from my comp using uaex and fellow and they run fine.Its whole letters like all the N's (gutted I cant play newzealand story mad.gif ).

So any ideas what I can do to fix this? Can you tell me where WinUAEX files go so I can wipe them ALL and start again?

Cheers

smile.gif

#11 kimota2004

kimota2004

    X-S X-perience

  • Members
  • PipPip
  • 368 posts
  • Location:UK
  • Xbox Version:v1.6
  • 360 version:none

Posted 20 November 2004 - 04:07 PM

I think the problem you are having is because you are breaking the file limit for the Xbox. It can only store a certain amount of games in a folder 2500 or something, so the only way would be to limit the amont of games per folder. I may be wrong, but at least I suggested something wink.gif

edit: Also note that some characters (eg. , # + [] ) arn't compatible with the xbox's file system so if any of your games have these in their titles they wont run. That it definetly the case for running games of the hardrive, im unsure what the situation is with playing games from DVD, but I assume it's the same.

Edited by kimota2004, 20 November 2004 - 04:11 PM.


#12 kimota2004

kimota2004

    X-S X-perience

  • Members
  • PipPip
  • 368 posts
  • Location:UK
  • Xbox Version:v1.6
  • 360 version:none

Posted 20 November 2004 - 04:30 PM

Also gotodengo, that was a nice post, I enjoyed reading that cheers! wink.gif beerchug.gif

#13 BornSlippy

BornSlippy

    X-S Enthusiast

  • Members
  • 11 posts

Posted 21 November 2004 - 03:20 AM

QUOTE (kimota2004 @ Nov 20 2004, 05:10 PM)
I think the problem you are having is because you are breaking the file limit for the Xbox. It can only store a certain amount of games in a folder 2500 or something, so the only way would be to limit the amont of games per folder. I may be wrong, but at least I suggested something wink.gif

edit: Also note that some characters (eg. , # + [] ) arn't compatible with the xbox's file system so if any of your games have these in their titles they wont run. That it definetly the case for running games of the hardrive, im unsure what the situation is with playing games from DVD, but I assume it's the same.

Cool thanks I 'll split them up a bit more an see if that helps.

#14 matsan

matsan

    X-S Enthusiast

  • Members
  • 1 posts

Posted 23 December 2004 - 11:52 AM

I donīt get the emulator towork with any game at all. It hangs up when on the loading screen after pressing B when Iīm finished with my configuration. It hangs up even if theres no disks loaded. What could be wrong? Please help

#15 fil

fil

    X-S Member

  • Members
  • Pip
  • 67 posts

Posted 23 December 2004 - 11:59 PM

one small problem with flicker filter

the flicker filter level changes when switching between pal50 and pal60

if you look closely level 1 on flicker filter on pal50 equals about level 2 on pal60

level 0 is too much on pal50, but just right on pal60

i like to have my setting on level 1 in pal50, but when running in pal60 its not quite enough and i have to keep switching to level 0

it's probably common on other emulators, but they generally run in 60hz all the time, so doesnt matter

winuae most games are best in 50hz but some games are better in 60hz, so thats where the issue comes in

this would be great if it could be addressed





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users