Jump to content


Photo

Networking With Osx


  • Please log in to reply
16 replies to this topic

#1 SomeCanuck

SomeCanuck

    X-S Enthusiast

  • Members
  • 4 posts

Posted 15 November 2004 - 06:38 PM

I just got XBMC installed (the latest as of yesterday) and everything i stream from my Windows PCs is just peachy. But I have a lot of stuff stored on an old G3 running OSX, when I try to launch anything (movies, pictures, whatever) I get an error something like "NT_ERROR_NOT_A_DIRECTORY".

It's like XBMC thinks the file is a folder and can't open it. ANy suggestions? I need the Mac around for other reasons and besides it has huge hard drive space in it. I'm running DAVE on it so it also networks with my PCs just fine.

SomeCanuck



#2 SomeCanuck

SomeCanuck

    X-S Enthusiast

  • Members
  • 4 posts

Posted 16 November 2004 - 12:38 AM

bump

#3 A@ron

A@ron

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,380 posts
  • Xbox Version:unk

Posted 16 November 2004 - 02:29 AM

use share points

#4 ZildjianKX

ZildjianKX

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,048 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 16 November 2004 - 06:22 AM

QUOTE (A@ron @ Nov 15 2004, 06:32 PM)
use share points

Well said. That shit should be built into OS X.

#5 SomeCanuck

SomeCanuck

    X-S Enthusiast

  • Members
  • 4 posts

Posted 17 November 2004 - 04:25 AM

Share Point? Help me out here. I've looked through DAVE and OSX help for something called Share Points. If you mean to simply share out the right directories ive done that too.

My PCs see and use the Mac just fine. They even print through it. But Im still at a loss for getting my XBox to open files from the OSX box. Again, it sees everything, it just cant open them.

Thanks again.



#6 Rodimus04

Rodimus04

    X-S Enthusiast

  • Members
  • 9 posts

Posted 17 November 2004 - 04:53 AM

Well I may not be able to completely answer your problem but I think I can get you pointed in the right direction. Check out XBMSX at macupdate.com. I have just recently installed XMC but have been XMP for a while. You should look at configuring XMC file. XMP was a .xml file. It needs to know exactly where to look. XBMSX is the setup on your Mac for sharing. Dave was a nice program but I have found it no longer necessary with the current version of OS X (10.3). Good luck and I hope that helps.

#7 A@ron

A@ron

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,380 posts
  • Xbox Version:unk

Posted 17 November 2004 - 05:28 AM

behold what google found; the most amazing search tool on the net wink.gif

http://www.hornware.com/sharepoints/

it's easy to set up, so easy... post with any problems and make sure you click the allow windows guests checkbox

#8 SomeCanuck

SomeCanuck

    X-S Enthusiast

  • Members
  • 4 posts

Posted 19 November 2004 - 04:08 PM

OK I upgraded to OS 10.3, and installed SharePoints. But I still have the same problem.

I added several shares in SharePoint and the XBox can see them, but again can either not enter the directory (which is new) or can not open a simple jpg (or anything else).

I cant find anythign further in the help. Any suggestions?



#9 frankle1

frankle1

    X-S Enthusiast

  • Members
  • 8 posts

Posted 21 November 2004 - 08:17 PM

I am doing the same thing- what I did was to use Sharepoints to share my iTunes and iPhoto folders in OSX as SMB shares. Sharepoints only changes permissions on the top level folder, so once you share the folder with sharepoints, locate that folder in the Finder, choose 'get info' (apple-i) and then under ownerships and permissions hit the 'apply to enclosed items' button.

I did this and XBMC seemed to have no problem browsing these folders.

Hope it helps.

#10 NickFury

NickFury

    X-S Young Member

  • Members
  • Pip
  • 42 posts

Posted 21 November 2004 - 08:26 PM

QUOTE (frankle1 @ Nov 21 2004, 09:20 PM)
I am doing the same thing- what I did was to use Sharepoints to share my iTunes and iPhoto folders in OSX as SMB shares. Sharepoints only changes permissions on the top level folder, so once you share the folder with sharepoints, locate that folder in the Finder, choose 'get info' (apple-i) and then under ownerships and permissions hit the 'apply to enclosed items' button.

I did this and XBMC seemed to have no problem browsing these folders.

Hope it helps.

Yes you have to make sure your Username is also in the filesharing wheel. If you dont know what that is, use google and learn about user permisions inside a Unix enviroment. Also, this is an easy way to do it too, open the properties of the top most folder for you share, change your persmisions for it to include "anyone" and make sure you click on the little check box that says "include in subfolders" or wahtever it says, im trying to go off memory here. This way makes your system a little unsecure from a Unix standpoint of security, but chances are you will absolutly fine. Just remember that once you chage the permissions of the folders, you cant change them back. But if you do it this way too, any other user on your system can also see those folders.

That error your also getting to could be casued by your computer name. My computer name used to be "The mac (OSX Samba)" and XBMC didnt like that, so I changed it something easy like "theMac" and all works great!

Nick

#11 seven5

seven5

    X-S Senior Member

  • Members
  • PipPip
  • 211 posts
  • Location:Richmond, Va
  • Xbox Version:v1.0

Posted 22 November 2004 - 04:30 AM

This is a sticky. Believe it or not, they work well and 99/100 questions are solved with them.

FIND IT HERE

#12 A@ron

A@ron

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,380 posts
  • Xbox Version:unk

Posted 22 November 2004 - 07:12 AM

also why the hell are you using sharepoints to share mp3s when XBMC can access iTunes shares?

#13 prezet

prezet

    X-S Young Member

  • Members
  • Pip
  • 31 posts

Posted 22 November 2004 - 09:12 AM

I'm trying to get it to work with XBMSX and it just won't do anything!

I have altered the XBMC config .xml file to point towards my mac at it's correct IP address (issued by the DHCP server) and still get nothing. I'm running a straight through cable from the xbox to the mac and then airporting out to the router.

anyone got any ideas?

XBMC .xml files looks like this:

<music>
.....

<bookmark>
<name>PowerBook G4</name>
<path>xns://192.168.0.2:1400/</path>
</bookmark>

.....
</music>

XBMSX on the mac has my username, group: admin, port: 1400, debug: 0
shared: /Users/leepowell/Music/iTunes
logs: /Users/leepowell/Library/Logs/xbms.log
PID: /Users/leepowell/Library/Logs/xbms.pid

whenever I select Powerbook G4 from the XBMC list it can't see anything??!

#14 Machard

Machard

    X-S Enthusiast

  • Members
  • 2 posts

Posted 03 February 2005 - 10:07 PM

QUOTE
<music>
.....
   
    <bookmark>
<name>PowerBook G4</name>
<path>xns://192.168.0.2:1400/</path>
</bookmark>
   
.....
  </music> 

XBMSX on the mac has my username, group: admin, port: 1400, debug: 0
shared: /Users/leepowell/Music/iTunes
logs: /Users/leepowell/Library/Logs/xbms.log
PID: /Users/leepowell/Library/Logs/xbms.pid

whenever I select Powerbook G4 from the XBMC list it can't see anything??!

View Post



has nothing to do with XBMSX...

You need to share your iTunes music folder via the Preferences in iTunes. Make sure you open port 3689 in your firewall (System Preferences -> Sharing)

and change your xml to read:

<bookmark>
<name>PowerBook G4</name>
<path>daap://192.168.0.2:3689/</path>
</bookmark>

You actually might not need the :3689 part. I think it's the default port for the daap protocol.

Edited by Machard, 03 February 2005 - 10:13 PM.


#15 aHorseofCourse

aHorseofCourse

    X-S Young Member

  • Members
  • Pip
  • 37 posts

Posted 03 February 2005 - 10:59 PM

If all you want to do is stream, there's no need to mess around with SMB shares. Just use xBmsx, a Mac OS X front end for the XBMC streaming server. It works very well and it's a breeze to set up. Get it here: http://www.versiontr...fo/macosx/21259
Seriously, it installs as a preference pane, you pick a directory to share and the Xbox picks it right up. Try it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users