Jump to content


Photo

Access Denied Using Xbox Media Centre


  • Please log in to reply
8 replies to this topic

#1 tomthecabinboy

tomthecabinboy

    X-S Enthusiast

  • Members
  • 4 posts

Posted 20 November 2004 - 04:39 PM

Hey All

I am trying to connect my XBox using XBox media Centre to my PC so I can watch some movies I have, stored on the PC Hard disk. When I try, I can see the workgroup, and I can see my PC (The Name of it). When I press "A" on my PC-name, there is a pause then I get the error message "Access Denied". I can gwt no further.

I am able to connect from my PC to MY xbox using ANY tools or an FTP client. My Firewall is configured to allow full access using all ip's within my IP range. Also I have enable file and print sharing. I have even tried with the firewall disabled.
I have made shares on my PC with permissions set to everyone.

Any suggestions please, I have run out of ideas? Is it access rights?

Thanks in advance

Tom blink.gif



#2 JayDee

JayDee

    X-S Legend

  • Head Moderators
  • PipPipPipPipPipPipPipPipPip
  • 5,750 posts
  • Gender:Male
  • Location:Sweden
  • Xbox Version:v1.1
  • 360 version:v2 (zephyr)

Posted 20 November 2004 - 04:40 PM

checked the guides in the pinned topic?

#3 tomthecabinboy

tomthecabinboy

    X-S Enthusiast

  • Members
  • 4 posts

Posted 20 November 2004 - 05:23 PM

Erm

I think SO.

Which guide did you have in mind? One of the guides had a link to http://www.xboxmediacenter.com/. Which does seem pretty helpful.

BUT it looks like I have tried most things. I am sure it is something so obvious I have missed.

All the things I have done so far are in my original post.

Any help would be appreciated as its doing mi nut in. I have been working on it for a few weeks now.

Thanks

Tom

#4 nickgailloux

nickgailloux

    X-S Young Member

  • Members
  • Pip
  • 38 posts

Posted 20 November 2004 - 09:59 PM

There are two ways to enable access. One, the easiest, is to enable the guest account in Windows, which allows you to connect to the share without a password. The other is to use a password, either with the default password or specify it in the bookmark in your XboxMediaCenter.xml file.

Defualt:

QUOTE
<!-- defaultusername  defaultpassword: the username and password that      !-->
    <!--            will used if none is specified in bookmark                !-->
    <!--            Usefull for samba browsing. Will fallback to guest access  !-->
    <!--            if it can't                                                !-->
    <samba>
        <workgroup>WORKGROUP</workgroup>
        <winsserver>-</winsserver>
        <debuglevel>0</debuglevel>
        <defaultusername />
        <defaultpassword />
    </samba>


Bookmark:

QUOTE
<!-- you can use the following formats: !-->
            <!-- smb://domain;user:password@ip/share/directory/ !-->
            <!-- smb://user:password@ip/share/ !-->
            <!-- if guest/public access is enabled: !-->
            <!-- smb://ip/ !-->
            <path>smb://WORKGROUP;Login Name:Password@Computer NetBIOS Name/Share Path/</path>


#5 tomthecabinboy

tomthecabinboy

    X-S Enthusiast

  • Members
  • 4 posts

Posted 21 November 2004 - 11:50 AM

QUOTE (nickgailloux @ Nov 20 2004, 11:02 PM)
There are two ways to enable access. One, the easiest, is to enable the guest account in Windows, which allows you to connect to the share without a password. The other is to use a password, either with the default password or specify it in the bookmark in your XboxMediaCenter.xml file.

Defualt:

   

Bookmark:


Hi Nick

Thanks ever so much for your response. biggrin.gif As you can probably tell I am not a wiz with the XBox manipulation so I am sorry if I sound like a bozo!!

BUT I have enabled my guest logon, in fact I am even speciffically added the guest user to my share saying Full control etc etc.

NO JOY sad.gif

I have had a look at my XBox media centre.xml file. I haev found the section you said in the <samba> section.

I will be honest I wasnt too sure what to do then. I changed :

<workgroup>WORKGROUP</workgroup>
<winsserver>-</winsserver>
<debuglevel>0</debuglevel>
<defaultusername>-</defaultusername>
<defaultpassword>-</defaultpassword>


The above highlighted words to a proper username and password. Is that correct??
Because when I reloaded the media centre it crashed, with errors. The only way to get it working was to return it back to its original state.

Like I said SORRY for missing the obvious, but what am I actually ammending it to?

Thanks in advance

Tom

Edited by tomthecabinboy, 21 November 2004 - 11:51 AM.


#6 disaster

disaster

    X-S Member

  • Members
  • Pip
  • 124 posts

Posted 21 November 2004 - 11:56 AM

Thought I might chime in, I get the same problem time to time as well. Haven't ever pinned it down but it's always straightened itself out.

Anyways, as far as giving guest access full control I wouldn't advise that, give read only control and you'll be better off.

#7 tomthecabinboy

tomthecabinboy

    X-S Enthusiast

  • Members
  • 4 posts

Posted 21 November 2004 - 12:16 PM

Hey No worries about Chiming in smile.gif. Chime away!! smile.gif The more the merrier.

The only reason why I gave full access was that I read one article about media centre wanting full control so I gave it.

I have not been able to connect at all. "Time to time" would be nice.
I just want to be able to connect and play all mi files, mp3's and piccies.

I know its not a connectivity thing as I can connect the other way from my PC to my xbox. I deffo thing NICK is on the right track but I just need to get the syntax right. He seems to be much more knowledgeable than me

Thanks again

Tom

#8 nickgailloux

nickgailloux

    X-S Young Member

  • Members
  • Pip
  • 38 posts

Posted 22 November 2004 - 01:19 AM

Tom,

The easiest and most secure way to do what you want would be to make a bookmark. To do this, leave the:

QUOTE
<workgroup>WORKGROUP</workgroup>
<winsserver>-</winsserver>
<debuglevel>0</debuglevel>
<defaultusername>-</defaultusername>
<defaultpassword>-</defaultpassword>


part alone for now and head to the music section. Mine looks like this:

QUOTE
<music>
    <default />
    <bookmark>
        <name>My Music on Delta-021</name>
        <path>smb://WORKGROUP;Nick Gailloux:thisismypassword@Delta-021/My Music/</path>
    </bookmark>


As you can see, my workgroup's name is "WORKGROUP", my login name is "Nick Gailloux", my password is "thisismypassword", my computer name is "Delta-021", and the path to my share is "/My Music". Of course this isnt my real password smile.gif Also, you can use your computer's IP address instead of its name. I would suggest using its name though, because your IP address can change from time to time and this can become a hassle. I also use two connections (Wired and wireless) and using the computer name means it will work with both.

So just add a bookmark in using this syntax:

QUOTE
    <bookmark>
        <name>My Music on Delta-021</name>
        <path>smb://WORKGROUP;Nick Gailloux:thisismypassword@Delta-021/My Music/</path>
    </bookmark>


and change the values which apply to your computer. Should work!

#9 RocafellaSqualie

RocafellaSqualie

    X-S Expert

  • Members
  • PipPipPip
  • 660 posts
  • Location:Delaware, USA
  • Xbox Version:v1.6
  • 360 version:v3.0 (falcon)

Posted 22 November 2004 - 05:30 AM

Another share type you can use is this kind (example of my config):

For viewing my Pictures PC:

<bookmark>
<name>Photos on My Computer</name>
<path>smb://Systemax/Photo Album</path>
</bookmark>


For listening to Music:

<bookmark>
<name>Music on My Computer</name>
<path>smb://Systemax/Music Jukebox</path>
</bookmark>


For watching Movies:

<bookmark>
<name>05 - Movies On My Computer</name>
<path>smb://Systemax/Video Library</path>
</bookmark>

Make sure you have "sharing & security" plus "Share this folder on the network" enabled on the folder you want to use with XBMC

in the xml, make a bookmark & add:
<path>smb://Your Computer Name Here/Folder Share Name Here</path>

Hope this helps ya smile.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users