Jump to content


Photo

X2:pro Review; X2 Pogo-pins Review + Guide


  • Please log in to reply
9 replies to this topic

#1 Skitals

Skitals

    X-S Member

  • Members
  • Pip
  • 121 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 14 February 2003 - 05:51 PM

Thought you guys might be interested in my reviews... an X2:Lite review is to follow soon.

http://www.xemulatio...hp?op=view&t=14
X-ecuter 2 Pro Review

http://www.xemulatio...hp?op=view&t=12
X-ecuter 2 Pogo-Pin Adaptor Review

http://www.xemulatio...hp?op=view&t=13
X-ecuter 2 Pogo-Pin Adaptor Guide

Peace

#2 Tripamang

Tripamang

    X-S Expert

  • Members
  • PipPipPip
  • 523 posts

Posted 14 February 2003 - 07:16 PM

oo nice pics...

#3 BenJeremy

BenJeremy

    X-S Elysian

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,690 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 14 February 2003 - 07:20 PM

Did the pogos come with the tape across the back like that?

#4 Skitals

Skitals

    X-S Member

  • Members
  • Pip
  • 121 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 14 February 2003 - 07:25 PM

Yeah, the pogo-pins came with the tape. Im guessing it was just to protect them in shipping because they ship the screw and everything in the same foam baggy.

#5 BenJeremy

BenJeremy

    X-S Elysian

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,690 posts
  • Gender:Male
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 14 February 2003 - 07:36 PM

QUOTE (Skitals @ Feb 14 2003, 03:25 PM)
Yeah, the pogo-pins came with the tape. Im guessing it was just to protect them in shipping because they ship the screw and everything in the same foam baggy.

I'm thinking it's because there's an issue with the bottom of the socket potentiallly coming into contact with something on motherboard.

It's possible these people having issues with the pogopins have removed this tape and while mounting the adapter, pressed/adjusted while the power was on.

Just a thought.

#6 Skitals

Skitals

    X-S Member

  • Members
  • Pip
  • 121 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 14 February 2003 - 07:45 PM

I removed the tape on mine... just cause I wanted to see what was on the pcb. I had no problem getting it working.

#7 NEC3354

NEC3354

    X-S Enthusiast

  • Members
  • 19 posts

Posted 15 February 2003 - 04:47 AM

Great post Skittals; thanx for the llink- esp the first one - it clears a few ??s up for me.

#8 Skitals

Skitals

    X-S Member

  • Members
  • Pip
  • 121 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 16 February 2003 - 01:08 AM

Im glad you guys like the articles... they took hours ph34r.gif I took nearly 100 pics and picked the best ones.

#9 ZildjianKX

ZildjianKX

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,048 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 16 February 2003 - 06:02 AM

Very nice reviews indeed, and I completely agree with them from my experience smile.gif

#10 Tripamang

Tripamang

    X-S Expert

  • Members
  • PipPipPip
  • 523 posts

Posted 16 February 2003 - 06:16 AM

now do a wire/header pin version! =)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users