Jump to content


Photo

Cant Turn Off Ftp Server


  • Please log in to reply
11 replies to this topic

#1 invictus2

invictus2

    X-S Enthusiast

  • Members
  • 8 posts

Posted 11 December 2004 - 06:52 PM

I want to disable the ftp server on my xbox, but when I disable it from the avalaunch menus, I can still connect from my PC. Is the ftp enable/disable option in avalaunch settings broken, or is it just my xbox that is difficult?

Also; is there any way to disable the possibility for another xbox to connect directly to my xbox and leech files?

#2 Trevante

Trevante

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,929 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 11 December 2004 - 07:14 PM

QUOTE
I want to disable the ftp server on my xbox, but when I disable it from the avalaunch menus, I can still connect from my PC. Is the ftp enable/disable option in avalaunch settings broken, or is it just my xbox that is difficult?


Try editing the avalaunch.xml.

Change

CODE
ftpserver enabled="1"


to

CODE
ftpserver enabled="0"


QUOTE
Also; is there any way to disable the possibility for another xbox to connect directly to my xbox and leech files?


That's why you're disabling the FTP server. Once that's off, there's no other way for any other device to connect to your Xbox, unless maybe you run another dashboard or app that enables an ftp server.

Edited by Trevante, 11 December 2004 - 07:14 PM.


#3 invictus2

invictus2

    X-S Enthusiast

  • Members
  • 8 posts

Posted 11 December 2004 - 07:21 PM

QUOTE
<ftpserver enabled="0" allowboostmode="1" showrootfreespace="0">
  <port>
  21
  </port>
  <pasvportstart>
  2048
  </pasvportstart>
  <pasvportend>
  32767
  </pasvportend>
  <maxusers>
  2
  </maxusers>
</ftpserver>


This is how my avalaunch.xml file looks like, but still the ftp server is enables with the user/pass combination that is set later in the file.

Also, my other question is because my friend can connect to my xbox from his xbox without typing in the password.

#4 Trevante

Trevante

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,929 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 11 December 2004 - 08:06 PM

hmmmm... try changing

network setup="1"

to

network setup="0"

And are you rebooting after saving these changes?

#5 invictus2

invictus2

    X-S Enthusiast

  • Members
  • 8 posts

Posted 11 December 2004 - 09:30 PM

Yes I am rebooting after I have changed the settings.

I have changed network setup to "0" now, but the ftp server is still up & running.

Edited by invictus2, 11 December 2004 - 09:35 PM.


#6 bernienoel

bernienoel

    X-S Young Member

  • Members
  • Pip
  • 43 posts
  • Xbox Version:v1.0

Posted 11 December 2004 - 09:42 PM

QUOTE (invictus2 @ Dec 11 2004, 09:33 PM)
I have changed network setup to "0" now, but the ftp server is still up & running.

i can't belive you're editing the right file


#7 invictus2

invictus2

    X-S Enthusiast

  • Members
  • 8 posts

Posted 11 December 2004 - 10:56 PM

When I change other settings like the ftps password and disable the newsfeed it works so I suppose its the correct file I am editing. Its the C:\avalaunch.xml

For your information: I have Xbox 1.6 crystal, and using the latest avalaunch. However; I had the same problems with the previous release of avalaunch as well. This may or may not matter, but the ftp server in XBMC can be turned on and off without this kind of trouble. (A friend of mine has the same xbox with the same software and he has the same problem).

Edited by invictus2, 11 December 2004 - 11:06 PM.


#8 invictus2

invictus2

    X-S Enthusiast

  • Members
  • 8 posts

Posted 12 December 2004 - 01:20 AM

I couldnt edit my last reply so I just create another one:

May this be a bug in avalaunch/bios/somethingelse so that I should report it somewhere? As this happens to both me and my friend it could happen to someone else as well.

#9 Trevante

Trevante

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,929 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 12 December 2004 - 01:21 AM

Hmmm...

well I was able to turn off network access in avalaunch.

Edit your avalaunch.xml so that it doesn't set up the network or start the ftp server (those two settings I told you to change in my previous posts), then go settings>network>IP settings> and make sure network is changed to disabled

After doing this, I no longer had network access and couldn't connect through ftp, so I think this should work.

#10 time_trial

time_trial

    X-S Enthusiast

  • Members
  • 17 posts

Posted 12 December 2004 - 10:30 AM

Do you have a mod chip with an ftp server? Maybe that's giving you ftp access.

#11 Trevante

Trevante

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,929 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 12 December 2004 - 06:24 PM

I doubt that could be it. I believe the modchip's ftp server is only running when you're in the modchip's built in OS.

#12 invictus2

invictus2

    X-S Enthusiast

  • Members
  • 8 posts

Posted 12 December 2004 - 07:36 PM

QUOTE (Trevante @ Dec 12 2004, 02:24 AM)
Hmmm...

well I was able to turn off network access in avalaunch.

Edit your avalaunch.xml so that it doesn't set up the network or start the ftp server (those two settings I told you to change in my previous posts), then go settings>network>IP settings> and make sure network is changed to disabled

After doing this, I no longer had network access and couldn't connect through ftp, so I think this should work.

It wasnt disabled when I did network setup="0", however when I just disabled the network from the menus, it worked. when I re-enabled the network, the ftp was still the same.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users