Jump to content


Photo

Kotor 2 - Offical Fix Post


  • Please log in to reply
54 replies to this topic

#1 shakaru

shakaru

    X-S X-perience

  • Members
  • PipPip
  • 355 posts
  • Xbox Version:v1.6
  • 360 version:v1 (xenon)

Posted 22 December 2004 - 05:43 PM

Because there has been many theories and "Fixes" for the KOTOR 2 T3 Blackness problem, I decided to post things that ARE garented to work as well as a few that might.

TSR Mode - WORKS
For Evox users, just follow these easy steps.
1) Go into you Settings tab on the Evox Dashboard and find the option for TSR. Set this to Debug (Not normal unlike many thought) Save, restart evox and then open Kotor 2.
2) get to the part right before you access the terminal that opens the administration level before the cut scene and save.
3) In IE type "Telnet:100.100.100.100". The 100's are obviously for your xboxs ip.
4) Then type in the new window that poped up "FR" but do not hit enter. You are doing this to get ready for a quick shot.
5) Now do the whole terminal thing and right as T3 gets zapped and the screen starts to fade, hit ENTER on your keyboard. You xbox should freeze.
6) Next on telnet just type "UF" for un freeze and the game should continue on and autosave and load the next part.
Your timing is all important as for the window of opertunity is short. If it dosent work, go back and try again. Took me 2 trys for this.

Sith Lords Video - Could not get to work
This has been reported to work but despite my efforts, I could not get it to. You still may try.
1) Save right before you use the terminal that T3 gets zapped after and the blackness happends.
2) Then press START on the keypad and goto QUIT. It will ask you if you want to quit and just say yes.
3) Then you will see the main menu with "Self Mutalation Boy". Goto Movies and select the "Sith Lords Trailer". Its just that wierd advert you see for the game you just bought and are playing. Watch the video or go play it and make a hotdog or something.
4) Come back and load the save game.
(THIS HAS ONLY BEEN RUMORED TO WORK)

Save game swap - Tried a few, got nothing
I personally think this should work, but I couldnt get it to with the save games availble and I didnt like the fact I would be playing someone's elses Jedi with a new name.
1) Find a KOTOR 2 save game file. (There are a few out there, but all were currupted when i tried them. Dont know why)
2) Either FTP or use action replay to install the save game. Now this shouldnt erase your game because in KOTOR 2 they allow multiple character saves. However if it works, you can only use the save you downloaded and is past this point.
3) When you go to load the save, press the X key to load other characters. Load the correct save after the blackness and your done but without your jedi.

Clear cache - DOES NOT WORK
I wont even say how to do this, it does not work at all on 3 diffrent boxes tried.


Personally I have never had the TSR mode fail once I perfected the process. I know it may seem difficult reading for thoese who never used telnet, but its really simple. Give it a shot, i can almost garentee it will work, and if it dosent, its beause of your timing and try again.

If anyone has any other methods, post em here and Ill give them a test or two on a few of my boxes and add them to the post.

#2 JWJ

JWJ

    X-S Expert

  • Dev/Contributor
  • PipPipPip
  • 621 posts
  • Location:Taylorsville, Kentucky
  • Interests:Playing xbox games and football
  • Xbox Version:v1.1

Posted 22 December 2004 - 06:38 PM

Did you try using MooGUI to make a optimized iso that worked great for me

#3 Nitr0

Nitr0

    X-S Enthusiast

  • Members
  • 23 posts

Posted 03 January 2005 - 02:33 AM

I don't get it. I enabled debug mode. Telnet is set to on. I can FTP into my xbox but if I attempt to telnet in it just says
MS Telnet> o
( to ) 192.168.0.2
Connecting To 192.168.0.2...Could not open connection to the host, on port 23: C
onnect failed


What's going on on this side?

#4 Nitr0

Nitr0

    X-S Enthusiast

  • Members
  • 23 posts

Posted 03 January 2005 - 02:45 AM

Never mind. When I installed my update to ZoneAlarm I forgot to restart and it was blocking the basic ports. A restart fixed that smile.gif

#5 Nitr0

Nitr0

    X-S Enthusiast

  • Members
  • 23 posts

Posted 03 January 2005 - 03:19 AM

Alas. A new problem has come up. The telnet method successfully worked for me, but now when I play, I'm getting jittering and slowdowns whenever characters speak and when I'm just running around. I erased the cache folder on Z and this works for the first time I load it but just returns to the jittering the second time I load.

#6 samoyeds_4life

samoyeds_4life

    X-S Member

  • Members
  • Pip
  • 95 posts

Posted 03 January 2005 - 11:38 PM

I just saved the game at the terminal, went to main menu, watched the game trailer, then loaded the game.

#7 bruder_s

bruder_s

    X-S Enthusiast

  • Members
  • 26 posts

Posted 05 January 2005 - 12:11 AM

I don't know if this is only possible for me, but after the screen went black I could still use the menu - saved the game and just reloaded it and then I could continue smile.gif

#8 bruder_s

bruder_s

    X-S Enthusiast

  • Members
  • 26 posts

Posted 05 January 2005 - 12:31 AM

Sorry, I was too fast - I could run around with my character but when I wanted to go back to where T3 came from, I was T3 again and stuck there...

But finally, the telnet-method worked for me smile.gif

#9 rook177

rook177

    X-S Enthusiast

  • Members
  • 4 posts

Posted 05 January 2005 - 10:30 PM

For some reason I can't get the telnet to connect to my xbox at any point other than when it's on the main screen. The second I start the game it disconnects, and I can't connect in game... What am I doing wrong?

#10 hellsingalucard

hellsingalucard

    X-S Enthusiast

  • Members
  • 7 posts

Posted 06 January 2005 - 12:14 AM

yeah i can't play KOTOR 2 off the hard drive or even the original game disc without getting dirty disk errors...i've repeatedly deleted the cache on xyz and e: and have tried other games. it doesn't freeze after the part everyone else is stuck at, i'm near the end of the game..none of my saves will load, even those from way earlier...what could the problem be?

#11 Rip3001

Rip3001

    X-S Enthusiast

  • Members
  • 5 posts

Posted 06 January 2005 - 02:00 AM

QUOTE(Nitr0 @ Jan 3 2005, 03:50 AM)
Alas. A new problem has come up.  The telnet method successfully worked for me, but now when I play, I'm getting jittering and slowdowns whenever characters speak and when I'm just running around. I erased the cache folder on Z and this works for the first time I load it but just returns to the jittering the second time I load.

View Post



I had the same problem pop up after I loaded up my game the day after. I tried reverting all the things I had done in previous attempts (modifying .ini stuff) to the originals, but that didn't work. However here's what I did to get mine working again. I'm not sure which part of it was key or if it'll act up again later...

1) I turned TSR back to "disabled" in the Evox settings and rebooted.
2) I loaded KOTOR 2 and went into the Movies sections and watched the Sith Lords trailer and let it play through.
3) I then loaded my game and it's running smoothly.

Hopefully it won't act up again, but if it does, then running the movie before plying might do the trick...I'm not sure.

#12 GaTechPimp

GaTechPimp

    X-S Enthusiast

  • Members
  • 24 posts

Posted 06 January 2005 - 05:42 AM

I cant even get the game to load when I turn TSR on for some reason!!

Help

#13 bumbi

bumbi

    X-S Enthusiast

  • Members
  • 5 posts

Posted 08 January 2005 - 10:35 PM

I got the telenet way to work the second time, I did it like 0.1 sec after he got hit.

The first time when I didn't get it to work I pressed start wen everything was black and saved the game then I loaded the save and started as the guy but where the droide just was blink.gif

#14 mitchy

mitchy

    X-S Member

  • Members
  • Pip
  • 67 posts
  • Location:Michigan
  • Xbox Version:v1.6

Posted 09 January 2005 - 12:11 AM

I did the save/re-load method, and I started where the guy was, but as the disabled droid, so I couldn't do anything. Thankfully, the telnet procedure worked perfectly.

#15 trentwinters

trentwinters

    X-S Enthusiast

  • Members
  • 3 posts

Posted 14 January 2005 - 04:47 AM

go go telnet! thanks a lot for the advice, man. i thought i had this problem licked until i noticed that for some reason my main character had just taken the droid's place... your method worked perfectly




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users