Jump to content


Photo

Nexgen V2.0.0 Alpha Nye Bugs & Suggestions


  • Please log in to reply
11 replies to this topic

#1 TMaul

TMaul

    X-S Senior Member

  • Members
  • PipPip
  • 230 posts
  • Location:Over there --->
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 31 December 2004 - 02:45 PM

Known bugs and suggestions moved over from previous thread, before it had to be deleted due to overzealous and slightly paranoid moderating:

need reboot and shutdown option on the menu.

Also enable DHCP by default in XML (will save a lot of hassle)

have a menu item to clean Nexgen cache cause on first startup

need to change the app title id from 00000000

need to do a bit of debugging on the dvd drive launching code, currently has problems lauching dvds

need to find out how to make the cache consitantly go wrong so it can be fixed a bit

remote control compatablity

Settings menu



---

Happy new year, you beetches. smile.gif

#2 wyrp

wyrp

    X-S Enthusiast

  • Members
  • 13 posts

Posted 01 January 2005 - 07:21 AM

Suggestions:

1. Remove extremely time consuming "Nexgen" load screen.
2. Fix it so it doesn't freeze on above mentioned load screen 4 of 5 boots
3. Re-style look and function like M$ dash (like v1 did, but do it better) and not a cross-breed of Ava and Evox.
4. Add configurable settings in the settings menu (instead of being empty)
5. M$ style Game Saves menu
6. M$ style Music menu


#3 TMaul

TMaul

    X-S Senior Member

  • Members
  • PipPip
  • 230 posts
  • Location:Over there --->
  • Xbox Version:v1.2
  • 360 version:v1 (xenon)

Posted 01 January 2005 - 12:29 PM

QUOTE(wyrp @ Jan 1 2005, 07:52 AM)
Suggestions:

1. Remove extremely time consuming "Nexgen" load screen.
2. Fix it so it doesn't freeze on above mentioned load screen 4 of 5 boots
3. Re-style look and function like M$ dash (like v1 did, but do it better) and not a cross-breed of Ava and Evox.
4. Add configurable settings in the settings menu (instead of being empty)
5. M$ style Game Saves menu
6. M$ style Music menu

View Post




1. We can remove the load screen but it will still take just as long to load.
2. Please post your config.xml and xbox specs as this sounds like a bug somewhere else
3. This is down to the skin, not the dash. Expect to start seeing a few 3d style skins in the future
4. being worked on
5. A save game manager is being worked on
6. An audio player is also being worked on

#4 HoRnEyDvL

HoRnEyDvL

    Nexgen Developer

  • Members
  • PipPipPipPip
  • 903 posts
  • Location:Australia
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 01 January 2005 - 01:05 PM

I find a bug kev & i believe i have tracked it down to the network init code.
When im doing something & i IGR back 2 nexgen it takes longer 2 load once it finaly loads looks like its frozen but its actually loading message comes up at the bottom saying no rss feed connection found.

#5 x_sasakue_x

x_sasakue_x

    X-S Young Member

  • Members
  • Pip
  • 57 posts
  • Location:North Carolina, USA
  • Xbox Version:v1.0
  • 360 version:none

Posted 01 January 2005 - 03:37 PM

yes on the rss feed pre-alpha i was getting some freezes

#6 unleashx

unleashx

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,330 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 01 January 2005 - 05:14 PM

I finally got a chance to take a look at this tonight and well, it worked right off the bat. Kudos, guys. Here are some things I found though:

1) Loading time is too long. A little over 15 sec on mine with 14 titles.
2) Using the default skin (Nice port from Dunny's Console UI), when I'm in Application submenu, it shows up to 8 items. When I'm in my games sub menu with 4 titles, it only shows 3 and scrolling all the way down doesn't work. What it does is it brings the whole menu one item down, but still displaying only the first 3 items.
3) When changing skin, the menu goes back to the top level. It should stay in the Skins menu.
4) Using the default skin (btw, why is it the default, what happened to MS look? I particularly liked that one and would love to see it again head in that direction.), the box on top of the menu doesn't show anything. Isn't it supposed to show the game icon?
5) BGM volume seems to fade in and out in a constant rythm.

Title ID should be changed to anything other than 000..., another homebrew is also using this ID. Also, patch the xbe so it doesn't have the debug flag. I know this could cause some problems with some bios.


I tested it using the xml that came with the distro.

#7 bucko

bucko

    Super Moderator

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPip
  • 7,996 posts
  • Gender:Male
  • Location:England
  • Xbox Version:v1.6
  • 360 version:v5.0 (360S - trinity)

Posted 01 January 2005 - 06:35 PM

QUOTE
4) Using the default skin (btw, why is it the default, what happened to MS look?


Well I think there was some problems with the 3D skins, it's being worked on now.

QUOTE
I find a bug kev & i believe i have tracked it down to the network init code.
When im doing something & i IGR back 2 nexgen it takes longer 2 load once it finaly loads looks like its frozen but its actually loading message comes up at the bottom saying no rss feed connection found.


I left my Xbox on for 1 hour and 20 minutes and RSS is still running fine. I connect to Zen ADSL (UK) via a Draytek Vigor 2500 ADSL Router.

My Xbox is a 1.1 with Xenium and the bios used to load nexgen was Evox M8plus.

Congrats on a superb dash! I love it!



#8 HoRnEyDvL

HoRnEyDvL

    Nexgen Developer

  • Members
  • PipPipPipPip
  • 903 posts
  • Location:Australia
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 01 January 2005 - 10:18 PM

Hey unleashx its great that u gave our dash a try.
Yeah theres is afew things that need 2 be sorted out but we getting there were also trying 2 adjust to teh whole 2d side of things tongue.gif.

I hope u dont mind that we used the default skin from unleash x. We are not trying to rip of unleashx in any ways.
Our M$ dash look skin is been worked on it just abit hard as u prob seen the lua has all changed.

Hopefully we will have the tittle id fixed & a new release fixed.
Title image should be finished.
Havent figured out how we can keep the menu positions usings lua as u can prob see it restartes the render state each time. if it didnot it leak.

Edited by HoRnEyDvL, 01 January 2005 - 11:06 PM.


#9 HoRnEyDvL

HoRnEyDvL

    Nexgen Developer

  • Members
  • PipPipPipPip
  • 903 posts
  • Location:Australia
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 04 January 2005 - 10:13 AM

kev take a quick look over rss feed again there is a lil nasty in there.

Edited by HoRnEyDvL, 04 January 2005 - 10:41 AM.


#10 HoRnEyDvL

HoRnEyDvL

    Nexgen Developer

  • Members
  • PipPipPipPip
  • 903 posts
  • Location:Australia
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 21 February 2005 - 02:10 AM

yeah found anotehr bug , Wheres the new beta release tongue.gif


#11 bucko

bucko

    Super Moderator

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPip
  • 7,996 posts
  • Gender:Male
  • Location:England
  • Xbox Version:v1.6
  • 360 version:v5.0 (360S - trinity)

Posted 21 February 2005 - 04:42 PM

eh?

#12 bucko

bucko

    Super Moderator

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPip
  • 7,996 posts
  • Gender:Male
  • Location:England
  • Xbox Version:v1.6
  • 360 version:v5.0 (360S - trinity)

Posted 30 April 2007 - 12:13 AM

Unpinning, linked to Important Topics thread.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users