Jump to content


Photo

Filebrowser And Autorun


  • Please log in to reply
5 replies to this topic

#1 ACARiD

ACARiD

    X-S Enthusiast

  • Members
  • 5 posts
  • Xbox Version:v1.0

Posted 04 January 2005 - 07:24 AM

Hey.

When I go into the filebrowser/handling section, I can't seem to find any button that will take me out of it. Hitting "B" makes the "B" in the skin glow, but the menu will not revert back to the previous one. Only solution seems to be manual reboot.

I have a DVD-modded box, with a flashed Samsung PC DVD reader installed to be able to read all media. When I open and close the tray without having any media in it, and the autorun function at "ask", the dash says there's an unknown media inserted, even though the tray is empty.

#2 LiketHc

LiketHc

    X-S Enthusiast

  • Members
  • 28 posts
  • Xbox Version:none
  • 360 version:none

Posted 04 January 2005 - 11:13 AM

QUOTE(ACARiD @ Jan 4 2005, 07:55 AM)
Hey.

When I go into the filebrowser/handling section, I can't seem to find any button that will take me out of it. Hitting "B" makes the "B" in the skin glow, but the menu will not revert back to the previous one. Only solution seems to be manual reboot.

View Post



You have to "collapse" the directories to the root level first on both sides of the browser. Then "B" will bring you out of it.

Maybe that's still a bug!?? wink.gif

Greetz liktHc.


#3 ACARiD

ACARiD

    X-S Enthusiast

  • Members
  • 5 posts
  • Xbox Version:v1.0

Posted 05 January 2005 - 10:45 AM

Well, yes. That I would consider a "bug", if not a very bad feature.
I, and I'm probably not alone, would preferr to have the "BACK" button to get out of the filebrowser immediately. Using "START" and "BACK" for BG musik volume change seems like a waste of good controlbuttons.

Would be better to have the right analog stick for volumecontrol, like XBMC do. That stick is not used for anything else in here right now anyways.

The bug with getting a "Unknown Media. would you like to try executing?" when I open my DVD tray (even when it's empty) is constant. Anyone else have this problem with a box that has a swapped DVD drive?

It should be mentioned that no other Dashboards I've tried get "media triggered" by opening the tray.

#4 Mr. Me

Mr. Me

    X-S Member

  • Members
  • Pip
  • 135 posts

Posted 05 January 2005 - 04:07 PM

I have the same problem with my samsung 616t dvd drive. There's got to be a way to make it take no action when an "unrecognized" disk has been entered, or better yet fix it so it doesn't get media triggered every time.

#5 Mr. Me

Mr. Me

    X-S Member

  • Members
  • Pip
  • 135 posts

Posted 06 January 2005 - 09:32 PM

Ii fixed the problem with it thinking i inserted an unknown disc when i eject the drive.

Here's what I did, I'm sure there's a better way but I know nothing about scripting.

Search default.xip/default.xap for..

else if(theDiscDrive.discType == "unknown")
{
stra = " An Unknown disk type has been detected.";
strb = " Do you wish to try to launch it and see what happens ?";
}

and delete it.
then search for...

function AutoLaunch()
{
if (theDiscDrive.discType == "Audio") { StartCDPlayer(); }
else if (theDiscDrive.discType == "Video") { ReStartDash(); }
else if (theDiscDrive.discType == "Title") { theLauncherLevel.GoTo(); }
else if (theDiscDrive.discType == "unknown") { TellUser("ERROR MESSAGE 1",""); }
}

and change too...

function AutoLaunch()
{
if (theDiscDrive.discType == "Audio") { StartCDPlayer(); }
else if (theDiscDrive.discType == "Video") { ReStartDash(); }
else if (theDiscDrive.discType == "Title") { theLauncherLevel.GoTo(); }
}

then search for...

else if (bShowInvalidDisc)
{
if (theDiscDrive.discType == "unknown") { BlockUser("ERROR MESSAGE 1"); }
}

and delete that too.

I just used the code that someone posted to make it auto launch xbmc when unknown disc is inserted, and instead of changing all the code for unknown disc, i just deleted it so it does nothing. Sorry for the shitty directions, hope it helps someone.






#6 ACARiD

ACARiD

    X-S Enthusiast

  • Members
  • 5 posts
  • Xbox Version:v1.0

Posted 19 January 2005 - 02:32 PM

Yes, I have a 616-drive installed too. And a friend of mine also swapped for a 616 some month ago. The UIX dash behaves exactly the same on his system. When opening the tray, UIX immediately reports an unknown media. Inserting a "known" media does not help at this point. You still have to press "NO" on the "unknown media" report to get the new autolaunch pop-up and can run the newly inserted movie or game or whatever it is.
As mentioned, no other autolaunch-capable dash that I have tried has this problem, so it is most definitely a bug within the UIX.

Edited by ACARiD, 19 January 2005 - 02:35 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users