Jump to content


Photo

Problem With Running Uix From Dvd


  • Please log in to reply
3 replies to this topic

#1 Dazza

Dazza

    X-S Young Member

  • Members
  • Pip
  • 30 posts
  • Location:Rugby, England
  • Xbox Version:v1.2

Posted 05 January 2005 - 07:33 PM

I have tried to run the dashboard from a DVD, so I can make multi game DVD's, but the dashboard fails to load from there and it causes other problems.
The main problem is that before it reboots it creates a directory called "/E:/UDATA/0ffeeff0/xips" and copies all of the xip files into it. None of these files can be deleted. The only way I could find to delete them was to first rename them and then you can delete them!
I then tried copying a file from the dvd to the root of my E drive and that could not be deleted either. This will become a bigger problem when copying games from DVD onto the hard drive.
I have tried deleting them using FlashFXP and the FileManager in UIX and Avalaunch.

#2 JbOnE

JbOnE

    X-S Expert

  • Head Moderators
  • PipPipPip
  • 526 posts
  • Gender:Male
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 05 January 2005 - 10:35 PM

#1 who ever said this would run from a dvd ?

#2 you can't delete the files in 0ffeeff0 while you are running uix because that is where it caches it's xips and runtime data so it's out of the way and still enables you to ftp in new xips/etc

#3 who ever said this would run from a dvd ?

#4 boot to another dash and you can delete that dir just fine

#3 Dazza

Dazza

    X-S Young Member

  • Members
  • Pip
  • 30 posts
  • Location:Rugby, England
  • Xbox Version:v1.2

Posted 05 January 2005 - 11:28 PM

1. I was hopeful of it running from a dvd that is all. I installed it as a test dashboard and it seemed stable and looked great. I had a second UIX install so that I could play with the xip files and after I tried to run it from dvd I noticed that I had lost all the changes to the test one, probably because the xip files in 0ffeeff0 could not be overwritten.
I have now temporarily gone back to avalaunch for my main dash while I played with the problem.

2. I understand why the xip files are there. It took me a while to find the 0ffeeff0 directory and it looked really odd when I deleted the xips directory from both of my user.interface.x.dash directories, one in the root of c and the other in e:\dashboards, and the dash continued to work despite me turning the power off to the xbox to reboot it.

3. Like I said I was only hopeful that it would work from dvd.

4. I tried to delete the files using ftp from a dos session, using avalaunches file manager and flashfxp but was unable to do so. Only after I renamed the files, using flashfxp and avalaunch, did I find that I could then delete them.
I also copied the uix.readme.txt from the dvd into the root of the E drive using the UIX file manager and could not delete that afterwards. I assumed it was a problem with copying any files from dvd to the hard drive but could be wrong.



#4 the_xbox_guy

the_xbox_guy

    X-S Enthusiast

  • Members
  • 13 posts

Posted 06 January 2005 - 05:00 AM

In my experience: when copying files from a CD/DVD to a HDD, the attributes of the file are set to ReadOnly. Iím not saying this is the root of your problem (Excuse the pun) But, attributes and how your FTP program performs itís deletion routine might be something to look into.

And by the way, Iím all for you trying to make the dash run from any media you see fitÖ CD, DVD, HDD, Tape, Record - whatever. That's what it's all about.

-x

Edited by the_xbox_guy, 06 January 2005 - 05:05 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users