Jump to content



Need Help Installing Xebian On V1.6 Softmod

  • Please log in to reply
12 replies to this topic

#1 Reaver


    X-S Enthusiast

  • Members
  • 22 posts

Posted 20 January 2005 - 01:21 AM

I am trying to install xebian, so far I have burnt iso 1.1.0-xbox to a cd-r and a dvd-rw. both boot up a black screen with with some words on the upper left hand corner that are cut off at the top, it reads like this:


I have a usb adapter with a usb to ps2 keyboard and mouse adapter pluged into it, which I have a keyboard and mouse plugend into. Will this settup work?

I read the tutorial which explains how to install version 0.3.1, but I don't find the file "Boot_fatx_vesa.iso" with the version I have. there is a "Boot_fatx_e.iso", but the linuxboot.cfg does not have any numbers like 800x600 in it.

I went ahead and transfered the files to the xbox from the Boot_fatx_e.iso, I just mounted the iso in Daemon and ftpd them over to E/Linux on my xbox. I executed the default.xbe using XBMC and it went through a series of tests and ended with something like this:

mount:/newroot/mnt/cdrom//debian/rootfs: no such file or directory
mount: could not setup loop device
pivot_root: pivot_root: No such file or directory
/linuxrc= 165 : cannot open dev/ console: no such file
Kernel panic: attempted to kill init

I am left with a flashing cursor and cannot use the keyboard to type in any commands. I don't even know if the keyboard will work with the way I have it hooked up.

Can anyone help me out here and tell me what I am doing wrong? blink.gif


#2 zekant


    X-S Enthusiast

  • Members
  • 2 posts

Posted 20 January 2005 - 02:49 AM

I did have this kernel panic too, i just kept trying, and it finally worked

#3 Trevante


    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,929 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 20 January 2005 - 05:47 AM

Did you actually ever install xebian? That boot_fatx_e is just a boot CD to load Xebian. It doesn't actually install it. The Xebian rar should contain another iso that's about 300MB, which is what you use to install Xebian. Do that first, then use the fatx boot cd.

#4 Reaver


    X-S Enthusiast

  • Members
  • 22 posts

Posted 20 January 2005 - 04:04 PM

I have tried to install but have been unsuccessfull. I have burned the iso, I think it was 272MB or something like that. The xbox recognizes the disk and boots it, but does not show the login screen, all it displays is what I mentioned above.

I have a mini linux which I cannot read because of the graphics chip in the v1.6. I have tried to telnet after I boot the xebian disk, but cannot get a connection. I use Ip as explained in the read me that came with the xebian, I don't know if it is because I am running it through a router or what. When I ftp files to the xbox, I use the non static ip that is displayed in evox when I boot, but I assume that the IP for connecting to xebian is static and contained on the disk. I am not getting the ligin screen anyway. How do I get the login screen to come up?

#5 Reaver


    X-S Enthusiast

  • Members
  • 22 posts

Posted 20 January 2005 - 05:28 PM

Well I was thinking of trying to copy over the files using dvd2xbox and I saw a post by potato bob about doing that to get the files on the xbox, so I tried it. I took the disk out and launched the default.xbe, still no cigar. I notice that it was looking for a cdrom, so I stuck the disk back in and rebooted. It loaded finally, and after a minute or two it was at what appeared to be the login screen. Almost immediately the screen went black blink.gif , then after about 30 seconds I was greeted with the xebian dashboard cool.gif .

Things are looking up, but I have to have the disk in to go into xebian, I can't boot from the drive and I have no idea how to get it to boot from the drive. Is there someway to redirect the default.xbe, or whatever file does the directing, to load from the hard drive instead of the cdrom? Does the file that contains the xebian need to be a certain name for the boot_fatx_e to launch it from the hard drive?

Sorry if I sound like an idiot, I am really new at this. I can't even get the mozzilla to go online, it says it is online, but will not load any pages from the net.

Thanks for any help.

#6 chimpanzee


    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,020 posts

Posted 20 January 2005 - 09:06 PM

you need to name the BIG file in the ISO as rootfs on E:/debian. That is how the script is written to look for. I have no idea what is the name of the file in the ISO image though. Just find the multiple hundred M file, that is it.

#7 Trevante


    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,929 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 21 January 2005 - 02:02 AM

I think it's called livefs.

#8 Reaver


    X-S Enthusiast

  • Members
  • 22 posts

Posted 21 January 2005 - 02:30 AM

I tried renaming the livefs, still did not work, but I finally got it to install. During the install I notices that there were allot of messages that said could not do this or that, It was moving so fast that I could not really keep up.

I still cannot boot it off the hdd. I tried running the default.xbe from the boot_fatx_e iso a few time and it went to the linux screen, but it froze. I tried it 2 or three times and also tried some of the other default.xbe's that I found in the files using XBMC and it just went to a black screen.

Well I have to go to work, I am working nights, so I will try again after I get off.

Thanks again for the help guys

#9 daveh


    X-S Member

  • Members
  • Pip
  • 100 posts
  • Location:Uk
  • Xbox Version:v1.4

Posted 25 January 2005 - 05:48 AM

Hey guys xebian is easy to install.

Just boot the xebian cd

When the desktop loads click on the terminal icon

Then login with: su root

Password: xebian

Then type: XBOXLinuxInstall

The install will start and ask you a few strait forward questions.

thats it.

#10 a94060


    X-S Enthusiast

  • Members
  • 16 posts

Posted 08 February 2005 - 03:29 PM

i tried to rename the rootfs file to livefs and got another error message. it said "Unable to mount root fs on 00:00"

#11 Xenosis0


    X-S Enthusiast

  • Members
  • 13 posts
  • Location:USA
  • Xbox Version:v1.3
  • 360 version:v5.0 (360S - trinity)

Posted 16 October 2011 - 01:17 AM

I know this is old but for the sake of completeness, I found the solution to this problem.

- extract the contents of fatx_e.iso to a temp directory on pc
- edit linuxboot.cfg and just verify that the line "xbox=fatx_e:/debian" is correct (change the e to an f if its on the f drive
- now go to where you installed it on the hard drive via ftp (ftp://E:/debian/)
- upload all the files in the temp directory (default.xbe,linuxboot.cfg,initrd,vmlinuz)
- reboot the xbox and you should be able to load xebian from the hdd without any disk in the drive.

some of the issues are largely caused by small differences between the initrd,vmlinuz, and linuxboot.cfg files.

the fatx_e.iso should be located in the xebian 1.1.4.iso

#12 kingtiger01


    X-S Enthusiast

  • Members
  • 11 posts

Posted 17 October 2011 - 02:29 PM

QUOTE(Xenosis0 @ Oct 15 2011, 08:17 PM) View Post

I know this is old.

"OLD"? this thread is Ancient, on top of that the ISO is no longer publicly availible. it can be found on Xbins, but pretty much no where else.

Besides, at this point theres no real gain to Linux on the Xbox1 Hardware.... a Intel Atom, could outperform it at a lower power solution...

#13 luther349


    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,369 posts
  • Location:irvine ky
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 13 November 2011 - 04:42 AM

agreed linux has move way past this hardware. those ultra low power plug in guru servers have more power then a xbox and use way less pwoer and space for the same stuff you use a xbox for now.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users