Jump to content


Photo

Foxlink Psu Revisions


  • Please log in to reply
2 replies to this topic

#1 Conundrum1911

Conundrum1911

    X-S Young Member

  • Members
  • Pip
  • 58 posts
  • Location:Courtice, ON
  • Xbox Version:v1.2
  • 360 version:v3.0 (falcon)

Posted 25 February 2005 - 04:34 AM

in light of the whole power cord issue going on right now, I decided to open up my XBOX and check my PSU before the new cord arrived...

I should start out by saying I have a 1.2/1.3 manufactured in China (line 05) with a mfg date of 2003-06-19. The XBOX itself was purchase from Futureshop in Nov 2003 as one of the holiday tetris/clonewars bundles of that year.

Anyways back to the topic at hand, low and behold my XBOX has a foxlink PSU, however I have had no incidents of sparking/crackeling/smoking at all, however my foxlink says "rev-B" on it. In the main thread about the power cords, somene else mentioned they have a "rev-H" foxlink, which didn't show any symptoms.

Therefore, I am asking those of you out there with foxlinks to post your XBOX rev number, foxlink rev number, and if possible, what replacement cord you received and whether or not your foxlink needed to be repaired (if you checked it recently). I couldn't find my torx 10 so I couldn't remove the PSU to check the point yet (I'll buy a new screwdriver tomorrow), but I will post my own findings once I can remove the PSU, as well as what cord I receive when it comes in the mail.

Thanks

Conundrum1911

#2 kenzlee

kenzlee

    X-S Enthusiast

  • Members
  • 6 posts

Posted 13 March 2005 - 10:26 PM

i just posted a new thread somewhat on this. i just bought a new power supply b/c my old delta went out. the new one i bought is a foxlink. mine says "rev b". as soon as i turned my xbox on minus the hardrive and dvd drive everything powered on fine but about 5 secs later my nvidia gpu started smoking. i don't know what to do, i yanked out the power cord and let it cool. i haven't done anything else yet i'm stumped on what to do.

#3 G0t M4xx 21

G0t M4xx 21

    X-S Freak

  • XS-BANNED
  • PipPipPipPipPip
  • 1,990 posts
  • Location:ATX! Hook 'em Horns!
  • Xbox Version:v1.4
  • 360 version:v1 (xenon)

Posted 14 March 2005 - 04:12 AM

From what ive determined, the 1.0-1.1 foxlinks (rev A and cool.gif are bad, and the 1.2-1.5 ones (rev b and higher) have the reinforced connector.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users