Jump to content


Photo

Using PC & PC BIOS To Make XBOX Modchip


  • Please log in to reply
1 reply to this topic

#1 DireW0lf

DireW0lf

    X-S Enthusiast

  • Members
  • 8 posts

Posted 08 June 2002 - 02:37 AM

Here is my Xbox Modding Experience in Full detail

Ok So I'm no chip expert but I do have a good electronics background (4 years in highschool) and can solder rather well


Day One

I started with a HP K6-300 pc it has this chip in it WinBond W29C020-90....8300K280883501VA when I looked it up and found it was 256kb i was excited so I went out to HP's website and downloaded the flash util for the mobo(stupid mistake #1)
opened up a hexeditor and split the first 256kb to another file and called it xbox.bin then I made a floppy bootdisk and put the bin file and flash util on it booted the disk and flashed the rom so far so good...I then proceeded to flash the chip which went ok. I then opened the xbox but I needed some wires...so I looked around and found an old gamepad I cut up the gamepad wire and striped about 1/8-1/4 inch off of each wire end..btw i suggest using wire strippers...but I didn't have any so i used my teeth after that I then twisted the ends of each wire so they came to a point. plugged a soldering iron in dipped each wire in flux and coated the ends with solder(this is called tinning) after that I proceeded to solder the wires to the marked locations on the xtender diagrams I use this http://arakon.hn.org/eprommod.html site btw...now this took about an hour I made sure to dip each wire in a little flux and melt a tiny bit of solder on the soldering iron(15w btw) then i put each wire to each point and touched the iron to it for .5-1 sec just enough so the wire stuck if i tugged on it slightly after that I then proceeded to solder the legs of the IC accordding to the diagram. (here comes mistake #2) I soldered 31 to 16,22,24. Anyway after reassembling and testing I got beep codes with flashing red/green light on my xbox. At this point it was late and I was frustrated so i went to bed.

Day Two

The next day I decided to figure out where i went wrong. after doing some reading I noticed I should have soldered 31-32 and not to 16,22,24. So I fixed that and tested it again...still didn't work I read somewhere that I may have wiped the chip. Unfortunately I had to go to work so I couldn't proceed any further. I work at a school as a programming instructor so luckily we have a lot of PC's laying around. And alot of them had the same chip as my HP K6-300...I did some further reading and found out about my first mistake..most BIOS flashing utils dont flash the bootblock of the BIOS. so after talking to some friends I was given this link http://www.pppr.sk/r...s.html#UniFlash a quick read of the docs had me doubtful cause I found this piece of info in the
docs

WHAT'S MISSING

Boot Block on Winbond W29C020 can be flashed even if the Boot Block protection is enabled on the chip - AMIFLASH v8.15.02 can do it but UniFlash can't (I don't know how to do it)

Note: If I had it to over again I probably would use the AMIFLASH util with the 29C020 just in case the boot block is write protected. (luckily mine wasn't as you'll soon find out)

Not being easily discouraged I decided to try it with Uniflash anyway. but first I went into the BIOS and made sure that any of the options that uniflash says to change were turned off...only one I found was the Virus Protection setting which I disabled

...so I made another boot disk and put the .bin file and Uniflash on it booted the pc and started uniflash. I went into advanced Mode and selected the option to overwrite the bios & Boot Block I typed in name the bin file and Uniflash flashed the BIOS...I thought it would be a good idea to make sure it worked so I dumped the BIOS image to the floppy before powering down. now I then checked the image I dumped but it didn't match in fact it looked like the original BIOS so I thought it may not have worked (I now know it does. The reason i got a different dump is I had Cache BIOS in ram set in the BIOS setup)...I tried rebooted but the BIOS didn't boot. When I got home I decided to try it out anyway...and this time I made sure to connect pin 31 & 32(only) to +v5(point 32 in diagram) and kept (16,22,24) attached to ground(16 in diagram). after 45 minutes of soldering I made sure no bare wires touched each other(didn't want to short out the xbox) I reassembled the xbox and tucked the modchip behind the DVD drive. I plugged it in and first tried it with Halo and it booted perfectly...then I tried a cdrw which didn't work..I went asked some more questions and found you need to burn the ISO files using DAO. I tried again and IT WORKED....Thanks bigmo, ^miro, Hyper, Arakon, El-Loco, MrSporty, and everyone in #xbox for your help in getting my modchip working...good luck to all who try this...BEWARE I TAKE NO RESPONSIBILITY IF YOU FRY YOUR XBOX

Notes:

here's couple extra tips now that I've put the xbox together 3 times and had wires shorting out. Find some nail polish or similar enamel and coat the points on the board this will keep them from shorting out to the chassis(make sure its dry before plugging in...also give youself alot extra wire at least 12" this way you can put it in the HD tray which is plastic mine are a bit short and I've had to wrap it in some paper and tuck it under the dvd drive not the most accessible place. Try and use a socket instead of soldering to the eeprom chips in case any BIOS updates come out. I'm only posting these things cause these are mistakes I've made and had to correct which was alot of extra work.

Later DireW0lf

#2 Duece

Duece

    X-S X-perience

  • Members
  • PipPip
  • 354 posts

Posted 13 June 2002 - 05:52 PM

WHat type of chip is the winbond w29c020-90? Do I just need to use the 256KB Bios Flash? Is that what you used?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users