Jump to content


Photo

Gentoox F Drive File Permissions


  • Please log in to reply
4 replies to this topic

#1 xboxstone

xboxstone

    X-S Enthusiast

  • Members
  • 25 posts

Posted 28 March 2005 - 05:25 AM

Xenium Ice chip
160 GB WD HD
no G drive
Formatted drive using the Ice chip disk formatting tool


Did an FTP install to E. Got it working finally in 760p mode. Burned Rexcootx to a CD. Able to SSH in and run Rescootx. I run sh /bin/f-drive. Get Patching Boot loader ...

then this pops up:

Moving over files to F...
This will take about 60 minutes
mv: unable to open `/mnt/fatx/f/swap': Read-only file system
mv: unable to open `/mnt/fatx/f/rootfs': Read-only file system
All done
Resctoox:>

I have no idea how to fix this. I formatted my E drive already and did a new install to help fix the problem. I have googled and searched 2 forums for a similar problem and haven't found anything related. I am somewhat familar with Linux and know that there is something wrong with the file permissions. I have tried moving e to f by putting the swap and roofts in F manually in addition to being on e. Aslo by having no Gentoox files on F and trying it that way. Still no luck. Formatting F is relly not an option.


I read about doing the magic f-drive command. Should I blow away this install again and try magic instead of rescootx? Are there any commands that I can run to fix the file permissions? Thanks for any sugestions.

#2 DeAdGuY

DeAdGuY

    X-S Senior Member

  • Members
  • PipPip
  • 154 posts
  • Location:GA
  • Xbox Version:v1.4
  • 360 version:v4.0 (jasper)

Posted 29 March 2005 - 05:54 PM

dont know if this will help but something simple i would try first is formating the f drive again with evox or unleashx....i know there used to be issues with formatting thru the xenium menu

#3 milfriez

milfriez

    X-S Enthusiast

  • Members
  • 2 posts

Posted 04 September 2009 - 03:04 PM

Softmod'd via Xboxhdm w/Kingroach Ndure

Funny enough I stumbled upon this as well, and I'm having a hard time fixing it.

When I FTP into the box and view the permissions on my new hard drive (500gb) compared to my old one (softmod'd 160GB), they are all wrong. I only get read access using unleash x. I can't save any games, I cant upload XBMC to the Apps folder, or anything. All gives me denied access.

Obviously I can't change permissions once booted, because default user is read only. I tried running Frosty's (which worked like a charm in the past) but it will not direct boot to it on the new drive. Something about permissions got jacked up. I was thinking possibly using Knoppix to try and repair permissions, but wasn't sure if that would work or not.

Ideas?

#4 osmorphyus

osmorphyus

    X-S X-perience

  • XS-BANNED
  • PipPip
  • 340 posts
  • Interests:Getting tea-bagged and gang banged
  • Xbox Version:unk
  • 360 version:unknown

Posted 13 September 2009 - 07:48 AM

alright, linux is a tricky OS, but its all we got on the box. your problem is obvious: your current user cannot write to the drive. its a retarded bitch of an issue with linux. all the open source bloviating about 'user security' can go out the window to me, because most people are the *only* users logging into the system. but, i digress.

let me start by saying reformatting your drive should have nothing to do with this problem - it is straight up a matter of user permissions.

if you want to have root access from the get go: reinstall your linux, and when it asks if you want to automatically log on, select NO!

NOTE THAT YOU *WILL* NEED A KEYBOARD IF YOU DO THIS SO YOU CAN TYPE IN YOUR ROOT NAME AND ROOT PASSWORD (ROOT / ROOT BY DEFAULT)




personally, due to ram limits, i stick with DSL, so my input may not help you at all.

on DSL, do the following to move files from your loopback to your F partition:


run the program emelfm in root mode (which is an option off the bat in DSL)
IPB Image
(a sample of what emelfm looks like)

from this 2 panel file manager, you can browse to one file location on the left panel, and on the right panel, browse to where you want to move files to on your box partitions, provided they are mounted by default.


assuming your partitions are mounted, in your right panel browse to (on DSL mind you)

.../mnt/hda55 (being your F partition)

from your left panel, you can now highlight your files, and move them into your respective F drive directories. an example for me is, i downloaded a video file to .../dsl/home and i want to move it out of the loopback file system into my main partitions so i can view it in XBMC,

i keep my left panel in .../dsl/home, browse my right panel to ...mnt/hda55/VIDEO (F partition, VIDEO folder) and select MOVE from the middle command menu, and my file is moved from the loopback into my selected partition/folder.

after this is done, i properly reboot my system thru the DSL reboot option, browse to my video folder on XBMC, and watch my freshly downloaded movie (pr0n, napoleon dynamite, plan 9 from outer space, whatever it may be...)

i use this for downloading music torrents, video torrents and single files like pictures, etc.. to be able to download files to begin with, you must be sure your web browser or torrent application has root access! in DSL, to open firefox in root access, you open a terminal window, "sudo " into root, then run the command "firefox". once FF is in root mode, test download a picture. it will download into .../dsl/home/

to mount your drives, open your FSTAB file in emelfm in root mode, edit your partitions to AUTO, and reboot. once rebooted, repeat my directions for moving files, as your disk partitions will now be mounted and writable thru root mode.


this is in DSL! i know nothing of gentoo or other linux systems! i actually have taken a liking to DSL and am finding it very easy to use. we dont get a whole lot of linux support here, but whatever i know about, i will always help with. keep in mind however, a linux guru, i am not!

Edited by osmorphyus, 13 September 2009 - 08:05 AM.


#5 osmorphyus

osmorphyus

    X-S X-perience

  • XS-BANNED
  • PipPip
  • 340 posts
  • Interests:Getting tea-bagged and gang banged
  • Xbox Version:unk
  • 360 version:unknown

Posted 13 September 2009 - 08:22 AM

also, just a note:

ask yourself, "why do i want an OS on my xbox?" is it for showing off that it can be done? are you really going to use it for word processing? emulation gaming? chat?

linux is a very limited OS, especially on the xbox. DSL does everything that i, and probably most users need: it lets me browse the web, check myspace, gmail, various other sites. it lets me download audio, video, ROMS, apps for my xbox, plugin packs for my xbox, and whatever else i need it to do, short of running youtube and other video websites.

but hey! thats why i have the newest youtube script, and videodevil! from the dashboard, my xbox gives me all the rss updates and other things i need.

i strictly use linux for a method of downloading updates and various proggies, scripts, A/V directly to my xbox to eliminate the hassle of downloading onto a main computer and FTP'ing data to my xbox. to me, it seems redundant to do all that work.


i dont know about the other variances of linux, but from what i have heard, most of them are not as lightweight as DSL. i run DSL on a 1.6, and have no problems working around the video capabilities. i can right click the menu bar of any app, and select to resize it if i cant see its nav bars. to me, this is a very versatile, useful and sensible system to work with.

i'm not hijacking this thread with this thought, but just ask yourself what you really need out of an OS on your box, and if what you are using works.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users