Jump to content


Photo

Wip Build 561


  • Please log in to reply
33 replies to this topic

#1 unleashx

unleashx

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,330 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 26 April 2005 - 06:08 PM

Thread reused for 561.
Change log:
*Fixed a few issues, as reported, with FTP client.


=============================
WIP Build 560 is out.

Change Log:
*Changed width of music player to accomodate extreme overscan
*Fixed FTP client. It should now be able to connect to other xbox ftp server. Also tested with Serv-U
*Music player will continue to play the selected file from file explorer even after exiting/hiding the player.
*added right thumbstick to control the bottom-right corner when doing screen calibration.
*Updated UnRar engine to 3.40. Fixed a few issues with extracting archives as well since there were changes in 3.40 engine that affected the unpacking code.


Build 559 and up is now using a new live update script. If you are using a version earlier than 556, you'll have to do live update twice. Once, to get 559, and another to upgrade to 560. Again, you can't use 556 or 557.

Edit:
To those doing the manual upgrade, check the URI, or try live update again, I did a minor change in the web engine. Can't say it fixes the issue, but it's worth a try.

Thanks guys, really appreciate all your help.

Edited by unleashx, 27 April 2005 - 05:42 PM.


#2 [BiA]FRAGMAN

[BiA]FRAGMAN

    X-S Young Member

  • Members
  • Pip
  • 35 posts

Posted 26 April 2005 - 06:25 PM

Great! I can't wait to see the release candidate in action smile.gif

I'm trying to update from 559 right now, but the download just stops seemingly at random points when downloading. Then an error message says that the file may be corrupt or damaged.
I'll try updating from an earlier version if this problem persists...


#3 [BiA]FRAGMAN

[BiA]FRAGMAN

    X-S Young Member

  • Members
  • Pip
  • 35 posts

Posted 26 April 2005 - 07:04 PM

It seems that the problem may have been caused by my router. Either way, after my last try it downloaded like it should from 559, so no worries smile.gif.

FTP client seems rock solid with all servers I've tested so far. I like the way it just switches to PORT if PASV is reported to be unsupported by the server. Details like that is what makes UnleashX great.
Music player also displays correctly when the picture is scaled to my TV biggrin.gif

Region switching still doesn't work with M8/+ BIOS versions. Could you comment on that James, so I know if I should stop reporting it? I'm also interested in knowing if it is even possible to do with M8 without altering the EEPROM.

Great update and surely worth a non-WIP release if you ask me.

Edited by [BiA]FRAGMAN, 26 April 2005 - 07:04 PM.


#4 incognegro

incognegro

    X-S Hacker

  • XS-BANNED
  • PipPipPipPipPipPip
  • 2,519 posts
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 26 April 2005 - 07:45 PM

QUOTE
Great update and surely worth a non-WIP release if you ask me.


I SECOND THAT!!!!! dry.gif

#5 isaac_24

isaac_24

    X-S Senior Member

  • Members
  • PipPip
  • 279 posts

Posted 26 April 2005 - 08:02 PM

Tried connecting to Xbins through the file manager and it worked smile.gif Only problem that cane up was that the Transfer Queue window didn't show. All I had was the two windows. Here a pic

user posted image

I did put something in the Transfer Queue and that is how it came up.

#6 MausMan

MausMan

    X-S Enthusiast

  • Members
  • 23 posts

Posted 26 April 2005 - 08:32 PM

Seems like you put a cd or dvd in your drive and recognised, but cant play it from the disk.
beerchug.gif

#7 isaac_24

isaac_24

    X-S Senior Member

  • Members
  • PipPip
  • 279 posts

Posted 26 April 2005 - 08:38 PM

I've tried playing a few XMVs in the file manager but after a while you were longer able to play any more. I checked the XBOX info (Y) and found that I only had 1538 KB memory free. Does UnleashX not release memory (I understand that it's not a media payer biggrin.gif) or is this a bug? You can try it if you have Street Racing Syndicate since that has tons of XMVs.

#8 unleashx

unleashx

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,330 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 27 April 2005 - 12:46 AM

QUOTE([BiA]FRAGMAN @ Apr 27 2005, 01:10 AM)
Region switching still doesn't work with M8/+ BIOS versions. Could you comment on that James, so I know if I should stop reporting it? I'm also interested in knowing if it is even possible to do with M8 without altering the EEPROM.

Great update and surely worth a non-WIP release if you ask me.

View Post



Sorry 'bout that. I have yet to take a look at M8, but from the look of things, it wouldn't be easy. It has been noted, though.

#9 unleashx

unleashx

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,330 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 27 April 2005 - 12:54 AM

QUOTE(isaac_24 @ Apr 27 2005, 02:08 AM)
Tried connecting to Xbins through the file manager and it worked  smile.gif  Only problem that cane up was that the Transfer Queue window didn't show. All I had was the two windows. Here a pic

user posted image

I did put something in the Transfer Queue and that is how it came up.

View Post



You are using a custom background for the file manager, no? You can force the border to be drawn via the skin file.

Maybe I should force the border of the queue box, what do you think?

#10 unleashx

unleashx

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,330 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 27 April 2005 - 12:55 AM

QUOTE(MausMan @ Apr 27 2005, 02:38 AM)
Seems like you put a cd or dvd in your drive and recognised, but cant play it from the disk.
  beerchug.gif

View Post



Sorry, I couldn't quite get what you mean. Are you talking about auto-play?

#11 unleashx

unleashx

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,330 posts
  • Xbox Version:v1.1
  • 360 version:unknown

Posted 27 April 2005 - 12:58 AM

QUOTE(isaac_24 @ Apr 27 2005, 02:44 AM)
I've tried playing a few XMVs in the file manager but after a while you were longer able to play any more. I checked the XBOX info (Y) and found that I only had 1538 KB memory free. Does UnleashX not release memory (I understand that it's not a media payer biggrin.gif) or is this a bug? You can try it if you have Street Racing Syndicate since that has tons of XMVs.

View Post



This is currently a known issue and I've done considerable amount of testing on it, but haven't found anything yet. Video screen saver doesn't do that, but it happens in the file manager. It is the same class, yet, it happens. I'll check it out again.

#12 isaac_24

isaac_24

    X-S Senior Member

  • Members
  • PipPip
  • 279 posts

Posted 27 April 2005 - 01:53 AM

QUOTE(unleashx @ Apr 26 2005, 07:00 PM)
You are using a custom background for the file manager, no? You can force the border to be drawn via the skin file.

Maybe I should force the border of the queue box, what do you think?

View Post


Yes, it was a custom skin. Forcing the border of the queue box I think would be better. Unless your intention now is that the file manager can have two images, one for regular (2 windows) and the other when you are connected through the FTP Browser (3 windows). Most skins would need to be updated for those with custom file manager skin though.

Also, I tried it with the Default skin and everything worked fine but I noticed something when selecting that skin. Pressing A twice wouldn't save the skin, only Start would.

Edited by isaac_24, 27 April 2005 - 02:05 AM.


#13 isaac_24

isaac_24

    X-S Senior Member

  • Members
  • PipPip
  • 279 posts

Posted 27 April 2005 - 02:12 AM

Since I can't edit my above posts anymore, after a couple of times changing skins back and forth, the file manager and ftp browser display fine if you are not using an image for your filemanager.

#14 moviecut

moviecut

    X-S Senior Member

  • Members
  • PipPip
  • 186 posts

Posted 27 April 2005 - 07:53 AM

i couldn`t test the new 560er build, but i want to report 2 ugly "xbox2xbox ftp-bugs" here (only tested with 559, but i think it is still there).

1. i have a 0kb-file, that can`t be transferrd! always get an error while trying to get it on the other box. both boxes running build559!

2. files with german umlauts also break the transfer. i have some german movies (dumm und dümmer, face off - im körper des feindes) and mp3s (from the great german band the ärzte), that always get stuck when transferring. the umlauts aren`t displayed in the file explorer... (it shows up as "dumm und dmmer")

transfer all these files with avalaunch is no problem...

hope this can be fixed for final release, as there are many german users with german named files...
i will test the 560er release and see, if its in there, too!

#15 moviecut

moviecut

    X-S Senior Member

  • Members
  • PipPip
  • 186 posts

Posted 27 April 2005 - 09:49 AM

okay, i tested the 560er build for xbox2xbox connection. first the good news:

- the 0kb-error is gone for me!
- umlauts-error is (nearly) gone. i can transfer the umlaut-files, but i can`t delete them on the other xbox after transfer! i transfered the file "dumm und dümmer.avi" and on the ftp-window it shows "dumm und dmmer.avi" like it was in the build 559 also on the local side.

now the bad (really bad) side:

- i can`t transfer folders to the other xbox! i only can transfer the files on its own. both xboxes freezes, when trying to transfer a folder! (the other xbox uses avalaunch 49.3 as dash). this is a prio1 bug i think sad.gif hope it will be fixed soon. i will switch back to 559 as this is a feature, which i use very often.

can someone else conform all this?

greetings, moviecut

Edited by moviecut, 27 April 2005 - 10:03 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users