Jump to content


Photo

Xbmc Samba And Windows Home


  • Please log in to reply
9 replies to this topic

#1 neo35

neo35

    X-S Young Member

  • Members
  • Pip
  • 50 posts
  • Location:Zion

Posted 24 May 2005 - 01:01 AM

Hi, I was wondering if someone could help me set up samba so I can access files I have shared on my computer.

I have spent about 4 hrs now trying all sorts of configurations, but I keep getting an access denied error. I was wondering if someone could help me out. I have read all the tutorials and I must be an idiot but I cannot access files from my Xbox, also would the fact that my Xbox has a wireless Ethernet bridge have anything to do with why I canít access the files?

I am running windows xp home ed. (SP2 firewall disabled)

computer name is Slayer, ip 192.168.2.2 my workgroup is WINHOME


Also, whatís the best and fastest alternative to Samba?


If someone could help id really appreciate it

Thanks


#2 flashfreak

flashfreak

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,255 posts
  • Location:Melbourne, Australia
  • Xbox Version:v1.0
  • 360 version:none

Posted 24 May 2005 - 01:16 AM

Try this line in ur xml:

smb://WINHOME;username:password@192.168.2.2/(sharename)

For username and password, its ur winxp username and if u don't have a password, then leave it blank, like this example "smb://WINHOME;Bob:@192.168.2.2/

What i've called sharename here, is the name of the shared folder on your comp with everything you wanna see, such as C (for c drive) then you can navigate around there, or share ur videos folder and call it videos, so it'd be:

smb://WINHOME;Bob:@192.168.2.2/videos/

It might be smart to setup an extra user on ur comp too, with username and password xbox, just for media center or suttin, but then u'll get a login screen when u start the comp.

#3 neo35

neo35

    X-S Young Member

  • Members
  • Pip
  • 50 posts
  • Location:Zion

Posted 24 May 2005 - 01:47 AM

still not working ...do i have to change these setting too?

<samba>
<workgroup>WINHOME</workgroup>
<winsserver>192.168.2.1</winsserver>
<debuglevel>0</debuglevel>
<defaultusername></defaultusername>
<defaultpassword></defaultpassword>
</samba>


or are they right?

#4 flashfreak

flashfreak

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,255 posts
  • Location:Melbourne, Australia
  • Xbox Version:v1.0
  • 360 version:none

Posted 24 May 2005 - 03:38 AM

these are default settings so u don't have to go through and change each one if u change a password or something. heres what u'd change it to

<samba>
<workgroup>WINHOME</workgroup>
<winsserver></winsserver>
<debuglevel>0</debuglevel>
<defaultusername>(Winxp login)</defaultusername>
<defaultpassword></defaultpassword>
</samba>

winsserver is not the ip and ur username needs to be the xp login. i'll post my settings here.

<workgroup>MSHOME</workgroup>
<winsserver>-</winsserver>
<debuglevel>0</debuglevel>
<defaultusername>guest</defaultusername>
<defaultpassword>tseug</defaultpassword>

guest:tseug are the username and password for my guest account on windows xp. heres the bookmark under my music:

<bookmark>
<name>SMB D:</name>
<path>smb://192.168.0.1/mp3s (d)/</path>
</bookmark>

Since the username and password were set above, you don't need to put it here. The shared folder on my comp is called "mp3s (d)"

So both the computer and the xbox need to be setup properly for it to work and then it should be cool, or after you've setup the password bits in the xml then you can try this if u want:

<bookmark>
<name>SMB MSHOME</name>
<path>smb://</path>
</bookmark>

This will be like the "show workgroup computers" icon in xp, you can pretty much browse the network with this one.

so yeah, hopefully you can get something working from that smile.gif

#5 xboxbox451

xboxbox451

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,015 posts
  • Xbox Version:v1.6
  • 360 version:none

Posted 24 May 2005 - 08:06 AM

If the above threads dont help, check out the link under my sig for XBMC Network Shares.

#6 jAVIS

jAVIS

    X-S Enthusiast

  • Members
  • 27 posts

Posted 24 May 2005 - 04:40 PM

Try this tutorial

#7 neo35

neo35

    X-S Young Member

  • Members
  • Pip
  • 50 posts
  • Location:Zion

Posted 24 May 2005 - 07:39 PM

try that one already...thanks tho


Still can get it to work however...it is now asking me for a username and password? do i have to setup an xbox user name for my home PC?

#8 minimoebius

minimoebius

    X-S Senior Member

  • Members
  • PipPip
  • 211 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 24 May 2005 - 08:28 PM

I found that these extra steps are needed in some cases:
http://forums.xbox-s...howtopic=397273

If that does not work, try removing the wireless bridge. Connect both devices directly to your router. Thats just a temporary check to see if your bridge may be the cause of your troubles. They should be transparent but I have a bridge that works great except that windows media exchange and other media streaming servers do not work with the bridge. So I wouldnt be surprised if its causing you problems.

#9 mau108

mau108

    X-S Member

  • Members
  • Pip
  • 129 posts

Posted 24 May 2005 - 09:04 PM

I dont know if XP Home has it, but make sure Simple File Sharing is NOT on.

You can disable it by going into My computer, goto tools, folder options, view tab, and scroll all the way down and unselect use simple file sharing.

Now another thing you must do is, create a user account in XP (I think its possible in home not sure) name it something like neo35 and password neo35.

In the share, add that account and set the permissions.

Now in your xbox, open up Xboxmediacenter.xml file, find smb:\\ (in anything my files, my video wut ever)

and type in this smb:\\(YOUR WORKGROUP);(YOUR COMPUTERNAME)\(YOUR SHARE NAME)

Hope that works smile.gif gud luck.

#10 neo35

neo35

    X-S Young Member

  • Members
  • Pip
  • 50 posts
  • Location:Zion

Posted 31 May 2005 - 02:22 AM

hey well i got the file sharing to work rather easily.... i did this by seeing if maybe it was the computer and not the xbox....and it is, i can share files on my other 2 computers (one laptop wireless, the other desktop LAN) and it picks up the files fine, but does anyone know why this computer wouldnt share files and allow access to them. I'm using XP home on all of the computer but this one seems to not be agreeing with the network? anyone have anyideas?? please help




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users