Jump to content


Photo

I Want Linux As An App For My Xbox


  • Please log in to reply
5 replies to this topic

#1 Mick Garvey

Mick Garvey

    X-S Genius

  • Members
  • PipPipPipPip
  • 891 posts
  • Xbox Version:none
  • 360 version:v1 (xenon)

Posted 29 May 2005 - 08:19 AM

I have avalaunch and all my backups and such and I really want to get a nice Linux setup on my xbox. I did the XDSL tut but instead of doing it in the E:/ area I did it in E:/apps which apparentally didnt work because its now a blue screen asking my to insert a disk like it want me to flash it. Im confused. Can anyone give some info im missing out on, thanks.

Oh and I have a modchip, an alladin to be exact. I have to hold down the button for 3 secs so it will boot from the chip, and to boot from TSOP I press eject. I was just thinking that if linux needs to flash the tsop that would be fine becuse I cant even boot the Xboxs dash anyway. Woudl that work??? blink.gif

#2 dorward

dorward

    X-S Enthusiast

  • Members
  • 6 posts

Posted 29 May 2005 - 12:50 PM

I performed a hard disk install of X-DSL over FTP about 20 minutes ago. I just followed section 9 of the README and it appeared in the Apps menu of EvoX.

The only bit where I had to make a decision was for: "Finally if you are not using the Cromwell BIOS copy default.xbe somewhere where you can run it from your Xbox.". I copied it to a Linux directory I created in the Apps directory.

I thin kthat the KNOPPIX directory must be in the root of the E: drive, but its the location of the default.xbe file that decides where it shows up in the menu system.

#3 Mick Garvey

Mick Garvey

    X-S Genius

  • Members
  • PipPipPipPip
  • 891 posts
  • Xbox Version:none
  • 360 version:v1 (xenon)

Posted 29 May 2005 - 08:30 PM

Ill check what I did and see but im shure I did something similar. Maybe not though.

#4 the_devil73

the_devil73

    X-S Senior Member

  • Members
  • PipPip
  • 279 posts
  • Xbox Version:unk

Posted 29 May 2005 - 09:47 PM

PUT THE DAMN DEFAULT.XBE IN THE APPS DIRECTORY, NOT THE KNOPPIX FOLDER ITSELF BUT THE DEFAULT.XBE IN IT!!!!!!

#5 edsrouter

edsrouter

    X-S Enthusiast

  • Members
  • 19 posts

Posted 31 May 2005 - 01:51 AM

It should also be noted when you put the default.xbe (you can rename it default.xbe from xromwell.xbe or whatever loader your using) in the apps directory, then hit the "Start" button on your controller when searching the "Applications" in the Dashboard. Then choose "Refresh List" and if "default.xbe" is in the E:/apps then an option on your Applications heading should appear and it will say "Linux". This is the shortcut to doing it. You could alter your config file but why bother. xromwell.xbe searches for the linuxboot.cfg in the E:\ drive automatically.

#6 edsrouter

edsrouter

    X-S Enthusiast

  • Members
  • 19 posts

Posted 31 May 2005 - 02:11 AM

It should also be noted when you put the default.xbe (you can rename it default.xbe from xromwell.xbe or whatever loader your using) in the apps directory, then hit the "Start" button on your controller when searching the "Applications" in the Dashboard. Then choose "Refresh List" and if "default.xbe" is in the E:/apps then an option on your Applications heading should appear and it will say "Linux". This is the shortcut to doing it. You could alter your config file but why bother. xromwell.xbe searches for the linuxboot.cfg in the E:\ drive automatically.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users