Jump to content


Photo

Mounting Xbox Partitions - Howto


  • Please log in to reply
23 replies to this topic

#1 friedgold

friedgold

    X-S Expert

  • Moderator
  • PipPipPip
  • 667 posts
  • Location:Bristol, England
  • Xbox Version:v1.1
  • 360 version:none

Posted 31 May 2005 - 06:35 PM

Background

A standard Xbox comes setup with 5 fatx partitions (fatx is a Xbox specific filesystem similar to fat). There is no partition table and the size and position of these partitions is fixed and hardcoded into the Xbox BIOS. If you have a hard disk larger than 8GB it is possible create a additional fatx partition (F) by formating the additional space. If you have a hard disk larger than 137GB (i.e. requires LBA48 to address) then it is possible to format space above 137BG to form a 'G' fatx partition. A linux kernel with the xbox-linux patches applied will detect these partitions as hda50-hda56.

Partitions

E = hda50 Data
C = hda51 System Files
X = hda52 Game Cache A
Y = hda53 Game Cache B
Z = hda54 Game Cache C
F = hda55 Additional partition
G = hda56 Additional partition

Mounting in linux

Here's how to mount F (hda55) to /mnt/F. The same method can be applied to the other partitions

1) Open a X Terminal.
2) Become root by typing in su. You will then need to enter the root password for your linux distribution
3) Make a directory for where you want to mount the Xbox partition using mkdir /mnt/F.
4) Type mount -t fatx /dev/hda55 /mnt/F to mount the F partition on /mnt/F.

All the files on F should now be accessible under /mnt/F (try typing in ls /mnt/F to check this)

Permissions

The fatx filesystem doesn't have UNIX-style permissions so files permissions are set based on the options passed to mount. By default only the root user has write access. The option umask=000 grants write access to all users when issuing the mount command (e.g. mount -o umask=000 -t fatx /dev/hda55 /mnt/F).

Editing the fstab

As you restart linux your Xbox partition will no longer be mounted. To have a partition mounted automatically you must add a entry for it into /etc/fstab. Open this file in you favourite editor as root. (for example I would open a X Terminal, type su to become root followed by nano /etc/fstab). A fstab entry is in the following form:

CODE
<file system> <mount point>   <type>  <options>       <dump>  <pass>


<file system> is the filesystem to be mounted (e.g. /dev/hda55)
<mount point> is the directory to mount the filesystem on (e.g. /mnt/F)
<type> is the type of filesystem (e.g. fatx)
<options> allows you to specify mount options for the filesystem (e.g. umask=000)

In most cases you'll want to leave <dump> and <pass> equal to 0.

To have a filesystem mounted automatically the option auto is required. Therefore if you want F automatically mounted on /mnt/F with write access to all users you would add the following line to /etc/fstab:

CODE
/dev/hda55 /mnt/F   fatx  umask=000,auto       0  0


More info

For more info on the mount command and fstab type man mount and man fstab from within a X Terminal.

Edited by friedgold, 03 June 2005 - 05:29 PM.


#2 total_ass

total_ass

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 3,000 posts
  • Location:England
  • Xbox Version:v1.4

Posted 02 June 2005 - 05:01 PM

a helpful guide indeed. i mounted my E and F (not permanently yet though)

i have a couple of questions regarding this:

1.) I opened up fstab in a program included in DSL called Beaver. it says that the file is write protected so i cannot edit it to make those entries. how to i change the attributes of the file to allow write back?

2.) am i ok deleting all of the hda50-55 entries that are in there by default? in my mnt folder all i want is E, F and Cdrom, and if its possible i'd like to get rid of all of the existing mnts (i like to keep things tidy).

thanks again.

#3 friedgold

friedgold

    X-S Expert

  • Moderator
  • PipPipPip
  • 667 posts
  • Location:Bristol, England
  • Xbox Version:v1.1
  • 360 version:none

Posted 02 June 2005 - 09:52 PM

QUOTE(total_ass @ Jun 2 2005, 06:12 PM)
1.)  I opened up fstab in a program included in DSL called Beaver. it says that the file is write protected so i cannot edit it to make those entries. how to i change the attributes of the file to allow write back?

View Post



This is a permission issue. You must be root to edit the fstab. Run open emelfm as su (it's a option under apps,tool in the desktop menu) and then open /etc/fstab from there.

QUOTE(total_ass @ Jun 2 2005, 06:12 PM)
2.) am i ok deleting all of the hda50-55 entries that are in there by default? in my mnt folder all i want is E, F and Cdrom, and if its possible i'd like to get rid of all of the existing mnts (i like to keep things tidy).

View Post



X-DSL works slightly differently from most linux distributions as the fstab is rebuilt everytime you reboot. This is due to its origins as a livecd based on Knoppix. To stop this from happening add the cheatcode nofstab into linuxboot.cfg. Then edit the fstab as you see fit. Finally use the command update-rc.d mountall.sh defaults (as root) to enable the init script which mounts the partitions in the fstab.

You can remove entries from the fstab but make sure you keep the entry of the root filesystem (/dev/loop0), as well the the Xbox partition the root filesystem is on (i.e. E or F).

#4 Big_Peb

Big_Peb

    X-S Member

  • Members
  • Pip
  • 93 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 03 June 2005 - 01:41 AM

I also have a few questions:

1) After trying to set permissions, my F drives is mounted but I still can't write to it after editing the umask command in/etc/fstab using Xterminal. Should I use another editor?

2) It seems that you need to be root to edit everything so is there anyway to login as root?

3) After using the "enhanced" install on the loopback, I tried to run the programs from myDSL but all I got was info files with text. Should I just manually add the programs I want? Also how do I install programs under Linux with the tar.gz format?

Is there any Damn Small Linux FAQ around?

#5 chimpanzee

chimpanzee

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,020 posts

Posted 03 June 2005 - 02:02 AM

some correction :

F and G are not automatically detected. You have to formatted them first, either hacked BIOS or in linux.

#6 friedgold

friedgold

    X-S Expert

  • Moderator
  • PipPipPip
  • 667 posts
  • Location:Bristol, England
  • Xbox Version:v1.1
  • 360 version:none

Posted 03 June 2005 - 05:34 PM

QUOTE(chimpanzee @ Jun 3 2005, 03:13 AM)
some correction :

F and G are not automatically detected. You have to formatted them first, either hacked BIOS or in linux.

View Post


Thanks, I've ammended the background info it make it clear that the partitions don't magically appear but need to be formatted first.

#7 friedgold

friedgold

    X-S Expert

  • Moderator
  • PipPipPip
  • 667 posts
  • Location:Bristol, England
  • Xbox Version:v1.1
  • 360 version:none

Posted 03 June 2005 - 05:43 PM

QUOTE(Big_Peb @ Jun 3 2005, 02:52 AM)
I also have a few questions:

1) After trying to set permissions, my F drives is mounted but I still can't write to it after editing the umask command in/etc/fstab using Xterminal. Should I use another editor?

2) It seems that you need to be root to edit everything so is there anyway to login as root?

3) After using the "enhanced" install on the loopback, I tried to run the programs from myDSL but all I got was info files with text. Should I just manually add the programs I want? Also how do I install programs under Linux with the tar.gz format?

Is there any Damn Small Linux FAQ around?

View Post


1)Did you do a loopback install to F? This is a slightly different situation because then F is already mounted before the root filesystem so you'll probably need to use the remount option. (mount -o remount,umask=000 ...)

2)http://forums.xbox-s...howtopic=403219

3)When you click on a info file it should bring up some infomation on the extension with the option to download at the bottom. Hoever with a loopback install I recommend using apt-get instead of DSL extensions, as then you get things like dependency handling, easy uninstall of programs, more choice, etc.

#8 manu_xl

manu_xl

    X-S Genius

  • Members
  • PipPipPipPip
  • 830 posts
  • Location:Europe
  • Interests:Hacking The Box!
  • Xbox Version:v1.1
  • 360 version:v2 (zephyr)

Posted 05 June 2005 - 10:02 AM

QUOTE(friedgold @ Jun 3 2005, 06:45 PM)
Thanks, I've ammended the background info it make it clear that the partitions don't magically appear but need to be formatted first.

View Post


so what does this mean? i have to reformat those partitions first. and then they will automatically be mounted when i have a line (see code) added to fstab?
because i did already edit fstab. but no mounting happened.
CODE
/dev/hda55 /mnt/F fatx umask=000,auto 0 0


i added this line at the bottom of fstab. i noticed also that the other lines say unauto ...
do i also have to change unauto to auto?

also next time i reboot and check fstab ... the added line is replaced up (its no longer the last line)... problem?

any help is appreciated

#9 sakamoto

sakamoto

    X-S Enthusiast

  • Members
  • 14 posts

Posted 05 June 2005 - 01:32 PM

for all those who cant automatically mount their partitions

this is the workaround (all credits go to friedgold @ #xbox-linux)

> open xterminal
> type su
> type password xbox
> type nano /opt/bootlocal.sh
> add a line for each partition you want to mount automatically mount /dev/hda5x
> save: ctrl+o
> quit: ctrl+x

when you edit the bootlocal.sh init script like described here you don't have to use the nofstab cheat

#10 lei

lei

    X-S Young Member

  • Members
  • Pip
  • 58 posts

Posted 10 June 2005 - 02:41 PM

if i try to mount F and G (hda55 and hda56) and do a listing on /mnt/F the folder to which i mounted the hda55 e.g I just get ascii crap. Anyone of you had the same problem and can help.


For Info:

160GB Samsung HD / 67 Bios (G Drive) and of course LBA48




Thanks for helping me out


Greetz lei

#11 manu_xl

manu_xl

    X-S Genius

  • Members
  • PipPipPipPip
  • 830 posts
  • Location:Europe
  • Interests:Hacking The Box!
  • Xbox Version:v1.1
  • 360 version:v2 (zephyr)

Posted 14 June 2005 - 10:19 PM

if you have followed my post above your post
you should only go to /mnt/hda5x and youll see your files

#12 devilmaycry666

devilmaycry666

    X-S X-perience

  • Members
  • PipPip
  • 478 posts
  • Location:Maryland, USA
  • Xbox Version:v1.0
  • 360 version:v3.0 (falcon)

Posted 10 November 2005 - 02:04 AM

Sorry to post in a old thread.

When i mounted hda55 and when i opened firefox and tryed to download a file it, and it sed something about HDA55 not writable. sad.gif

I'm using XDSL if that helps.

#13 friedgold

friedgold

    X-S Expert

  • Moderator
  • PipPipPip
  • 667 posts
  • Location:Bristol, England
  • Xbox Version:v1.1
  • 360 version:none

Posted 10 November 2005 - 02:38 AM

QUOTE(devilmaycry666 @ Nov 10 2005, 02:11 AM)
Sorry to post in a old thread.

When i mounted hda55 and when i opened firefox and tryed to download a file it, and it sed something about HDA55 not writable. sad.gif

I'm using XDSL if that helps.

View Post



Open a xterm and type mount. It should show a list of drives that are mounted. One of the these should be /dev/hda55

e.g.
CODE
/dev/hda55 on /mnt/hda55 type fatx (rw,umask=0000)


What mount options does it show in the brackets for you?

#14 devilmaycry666

devilmaycry666

    X-S X-perience

  • Members
  • PipPip
  • 478 posts
  • Location:Maryland, USA
  • Xbox Version:v1.0
  • 360 version:v3.0 (falcon)

Posted 11 November 2005 - 12:31 AM

Is this bad?
user posted image

#15 friedgold

friedgold

    X-S Expert

  • Moderator
  • PipPipPip
  • 667 posts
  • Location:Bristol, England
  • Xbox Version:v1.1
  • 360 version:none

Posted 12 November 2005 - 03:45 PM

Hmm, those options look right to me. Is this a lookback install to F. Becuase if it is F will be mounted so only root has write permission initially (by the initrd). Once X-DSL loads I don't know anyway to change this. mount -o remount,umask=000 doesn't seem to work (I guess because the loopback file is mounted the partition containing it can't be remounted). You should be to save you file somewhere else (e.g. /tmp) then open emelfm as superuser (it's one of the options in the menu) and move your downloads to F.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users