Jump to content


Photo

Password For Smb?


  • Please log in to reply
22 replies to this topic

#1 bGxboX

bGxboX

    X-S Enthusiast

  • Members
  • 12 posts

Posted 01 June 2005 - 03:04 PM

Hello and sorry for my bad english unsure.gif

I make all settings for SMB and it works biggrin.gif But... I don't know my user and password blink.gif Here is a screenshot:

user posted image

My Windows username is "Deni" and I don't use password for login! I try to write only "Deni" with no password ,but it doesn't work sad.gif I make a new user called "xbox" with password "xbox" but it doesen't work too unsure.gif Any ideas? Thanks!

#2 JayDee

JayDee

    X-S Legend

  • Head Moderators
  • PipPipPipPipPipPipPipPipPip
  • 5,750 posts
  • Gender:Male
  • Location:Sweden
  • Xbox Version:v1.1
  • 360 version:v2 (zephyr)

Posted 01 June 2005 - 03:18 PM

Have you tried the guides in the pinned topics?

Links are in my sig...

#3 bGxboX

bGxboX

    X-S Enthusiast

  • Members
  • 12 posts

Posted 01 June 2005 - 03:29 PM

Yes. But where can I see or change this username and password for SMB?

#4 bakman

bakman

    X-S Young Member

  • Members
  • Pip
  • 50 posts

Posted 01 June 2005 - 03:31 PM

this seems like the dubious linksbox version

#5 JayDee

JayDee

    X-S Legend

  • Head Moderators
  • PipPipPipPipPipPipPipPipPip
  • 5,750 posts
  • Gender:Male
  • Location:Sweden
  • Xbox Version:v1.1
  • 360 version:v2 (zephyr)

Posted 01 June 2005 - 03:41 PM

Might be...

If the default.xbe is larger then 8mb get another build....

#6 Bugnutz

Bugnutz

    X-S Member

  • Members
  • Pip
  • 80 posts
  • Location:East Coast Canada
  • Xbox Version:v1.6b
  • 360 version:none

Posted 01 June 2005 - 03:44 PM

Did you set up a shared folder and give share and ntfs rights for that xbox user, and/or your Deni user.
Also you can edit the xboxmediacenter.xml file and set a default username and password, or create shortcus and define username and password for each one.

(to make things easy, but unsecure, enable the guest account and make sure that the everyone group is setup on the share and ntfs permissions on the shared folders)



#7 bGxboX

bGxboX

    X-S Enthusiast

  • Members
  • 12 posts

Posted 01 June 2005 - 04:12 PM

QUOTE(Bugnutz @ Jun 1 2005, 04:55 PM)
Did you set up a shared folder and give share and ntfs rights for that xbox user, and/or your Deni user.
Also you can edit the xboxmediacenter.xml file and set a default username and password, or create shortcus and define username and password for each one.

(to make things easy, but unsecure, enable the guest account and make sure that the everyone group is setup on the share and ntfs permissions on the shared folders)

View Post



Thanks! I try smile.gif But where can I enable the guest account?

#8 bGxboX

bGxboX

    X-S Enthusiast

  • Members
  • 12 posts

Posted 01 June 2005 - 05:50 PM

Ok ok this are the settings:

<bookmark>
<name>SMB</name>
<path>smb://tslayer:password@192.168.0.1/Movies</path>
</bookmark>

But I don't use password for login in my Windows tongue.gif What must I write?

#9 Bugnutz

Bugnutz

    X-S Member

  • Members
  • Pip
  • 80 posts
  • Location:East Coast Canada
  • Xbox Version:v1.6b
  • 360 version:none

Posted 01 June 2005 - 07:24 PM

the proper syntax for no password would be :

<path>smb://tslayer@192.168.0.1/Movies</path>

but you may find better result by setting a default username and password for XBMC to use everytime it has to access a SMB (linux or windows), her is the code snippet in xboxmediacenter.xml

<samba>

<workgroup>WORKGROUP</workgroup>

<winsserver>-</winsserver>

<debuglevel>0</debuglevel>

<defaultusername>windows username</defaultusername>

<defaultpassword>windows passwordxbox</defaultpassword>

</samba>

it's near the top of xboxmediacenter.xml

so when you start browsing "WORKGROUP (SMB) Network" you'll be able to access shares on any PC that is connected to the xbox via a patch cable or a router. Providing you have a user and password defined that matches for your Windows shares.

Also to be able to enable the guest account, goto Start Button -> Control Panel -> Administrative tools -> Computer managment -> users and groups -> users

you can enable the guest acocunt there, or create new users and place them into groups as you see fit.

Hope this helps, as there are many tuts on XS that explain this in more detail.


#10 Bugnutz

Bugnutz

    X-S Member

  • Members
  • Pip
  • 80 posts
  • Location:East Coast Canada
  • Xbox Version:v1.6b
  • 360 version:none

Posted 01 June 2005 - 07:27 PM

If you have win2000/20003 then you'll be able to just right click the folder and start sharing it. But if your running winXP then you'll have to go to folder options and turn off simple file sharing. that may help you along, as WinXP tries to dumb this sort of thing down, I prefer to have more control with the sharing and NTFS rights. That's why I'm still a die-hard 2000 user. not to mention all the other problems with XP which I'll not get into here.....

l8rz


#11 bGxboX

bGxboX

    X-S Enthusiast

  • Members
  • 12 posts

Posted 02 June 2005 - 12:30 PM

OK I edit the .xml file so:

<path>smb://Deni@192.168.1.201/Downloads</path>

This is my path wink.gif Click here to view my computer!
Also it works ,but when I try from XBMC on the display is this:
user posted image
But then it ask me for password and I just press enter. But it doesn't work sad.gif Where is the problem?


#12 xboxbox451

xboxbox451

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,015 posts
  • Xbox Version:v1.6
  • 360 version:none

Posted 02 June 2005 - 01:26 PM

Try adding "everyone" to your shared folder. That worked for me.


user posted image

#13 bakman

bakman

    X-S Young Member

  • Members
  • Pip
  • 50 posts

Posted 02 June 2005 - 01:28 PM

which version are you running ? is this the one with the integrated browser ?

#14 xboxbox451

xboxbox451

    X-S Freak

  • Moderator
  • PipPipPipPipPip
  • 1,015 posts
  • Xbox Version:v1.6
  • 360 version:none

Posted 02 June 2005 - 01:33 PM

5.31.05 build is my current version.

Update to the latest build and you can enter your network shares via the GUI.

It located on XBMC by selecting: settings --> network --> smb share

All I had to do was enter my computer IP for "SMB IP" and XBMC saw my folders no problem.

To see your shared folders via XBMC you'll have to go to: My Videos --> and select WORKGROUP (SMB) Network (if you see two of these try both).

#15 bakman

bakman

    X-S Young Member

  • Members
  • Pip
  • 50 posts

Posted 02 June 2005 - 02:41 PM

QUOTE(xboxbox451 @ Jun 2 2005, 03:44 PM)
5.31.05 build is my current version.


the question was ment for bGxboX wink.gif





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users