Jump to content


Photo

Halo 2 Headset


  • Please log in to reply
6 replies to this topic

#1 Diceman5022

Diceman5022

    X-S Enthusiast

  • Members
  • 6 posts

Posted 06 June 2005 - 11:28 PM

Sorry if this is in the wrong spot i wasnt really sure to put this or if this is even the right forum but i wasnt sure where else to ask

I bought a halo 2 headset around a month or so ago worked fine so i stupidly threw the reciept away....now it wont work i cant talk with it or hear through it the part that plugs into the controller works fine i plugged a cell phone mic into it and presto i have communication ive tried blowing in the mid ive used those little cans of compressed air ive push the wires in thinking maybe they were just a little lose ive cleaned the tip that plugs into the adapter..but still nothing ive come to the conclusion its dead..someone posted a link awhile back that had a site you could sell a broken xbox to so i figured id post here see if anyone knew where i could sell/trade/anything but throw it away with im 15 so a 60 dollar mic isent exactly a "oh well ill go get another" kind of thing any help is greatly appreciated once again sorry if this is the wrong spot i just dident know where else to go

Diceman5022

#2 mckenn88

mckenn88

    X-S Expert

  • Members
  • PipPipPip
  • 554 posts
  • Location:Buffalo, New York
  • Interests:doin shit
  • Xbox Version:none
  • 360 version:v1 (xenon)

Posted 06 June 2005 - 11:33 PM

u should put thgis in the buy/sell/trade forum.......

#3 KyesaRRi

KyesaRRi

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,576 posts
  • Location:Australia
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 06 June 2005 - 11:34 PM

It could be that the part that plugs into your controller is broken, you could try and see if that is the problem by borrowing someone elses to test.

Maybe its disabled in the game that your playing. Try setting it up in that game

I have the same headset and it works great, you just have to treat it with respect =P

And mine works fine in my house phone, but not my mobile phone so maybe the mobile has killed it ?

#4 Diceman5022

Diceman5022

    X-S Enthusiast

  • Members
  • 6 posts

Posted 06 June 2005 - 11:40 PM

Thx mck ill put anything similar to this there next time


well the only game ive used it in up till today when i tried it on mech assault 2 was halo2 and it worked fine there up until yesterday where it went in and out and i had to keep unplugging it and plugging it back in to work

i only have one other person with live and he doesnt have the halo2 headset and with my incident i dont think he plans on it lol i know a guy on live that has one and now you and neither of you seem to have problems with them so im sure its a bad mic i just think i got a bad one ohmy.gif ill check to see if theres anything wrong with the tip but even if there was i cant fix it or anything..looks like ill have to just bury it and shell out the green for another

#5 KyesaRRi

KyesaRRi

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,576 posts
  • Location:Australia
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 06 June 2005 - 11:45 PM

It sounds like a cable problem, you COULD try to replace the cable with another, but it would look like crap. You should allways keep the recipt for anything that you buy

#6 Diceman5022

Diceman5022

    X-S Enthusiast

  • Members
  • 6 posts

Posted 07 June 2005 - 01:26 AM

yeah ive never had a problem like this before so i dident think the reciept was a big deal but lesson learned

#7 BoNg420

BoNg420

    X-S Messiah

  • Head Moderators
  • PipPipPipPipPipPipPip
  • 3,809 posts
  • Gender:Male
  • Location:USA
  • Xbox Version:none
  • 360 version:v5.0 (360S - trinity)

Posted 07 June 2005 - 04:00 AM

here's what you do, you go and buy a new halo headset, then you return the broken one and you got yourself a new working headset. I do stuff like this sometimes, it works as long as there is no serial numbers on it that can be tracked to the box. Just say it didnt work when you got it.

Edited by BoNg420, 07 June 2005 - 04:07 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users