Jump to content


Photo

Xbmc Cannot Access Workgroup


  • Please log in to reply
2 replies to this topic

#1 cho

cho

    X-S Enthusiast

  • Members
  • 3 posts

Posted 08 June 2005 - 08:58 AM

I am getting the following error when trying to access the Workgroup (SMB) bookmark on XB Media Center:

Error - 1073741772: Share not available

I am able to access everyone's computer on the network if I manually enter in bookmarks into the xml file like this:

<bookmark>
<name>//cho</name>
<path>smb://cho</path>
</bookmark>

However, when I go to acess the workgroup bookmark it comes up with the above error. The bookmark for workgroup is default as follows:

<bookmark>
<name>WORKGROUP (SMB) Network</name>
<path>smb://</path>
</bookmark>

Manually entering everyone's computer on the network isn't too bad a workaround, but it's rather annoying, particularly if someone joins onto the network and I want to stream from their pc.

Our network setup is fairly simple, just a router/modem accessing ADSL and running a DHCP server to all the computers on the network. The xbox is set to static IP on 192.168.1.99, however it makes no difference if I don't use static IP, I still get the problem.

Xbox OS: Evox +3935
Kernel: 1.00.5101.01
XBMC version: XBMC 2005-06-04-PIMPED
I think my modchip is an Alladin.

I have had this problem with all versions of XBMC, doesn't seem to make any difference.

I think that's about all the information I can provide about the network/problem. Any help with this would be greatly appreciated.

#2 MameManiac

MameManiac

    X-S Enthusiast

  • Members
  • 8 posts

Posted 08 June 2005 - 11:10 AM

QUOTE
        <bookmark>
            <name>Music</name>
            <path>smb://workgroup;user:password@192.168.1.4/Music/</path>
        </bookmark>

thats how your smb should look like, you need to put in your network cards ip not your xbox's ip.


#3 DJ_Phatic

DJ_Phatic

    X-S Enthusiast

  • Members
  • 9 posts

Posted 21 June 2005 - 06:04 PM

I too was having this problem, i seem to have fixed the problem, hopefully this will work for you as well.

in the xboxmediacenter.xml file I have setup the Samba settings as follows

<samba>
<workgroup>HOUSE</workgroup>
<smbip></smbip>
<smbsharename>(SMB) Network</smbsharename>
<defaultusername></defaultusername>
<defaultpassword></defaultpassword>
<winsserver></winsserver>
<debuglevel>0</debuglevel>
</samba>

After transferring the file over, I deleted the following folders:

E:/UDATA/0face008/ and E:/TDATA/0face008/

Now XBMC fines the workgroup correctly and i am able to get stuff from the network.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users