Jump to content


Photo

Xbmc Smb Setup Problem


  • Please log in to reply
4 replies to this topic

#1 Sneeekey

Sneeekey

    X-S Enthusiast

  • Members
  • 4 posts

Posted 26 June 2005 - 02:49 AM

Please forgive me if this issue has been posted before, but I have searched and I couldn't find a relevant post. I also have read the stickys and *think* I have followed the steps to the letter, but I'm still having the problem.

I have set following setup:

xbox IP: 192.168.1.101
PC: 192.168.1.100
OS: WinXP Pro

I'm using the following in the xboxmediacenter.xml

<samba>
<workgroup>MSHOME</workgroup>
<winsserver></winsserver>
<debuglevel>0</debuglevel>
<defaultusername>xbox</defaultusername>
<defaultpassword>xbox</defaultpassword>
</samba>


and

<bookmark>
<name>Network My Computer</name>
<path>smb://xbox:xbox@192.168.1.101</path>
</bookmark>

My xbox is networked to my PC via a linksys router. I am also using NIS 2005, but am seeing this problem whether NIS is enabled or disabled. I can get the weather, ftp, shoutcast etc. but I can't see the contents of the shared folder on my PC. I tried sharing the folders under the shared folder on my PC, but this nets the same result (can't see the files under the folder).

I verified that both machines are on the same subnet (255.255.255.0) and use the same gateway (192.168.1.1) in the xbmc gui and my pc's ipconfig.

Has anyone seen this before? How did you fix it?


#2 killerxbox

killerxbox

    X-S Young Member

  • Members
  • Pip
  • 45 posts
  • Location:California
  • Xbox Version:unk

Posted 26 June 2005 - 03:44 AM

I have a similar problem. Using an SMB setup I have trouble seeing files in shared folders (BTW I have Win XP Pro SP2 and XBMC as of 6/16/05). One thing I do is either reboot my xbox or exit and reenter the folder a couple of times and then the files will show up. But sometimes after playing for a while, the files will disappear again and crash my computer

I also noticed another strange thing -- the size of my files are way off. An avi file that is just under 200 megabytes, is showing up as over a terabyte of data. What gives?


#3 Sneeekey

Sneeekey

    X-S Enthusiast

  • Members
  • 4 posts

Posted 26 June 2005 - 04:17 AM

I did some further digging after reading some posts in the xbmc sites forums and checked the xbmc log file after trying to connect to my shared folder from my xbox.

The following is logged:

25-06-2005 23:12:25 NOTICE initialize done
25-06-2005 23:12:25 NOTICE Running the application...
25-06-2005 23:12:26 ERROR Invalid url:
25-06-2005 23:12:26 ERROR Invalid url:
25-06-2005 23:12:26 ERROR Invalid url:
25-06-2005 23:13:09 ERROR SMBDirectory->GetDirectory: Unable to open directory : 'smb://xbox:xbox@HAL2004/Music/'
unix_err:'16' nt_err : 'c0000008' error : 'Invalid handle'


Does anyone know what to do to resolve this problem? sad.gif

#4 fireburster

fireburster

    X-S Senior Member

  • Members
  • PipPip
  • 175 posts

Posted 26 June 2005 - 04:22 AM

is there a user on your pc called xbox with password xbox? If not thats a problem.

#5 Sneeekey

Sneeekey

    X-S Enthusiast

  • Members
  • 4 posts

Posted 26 June 2005 - 06:14 AM

yes, there is a user on my pc named xbox (pwd: xbox). I've tried giving the user Administrative priveleges as well, but it still doesn't work.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users