Jump to content


Photo

Debug Xbox?


  • Please log in to reply
56 replies to this topic

#1 johnnysoj

johnnysoj

    X-S Enthusiast

  • Members
  • 12 posts

Posted 28 June 2005 - 07:23 PM

Hello All,

I have two questions, but first, a little background:


My company has an xbox that is busted. Ive worked with xboxes before so I figured i'd look at it and see what the problem could be.

So, I turned the machine on, and noticed that the fan tries to turn and stops, and tries to turn and stops... and
theres a clicking sound. Originally I thought the clicking was from a bad hard drive.

Upon turning it over to open it, the first thing that caught my eye was that this xbox had no serial numbers on it. No warrantee voiding tamper stickers,
and no feet.

I opened the xbox, and found to my surprise that it already had a debug header on the lpc. I also noticed an inch long black 30 pin (2 rows of fifteen) connector
directly below the fan, and just before the CPU heat sink.

When i turned it on, I noticed the clicking was coming from the power supply, not from the hard drive.

I had an extra power supply, so I installed it, and turned the machine on, and now the fan spins properly, and theres no more clicking. Upon putting everything back together, and plugging it in, I noticed that the CDROM drive just opening and closing. There is also no audio or video at all.

I guess the first question is, what kind of an xbox is this?
I think it might be a debug xbox, even though the case is not that see-thru green.

According to the guide it says its a version 1.1, but i've never seen the debug port, and this strange black connector on a 1.1, or on the 1.0 that I have.

The second question is what might be wrong with it?

Any and all help anyone can provide will be much appreciated.
Thanks.
John.





#2 TH!RDEYE

TH!RDEYE

    X-S Young Member

  • XS-BANNED
  • Pip
  • 46 posts
  • Xbox Version:unk

Posted 28 June 2005 - 07:49 PM

take pics!!!!! but yeah thats weird you stumped me. the wierdest xbox Ive ever seen was just a refurb frankenstien it had no daughterboard but it had fan on the gpu and the drive was a philips but the lpc had solder in them and the heatsink on the cpu was black... Its stumped me on what version it was blink.gif You propably got a rare xbox or something take pics it will help everyone here. (you did do a good job describing though)

#3 Pikkon

Pikkon

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 675 posts
  • Location:Florida
  • Interests:女の子-音楽-ゲーム
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 28 June 2005 - 08:22 PM

I think is a beta live debug xbox.It has a pinheader installed and just
standard 64ram.Well I dont think the recovery cd would work,its
not a standed debug/dev kit.Check all the wires and make sure
everything is plug in properly.And you can try to install a chip
on it with debug bios.I dont know if the eprom is blank or not.
Well thats all I know for now.

Edited by Pikkon, 28 June 2005 - 08:32 PM.


#4 johnnysoj

johnnysoj

    X-S Enthusiast

  • Members
  • 12 posts

Posted 28 June 2005 - 09:02 PM

Heres some pics. One noteable one is of the bios. The date on the bios chip says 03/29/01, and the other pic is of the additional 30 pin connector below the fan.


Full Motherboard:
user posted image

LPC+Bios:
user posted image

30 Pin Connector:
user posted image

Hope this helps... dry.gif

#5 bgrill27

bgrill27

    X-S Senior Member

  • Members
  • PipPip
  • 229 posts
  • Location:Rio Rancho, New Mexico
  • Xbox Version:v1.0

Posted 28 June 2005 - 09:04 PM

That's awesome!!
Thanks for posting the pics!

I have no idea what that box is, though dry.gif !

Edited by bgrill27, 28 June 2005 - 09:04 PM.


#6 johnnysoj

johnnysoj

    X-S Enthusiast

  • Members
  • 12 posts

Posted 28 June 2005 - 09:24 PM

I've been told that this is an eval xbox. Apparently they gave them out way back when before the xboxes were released for evaluation purposes...

Don't know...

I just want to get it to work. If the bios is hosed, I might have to get a mod chip for it...


#7 sapper

sapper

    X-S Genius

  • Members
  • PipPipPipPip
  • 900 posts
  • Location:Sacramento, Ca
  • Xbox Version:v1.0

Posted 29 June 2005 - 09:29 AM

i would really like to know what that header near the fan is for.

#8 Tobb555

Tobb555

    X-S Expert

  • Members
  • PipPipPip
  • 656 posts
  • Location:From the dark side of the Moon
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 29 June 2005 - 09:36 AM

could this be the same motherboard as the XDK and that header connects all the extra boards. I dont know much about the special xboxes such as the XDK or debug but its a possibility.

#9 sapper

sapper

    X-S Genius

  • Members
  • PipPipPipPip
  • 900 posts
  • Location:Sacramento, Ca
  • Xbox Version:v1.0

Posted 29 June 2005 - 10:32 AM

but if it was xdk or debug it would be a 1.0 version mobo if im not mistaken. His is clearly a 1.1 (note thier is no daughterboard) also i believe the xdk have 128meg ram and his is 64 by the pictures.

#10 johnnysoj

johnnysoj

    X-S Enthusiast

  • Members
  • 12 posts

Posted 29 June 2005 - 03:37 PM

What does the cdrom opening and closing generally signify? Does it mean a corrupt bios? or bad hardware?



#11 TKramka

TKramka

    X-S Genius

  • Members
  • PipPipPipPip
  • 830 posts
  • Location:CT
  • Interests:Computer Technology, Xbox Hardware and Modding
  • Xbox Version:v1.1
  • 360 version:none

Posted 29 June 2005 - 03:53 PM

Bad DVD drive, maybe heat shock failure. If its a Thomson, just get another one, or better yet, a new Philips.

#12 G0t M4xx 21

G0t M4xx 21

    X-S Freak

  • XS-BANNED
  • PipPipPipPipPip
  • 1,990 posts
  • Location:ATX! Hook 'em Horns!
  • Xbox Version:v1.4
  • 360 version:v1 (xenon)

Posted 29 June 2005 - 05:44 PM

QUOTE(johnnysoj @ Jun 28 2005, 03:35 PM)
I've been told that this is an eval xbox.  Apparently they gave them out way back when before the xboxes were released for evaluation purposes...

Don't know... 

I just want to get it to work.  If the bios is hosed, I might have to get a mod chip for it...

View Post



now why would they have a version 1.1 before release???

#13 Pikkon

Pikkon

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 675 posts
  • Location:Florida
  • Interests:女の子-音楽-ゲーム
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 29 June 2005 - 08:14 PM

Like I said before.This xbox was used to beta test xbox live games,
thats it.As for the odd connector,I cant put my finger on it.


#14 old engineer

old engineer

    X-S X-perience

  • Moderator
  • PipPip
  • 405 posts
  • Location:U.K
  • Interests:Xbox Development
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 29 June 2005 - 08:41 PM

It isn't anything to do with Beta Live!

...Beta Live! Debug's run on 128mb RAM Ver 1.0 Mobo's

It's a real 'odd' one off type evaluation Xbox showing the migration from Ver1.0 to 1.1, also even though the pic isn't that clear I'm pretty sure it's fitted with an MCP rather than am MCPX. A nice piece of kit.

...The 'odd' connector is an arcade harness connector related to the relationship with the Sega, as per DVT3.
__________________


#15 sapper

sapper

    X-S Genius

  • Members
  • PipPipPipPip
  • 900 posts
  • Location:Sacramento, Ca
  • Xbox Version:v1.0

Posted 29 June 2005 - 09:45 PM

if you want to sell that motherboard let me know.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users