Jump to content


Photo

Xport Networking Not Working In *any* Emulator


  • Please log in to reply
10 replies to this topic

#1 brakken

brakken

    X-S Enthusiast

  • Members
  • 20 posts

Posted 05 July 2005 - 07:17 AM

I'm having having issues trying to get networking working on my windows 2k box which is connected to a dhcp router using dgen/pscxbox, xbmc and ALL other Dash/Apps works fine, i need to know the exact string to configure to these settings: router (192.168.1.1) pc (192.168.1.100) xbox (192.168.1.102) wg (imp0st3r) pcname (g33k3m0n) share (roms) . can anyone help?

smbshare=smb://workgorup;usernameassword@computername/share
smbshare=smb://workgorup;usernameassword@ip_address/share
smbshare=smb://usernameassword@workgroup:ip_address/computername/sharename
smbshare=smb://usernameassword@workgroup/computername/sharename
smbshare=smb://usernameassword@workgroup:ip_address/computername/sharename
smbshare=smb://usernameassword@computername/sharename
smbshare=smb://usernameassword@computername:ip_address/sharename
smbshare=smb://workgroup/computername/sharename
smbshare=smb://workgroup:ip_address/computername/sharename
smbshare=smb://computername/sharename
smbshare=smb://computername:ip_address/sharename

I've tried all of these on both the PSX and NES emus with the smb nameserver set to empty, 192.168.1.1 (router) and 192.168.1.100. Took about 4 hrs to test and NONE OF THEM WORKED!


#2 hargle

hargle

    X-S X-perience

  • Members
  • PipPip
  • 413 posts

Posted 05 July 2005 - 04:42 PM

Welcome to the club!

I gave up on SMB and switched to relax instead and it works quite nicely.

Somewhere in this forum is a tutorial I wrote up on getting relax to work. Let me know if you can't find it.

People have said they've gotten SMB to work on the PSX emulator though. Search the other emulator forum, as I had someone post their INI file.





#3 Stabby_McTwist

Stabby_McTwist

    X-S Member

  • Members
  • Pip
  • 132 posts
  • Location:Worcester, MA
  • Xbox Version:v1.0
  • 360 version:none

Posted 05 July 2005 - 05:33 PM

you sure your PC is 192.168.1.100 and not 192.168.1.101?

As far as I know 192.168.1.xxx is used only by Linksys. Ive had a few Linksys routers and they always start at .101

#4 beige

beige

    X-S Member

  • Members
  • Pip
  • 96 posts

Posted 06 July 2005 - 02:17 AM

what worked for me in pcxbox and neogenesis is:
SMB://username:password@computername/sharename

You could add the rest of the path to the roms folder also, or use the emulator to browse to the folder from the home path of the share.

However, I keep getting connection timeout errors that keep me from using it since it only stays connected to the samba share for a few minutes. But i'm not sure if it's the emulator or the network.

#5 brakken

brakken

    X-S Enthusiast

  • Members
  • 20 posts

Posted 13 July 2005 - 09:04 PM

QUOTE(beige @ Jul 6 2005, 03:28 AM)
what worked for me in pcxbox and neogenesis is:
SMB://username:password@computername/sharename

You could add the rest of the path to the roms folder also, or use the emulator to browse to the folder from the home path of the share.

However, I keep getting connection timeout errors that keep me from using it since it only stays connected to the samba share for a few minutes. But i'm not sure if it's the emulator or the network.

View Post



Yes I've tried to use that string and it didn't work. Additionally I gave the relax share a go and it connects, but all I see is garbage as filenames with no luck loading anything. I've tried on two computers one with XP and one with Win2k and used two different routers as I am a networking major and understand these things.

My Router IP is 1.1 and my first IP is 1.100

#6 hargle

hargle

    X-S X-perience

  • Members
  • PipPip
  • 413 posts

Posted 14 July 2005 - 07:59 PM

QUOTE(brakken @ Jul 13 2005, 10:15 PM)
I gave the relax share a go and it connects, but all I see is garbage as filenames with no luck loading anything.


This is a common misconfiguration in relax. I don't know the exact cause of it, but I've seen that too and been able to fix it with some tweaking. Probably slightly different naming conventions between your *.ini file in the emulator and the share name in relax. Could also be spaces in the share names. I'm not 100% sure, but spaces in things scare me, so I made all my share names space free.

Here's my guide:
http://forums.xbox-s...howtopic=326540

This works for me flawlessly. I've only got it on atari 2600, NES, colecovision and intellivision emulators, but that's entirely due to time constraints.



#7 brakken

brakken

    X-S Enthusiast

  • Members
  • 20 posts

Posted 21 July 2005 - 06:06 AM

Thanks! I've got it working! Is there any way to use RLX shares in MAMEoX as of course SMB isn't working in that emulator either?

#8 Paxil

Paxil

    X-S Young Member

  • Members
  • Pip
  • 31 posts

Posted 25 July 2005 - 04:57 AM

I'd also like to thank you for the guide.

I have been struggling for hours with a samba share.

I like relax much better.

It worked for pcsxbox v11

One note for anyone else reading this and looking for Relax
RelaX V0.79 from sourceforge is a corrupt zip
so look at hxxp://www.raforce.nl/ to get the good one.

beerchug.gif

#9 hargle

hargle

    X-S X-perience

  • Members
  • PipPip
  • 413 posts

Posted 25 July 2005 - 03:48 PM

QUOTE(brakken @ Jul 21 2005, 07:17 AM)
Is there any way to use RLX shares in MAMEoX as of course SMB isn't working in that emulator either?

View Post



I've tried to get RLX working with MAMEox and MAMEdOX, but have had no luck.
see: http://forums.xbox-s...howtopic=403558

I believe MAMEdOX is still being worked on, perhaps we can convince someone to add RLX support, since it seems like it might be easier than SMB support.



#10 Paxil

Paxil

    X-S Young Member

  • Members
  • Pip
  • 31 posts

Posted 26 July 2005 - 08:14 AM

Eureka!
I got samba working with MAMEoX and pcsxbox-v11

"names/numbers changed to protect the innocent"

System settings
xbox softmod
UIX dashboard settings
IP 192.168.1.40
gateway 192.168.1.1
subnet 255.255.255.0

Home PC
Windows XP Home Edition
Latest service packs and firewall is on
Be sure that in the firewall 'Exceptions' tab that there is a check mark on 'File and Printer Sharing'
IP 192.168.1.66
workgroup = WORKGROUP
computer name = Dell
Logon = Me
and there is no password

Router
IP 192.168.2.1

Long story short
Since all FAQs and threads say that samba works with xbox media center, I went and set it up first.
Best info was here, please RTFM

hxxp://manual.xboxmediacenter.de/wakka.php?wakka=HowToSamba&v=196f

I went with the example they give

<bookmark>
<name>My Share Name as it you would like it to appear in XBMC</name>
<path>smb://domain;username:password@MyWindowsServer/movies</path>
</bookmark>


So I setup a share on my windows computer called 'mp3' and this was all I needed to setup in the 'XboxMediaCenter.xml' file was
So I FTP'd off the 'XboxMediaCenter.xml' file and used the following two lines:

<name>Dell</name>
<path>smb://WORKGROUP;Me:@Dell/mp3</path>

And then FTP back on to the xbox and start XBMC and select SMB drive.
Note the format with the semi-colon and colon with no password.
That was all that had to be configured because I left XBMC to get the xbox ip address etc from the dashboard.

I opened up my music and could play streaming mp3s from my PC.

Since this setting worked for XBMC, I used the same for pcsxbox-v11.

I made a share on my windows computer called PSXCDS and put some .IMG and some .BIN and .CUE files.
Before I got it right with the XMBC samba config format, pcsxcbox would lock up when I chose 'SMB:\'
After I used the right format, I could load a game from the SMB share.
Again I left the application to get the xbox ip address and subnet from the dashboard networking configs.
So I FTP'd off the 'pcsx.ini' file and used the following two lines in the [GENERAL] section:

smbshare=smb://WORKGROUP;Me:@Dell/PSXCDS
smb_nameserver=192.168.1.66

I FTP'd back the 'pcsx.ini' file and started pcsxbox-v11.
I had to go to configuration first and select the force reload of D:\*.INI to make my changes take effect.
Then I chose Select Game and selected 'D:\', then selected 'D:\' again and scrolled down and selected 'SMB:\'

This time it did not lock up and instead showed the contents of the samba share and it loaded and ran a game correctly.

With both XBMC and pcsxbox running samba share successfully, I went to MAMEoX.

I setup a share called 'mame' with a subdirectory called 'roms' and put some roms there.

I had some trouble at first but the MAMEoX FAQ I found here gave the info needed

hxxp://members.lycos.co.uk/xboxadam/index.php?page=docsview.php&doc=doc_mame.php

I had been trying to use the drive mapping page to setup the samba, when it was actually the rom directory path page to use.

I also found that I had an orphaned 'MAMEoX.ini' file on my xbox in 'e:\udata\4d414d45\' when the current one had moved to 'e:\tdata\4d414d45\system\' after a previous MAMEoX upgrade. This caused a little confusion. So be sure to check the date on yours to know which INI file is being used.

So I FTP'd off the 'MAMEoX.ini' file and edited it under [Directories]
I needed to edit the following line:

RomsPath3 = smb://WORKGROUP;Me:@Dell/mame/roms

Instead of trusting the dashboard, I did use these settings from 'MAMEoX.ini'.
[Network]
DisableNetworking = 0
IPAddress = 192.168.1.40
Gateway = 192.168.1.1
Subnet = 255.255.255.0
NameServer = 192.168.1.66

I had MAMEoX do a ROM seach and when it did the third path, it read the samba correctly. (My rom path 1 and 2 are on the xbox hard drive) path 3 was a test to see if samba would work. I could probably move all roms off to the samba shares.

I selected one of the games that was on the samba share and it worked.

I assume if I put the artwork on the share it would work too.
ArtPath = smb://WORKGROUP;Me:@Dell/mame/artwork

I had some concerns with MAMEoX because the GUI only allows upper case characters when setting the path. I was afraid the samba share was case sensitive. However after I ran MAMEoX, it automatically changed
my rom path text in the INI file from
RomsPath3 = smb://WORKGROUP;Me:@Dell/mame/roms
to
RomsPath3 = smb://workgroup;me:@dell/mame/roms

but it still worked.


So yes MAMEoX and pcsxbox-v11 samba shares work and others may too with the right format and research.

happy hunting!
biggrin.gif

#11 nugmebot

nugmebot

    X-S Young Member

  • Members
  • Pip
  • 48 posts

Posted 05 April 2010 - 09:03 AM

Anybody has been able to access roms via samba in MAMEdOX?

Iīve trid the typical and correct (i think) lines in mamedox comnfig:
smb://user:pass@ip-address-pc/sharename

And my mamedox canīt load the roms...

anyone knows why?

Thanks!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users