Jump to content


Photo

Network Help Please


  • Please log in to reply
5 replies to this topic

#1 practal

practal

    X-S Young Member

  • Members
  • Pip
  • 35 posts

Posted 01 August 2005 - 07:40 PM

I am attempting to set up a network between a pc with 2 NICs and a Xbox. I have spent about 10 hours on failed attempts and read every tutuorial I can find. I am listing in detail all hardware and settings used. If you know of any conflicts with the below items that would prevent ICS from working please say so. If your good with networking, could you please point out the error because I cant seem to find it. I know nothing about networking so any help is appreciated.

I have SBC DSL with a Dynamic IP (ipconfig /all screen shot below). On the screen shot I have a line that says domain_not_set.invalid and Im not sure if this could be the problem. I connect using a Speedstream 5100 modem. I do NOT have a router, Hub, or firewall.

My network is set up as follows: Modem -> NIC1->NIC2->Xbox (Crossover cable from NIC 2 to Xbox)

NIC1 is intergrated (SiS 900 PCI Fast Ethernet Adapter). I have ICS turned on with this and set to obtain IP Adress and DNS automaticaly.

NIC2 is a stand alone card (3Com EtherLink XL 10/100 PCI For Complete PC Management NIC (3C905C-TX)). I have tried numerous settings with this, all came from tutorials and havent gotten it to work. I believe my problem is with the settings here. I can ping the xbox, ftp in, and map network drives with the settings I found in the tutorial. I cannot seem to get an internet connection though using these same settings. When I turn ICS on NIC1 (ICS is not turned on NIC2) it assigns this IP 192.168.01 and mask 255.255.255.0, everything else is blank. I have filled in about every number I get from ipconfig but still nothing. When I set it to automaticaly obtain an ip address, the Xbox registers as 0.0.0.0.

My Xbox is mod'd with Soft Mod Installer Deluxe. I havent messed with the settings in the bios but if I need to please let me know. I assume that evox would set the connection since its the program that launches.

I can get the xbox to get on the internet by directly connecting it to the modem and it works fine, different settings of course. I use evox as my default dash. I have tried numerous settings here, including setting static ip to no. I havent tried changing it but I assume set up network should be left on yes.

My main reason of getting this connection working is for XBMC. XBMC also works when directly connected to the modem but not through 2 NICs. I have tried many variations and have set it to automatic but not luck. Strange thing is that when I power on my Xbox, my PCs internet connection dies so I dont have a connection on either. I read that having ICS on NIC2 will cause this but its not enabled.


Stupid Shit Not Accepting Imageshack, anyways I guess Ill type it up:

Windows IP Configuration:
Primary DNS Suffix Blank
Node Type Unkown
IP Routing Enabled Yes
WINS Proxy Enabled No

All of NIC2 Info is above

Ethernet Adapter Internet Connection:
Connection-Specific DNS Suffix domain_not_set.invalid
Dhcp Enabled Yes
Autoconfiguration Enabled Yes
IP Address 69.221.224.27
Subnet Mask 255.255.255.0
Default Gateway 69.221.224.28
DHCP Server 192.168.0.1
DNS Server 192.168.0.1
192.168.0.1
Lease Obtained And Lease Expire are for 10 minute durations and a new one is generated.

Edited by practal, 01 August 2005 - 07:47 PM.


#2 Textbook

Textbook

    X-S Hacker

  • Last Chance
  • PipPipPipPipPipPip
  • 2,552 posts
  • Location:Near Flint, Michigan
  • Interests:Xbox and Computers
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 01 August 2005 - 09:10 PM

I'm not guaranteeing anything, but try this. First of all, disable both of your PC's NIC's and change their IP settings to detect automatically, and then enable NIC 1. Leave NIC 2 disabled for now. On your Xbox, set the IP for 192.168.0.3 and set the default gateway to 192.168.0.1. Make sure Static IP is set to NO. Remember to scroll down and hit Save and Exit. Turn off your xbox. On your computer, enable NIC 2 while the xbox is off. Once both NIC's are enabled and set to detect automatically, select/highlight both of them. Right click when both NIC's are highlighted and hit Bridge Connections. Once the network bridge has been made, turn on your xbox and hope it works. It works for me, and this is how I connect everyday.

Edited by Textbook, 01 August 2005 - 09:11 PM.


#3 practal

practal

    X-S Young Member

  • Members
  • Pip
  • 35 posts

Posted 01 August 2005 - 10:22 PM

Thanks for the help Textbook but it didnt change anything. When I attempt to bridge the 2 connections I get "To Create A Network Bridge, you must select at least 2 network connections that are not being used by Internet Connection Sharing or the internet connection firewall". Neither have a firewall so that is not the problem.

I checked in my DSL settings and found somethings that may be throwing me off. Keep in mind I know next to nothing about networking so they may be set correct. I tried searching the SBC Tech Support Web site and even called but both of them pretty much said dont use ICS, buy our 2way home kit.

I listed the sbc settings and put divider lines between the different areas, if I had the option to choose one I put XXX next to the one selected. Some are just places where different variables can be entered. I am also wondering why the DNS numbers are different then what ipconfig puts out??
________________________________________________
A very limited number of applications require that the public IP address assigned to the modem be used by the local LAN device.
Let LAN device share Internet address?

No, use private IP address.
XXX Yes, use public IP address
________________________________________
VPI 0
VCI 35
Protocol PPPoE
Maximum allowable MTU 1492
ATM Encapsulation LLC (can also be VC-Mux)
_________________________________________________
Option 1. XXX PPP is on the modem. This is the normal mode for this modem when connected to a single computer. In this mode, the PPP session is initiated from the modem. Gateways and routers should work in this mode but their configuration may have to be changed to do so (e.g., you may need to have the gateway/router IP address changed to 192.168.1.1).

Option 2. PPP is on the computer. This mode is normally used if you need to run a PPPoE client on your PC. This mode can be used with a gateway or router which initiates a PPPoE session. To return to the DSL modem user interface you will need to directly connect your PC to the modem without any gateway or router between the modem and the PC.

Option 3. Bridged Mode (PPPoE is not used). This mode must be used if you are connecting to a non-PPPoE network
______________________________________________________________
These numbers are different than what ipconfig gives?

DNS Servers 67.36.55.26 dns1.klmzmi.sbcglobal.net
206.141.193.55 dns1.sfldmi.sbcglobal.net
Mode PPP on the modem (Public IP for LAN device)

#4 Textbook

Textbook

    X-S Hacker

  • Last Chance
  • PipPipPipPipPipPip
  • 2,552 posts
  • Location:Near Flint, Michigan
  • Interests:Xbox and Computers
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 01 August 2005 - 10:32 PM

Disable ICS and then try to bridge connections. Believe me, it may sound stupid, but it does share the internet when you bridge the connections.

#5 practal

practal

    X-S Young Member

  • Members
  • Pip
  • 35 posts

Posted 01 August 2005 - 11:15 PM

Thank you, that worked perfectly. Why are there so many tutorials if it is just that simple? Is there a big speed differance between bridging and ICS? I run emule and d2jsp alot on the pc so Im hoping the performance is close to the same. I only wanted a dual connection for cd look up in XBMC, that was alot of work just so I didnt have to name songs dry.gif Thanks Again Textbook love.gif

#6 Textbook

Textbook

    X-S Hacker

  • Last Chance
  • PipPipPipPipPipPip
  • 2,552 posts
  • Location:Near Flint, Michigan
  • Interests:Xbox and Computers
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 01 August 2005 - 11:27 PM

Your welcome, man. I'm glad it worked for you. You know why it was so easy, don't you? Because you're smart and actually listed everything I needed to know. I see too many posts where people are just like, "I'm having problems with FTP" and that's it, end of post.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users