Jump to content


Photo

Problem Browsing Shared Linux Server


  • Please log in to reply
1 reply to this topic

#1 strangerX

strangerX

    X-S Enthusiast

  • Members
  • 3 posts

Posted 04 August 2005 - 09:39 AM

k k, i have a linux box running Smb Server with slackware on it. now i have no problem seeing the Linux box under Workgroup, but when i go in (under XBMC) there was nothing there. does anyone has the same problem?

i have tried

smb://Workgoup;root:pass@ip

or just though the workgroup...

non of the shared folders under my linux box shows up

can anyone give me any pointers :-)

Edited by strangerX, 04 August 2005 - 09:40 AM.


#2 MrFish

MrFish

    X-S X-perience

  • Members
  • PipPip
  • 369 posts
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 04 August 2005 - 12:27 PM

QUOTE(strangerX @ Aug 4 2005, 10:50 AM)
i have tried

smb://Workgoup;root:pass@ip

View Post



You just want smb://user:pass@host (host doesn't have to be (and in my opinion shouldn't be) an IP); where you're saying 'workgroup' is actually where you'd put the name of the domain.

Whereas a workgroup is an organizational filter that prevents computers appearing in each other's network neighbourhoods, a domain is an authentication hierarchy, where all members share the same set of user accounts, and computers delegate their authentication functions to a Primary Domain Controller. You almost certainly don't have a domain, because setting Samba up as a PDC is something you have to go way out of your way to do; I'm guessing that had you done so, you'd probably mention it.

First things to check (after taking the workgroup out of your XBoxMediaCenter.xml) is if another computer, using the same username/pass as the XBox can access your samba box. If so, it's a problem with XBMC. If this computer can't, but can when it uses its normal username/password, it's a permission problem in Samba. If it can't at all, Samba is misconfigured in some way, or firewalled off.

As with all Samba problems, you first stop should be /var/log/smbd.log (which may be somewhere else depending on your distribution).
CODE
Tail -f
it, attempt to access the computer using the XBox, and if the error message doesn't enlighten you, consider posting it. If there's no meaningful error message, you might have to turn up your log level (
CODE
man smbd.conf
).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users