Jump to content


Photo

Did Your Xbox Psu Blow Up?


  • Please log in to reply
67 replies to this topic

Poll: Did your Xbox PSU blow up?

Did your Xbox PSU blow up?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.
Vote Guests cannot vote

#1 XanTium

XanTium

    Xanta Powa!

  • Admin
  • 3,110 posts
  • Location:Solaris
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 23 October 2005 - 05:26 AM

feel free to vote/discuss.

#2 ndsbass

ndsbass

    X-S X-perience

  • Members
  • PipPip
  • 440 posts
  • Location:IL
  • Xbox Version:v1.6b
  • 360 version:v1 (xenon)

Posted 23 October 2005 - 05:34 AM

i like the new polls but this is kinda random, dont you think? o well better than nothing rolleyes.gif

my psu is still going strong after like 3 shorts caused by me (whoops)



#3 1starvingartist

1starvingartist

    X-S Enthusiast

  • Members
  • 25 posts

Posted 23 October 2005 - 05:35 AM

sheesh, new post . hmm wonder who'll wind up makin more; time or, $$ off consumers in the long run.

guess too many kids broke their box, n' M$ could capitalize.

#4 mgamer20o0

mgamer20o0

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,115 posts
  • Location:So Cali
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 23 October 2005 - 05:49 AM

had a xbox psu blow and now it doesnt work. even with a new psu.

#5 VOlition

VOlition

    X-S Expert

  • XS-BANNED
  • PipPipPip
  • 680 posts
  • Location:Canada, B.C
  • Xbox Version:v1.4
  • 360 version:v1 (xenon)

Posted 23 October 2005 - 05:58 AM

Nope, my psu didn't blow up and I know it's not planning to. I just got recently, probally 5 months, and it will last longer.

#6 Shadow Fox 14

Shadow Fox 14

    X-S Young Member

  • Members
  • Pip
  • 45 posts
  • Location:WA
  • Xbox Version:v1.1
  • 360 version:none

Posted 23 October 2005 - 05:59 AM

still using the original PSU after resoldering the two points

#7 lordvader129

lordvader129

    He Who Posts Alot...

  • Head Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 17,743 posts
  • Gender:Male
  • Location:Chicago, USA
  • Xbox Version:v1.1
  • 360 version:v5.0 (360S - trinity)

Posted 23 October 2005 - 06:01 AM

mine never blew up (was a delta) but i had repaired several foxlinks for people, all with the same burned solder joints in the back, i fixed probably about 5 of these as much as a year before MS started sending the cables out

#8 neb15

neb15

    X-S X-perience

  • Members
  • PipPip
  • 403 posts
  • Location:Canada
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 23 October 2005 - 06:06 AM

never had a power problem although i did have a few shorts due to mods...

yay polls are back finaly biggrin.gif

#9 Alkane

Alkane

    X-S X-perience

  • Members
  • PipPip
  • 441 posts
  • Xbox Version:unk
  • 360 version:unknown

Posted 23 October 2005 - 06:31 AM

At the time that it happened to me, I had no clue what happened. Year or more before MS officially recalled the cables. I was testing a VGA cable I'd made when I heard crackling sounds. I figured the sound was coming from the papers the Xbox was resting on. Next thing I knew there were sparks flying out of the machine. Needless to say, the PSU was toast.

I've been fixing the PSU units as I see them.

Here, the owner complained of hearing crackling sounds everytime he plugged the power cord. With further inspection, I found the plug points burned -- with with a hole.
user posted image
Foxlink on a v1.0

#10 Xijar

Xijar

    X-S Enthusiast

  • Members
  • 29 posts
  • Location:Utah
  • Interests:Xbox 360
  • Xbox Version:v1.0
  • 360 version:unknown

Posted 23 October 2005 - 06:51 AM

I ordered two of the replacement plugs just because they were free, but I don't use them on either of my Xboxes simply because they're ugly and bulky and take up too much space on my outlet strips. Never had any problems with the PSU, although I've been meaning to resolder them for sometime, just to be on the safe side.

#11 Elusive hacker

Elusive hacker

    X-S Senior Member

  • Members
  • PipPip
  • 216 posts
  • Xbox Version:v1.4
  • 360 version:v2 (zephyr)

Posted 23 October 2005 - 06:53 AM

i was lucky had a Delta in my V1.0 and still going strong

#12 brandonvb

brandonvb

    X-S Enthusiast

  • Members
  • 0 posts

Posted 23 October 2005 - 06:58 AM

Before the whole replacement thing my psu started sparking at a friends house, when we noticed, it was too late. I got a new psu off eBay, after re-soldering the plug didn't revive it. Now it works fine.

I would have also gotten a free cord from MS, but the serial sticker on the bottom my my box was gone so long ago.

#13 miggidy

miggidy

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,369 posts
  • Location:NorCal
  • Xbox Version:v1.2
  • 360 version:v3.0 (falcon)

Posted 23 October 2005 - 07:43 AM

I never had a problem until a few days ago, I think mine is ready to go.
I hear a low frequency, but high pitch sound coming from my PSU when the power cord is connected, all this while my Xbox is turned off.
It sounds very similar to the low frequency sound hear from your television when it's on but you have it on one of the empty video channels. You know the ones with the black screen and no sound.

It's pretty strange, the sounds kicks in a few minutes after I turn my Xbox off.
I unplug the power cord from the xbox and it goes away, obviously.
At this point I think my PSU is screwed but I'll get the replace power cord just to see if it makes a difference....

#14 Puskas

Puskas

    X-S Young Member

  • Members
  • Pip
  • 43 posts
  • Xbox Version:v1.0

Posted 23 October 2005 - 08:06 AM

have an original v1.0 xbox... been used almost EVERY day since I bought it in march 2002.

#15 Alex548

Alex548

    X-S Knowledgebase

  • Head Moderators
  • PipPipPipPipPipPipPipPip
  • 4,412 posts
  • Gender:Male
  • Location:Your mom's house
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 23 October 2005 - 09:27 AM

QUOTE(miggidy @ Oct 22 2005, 11:54 PM)
I never had a problem until a few days ago, I think mine is ready to go.
I hear a low frequency, but high pitch sound coming from my PSU when the power cord is connected, all this while my Xbox is turned off.
It sounds very similar to the low frequency sound hear from your television when it's on but you have it on one of the empty video channels. You know the ones with the black screen and no sound.

It's pretty strange, the sounds kicks in a few minutes after I turn my Xbox off.
I unplug the power cord from the xbox and it goes away, obviously.
At this point I think my PSU is screwed but I'll get the replace power cord just to see if it makes a difference....

View Post



I have a 1.2-1.5 PSU having the same low level high pitch sound... neither the old or new cords solve this problem. Nothing seems burnt on the PSU...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users