Jump to content


Photo

Confused With Xdsl .cfg Format


  • Please log in to reply
2 replies to this topic

#1 tharien

tharien

    X-S Senior Member

  • Members
  • PipPip
  • 196 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 23 October 2005 - 10:40 PM

Ok i know about the cheat codes, and i have the list, I have searched to forums and all i come up with is
QUOTE
'eth0=ip,nm,dg,dns - Use a static ip for networking. Here ip is your IP address, nm your netmask, dg your default gateway and dns your dns server'
which is the same thing i have in the cheat codes text. Great, i know how to read and i have read it over and over.

so my question is, what is the correct formatting within the config file?

I tired 'eth0=ip,nm,dg,dns' and 'eth0=ip nm dg dns' and i keep getting the "Network settings are invalid' message on start. so here is my config file please tell me where the line is put and what the formatting is.

QUOTE
kernel /KNOPPIX/linux24-xbox
initrd /KNOPPIX/minirt24-xbox.gz
append init=/etc/init video=xbox:640x480 noscsi nofirewire frugal lang=us quiet kbd-reset

title XDSL Loopback install
kernel KNOPPIX/linux24
initrd KNOPPIX/ird-loop.gz
append root=/dev/ram0 init=/etc/init rw video=xbox:800x600 rootfs_name=xdslfs quiet kbd-reset
eth0=123.123.123.123,255.255.255.0,123.123.123.123,123.123.123.123


#2 tharien

tharien

    X-S Senior Member

  • Members
  • PipPip
  • 196 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 October 2005 - 12:32 AM

any help would be greatly appreciated.

#3 friedgold

friedgold

    X-S Expert

  • Moderator
  • PipPipPip
  • 667 posts
  • Location:Bristol, England
  • Xbox Version:v1.1
  • 360 version:none

Posted 26 October 2005 - 01:12 PM

I'm not sure why it's not working for you. I usually use DHCP but I set it to static just to check everything was working. Here's a exact copy of my linuxboot.cfg entry:

CODE
title X-DSL static
kernel KNOPPIX/linux24
initrd KNOPPIX/minirt24.gz
append memory=61M root=/dev/ram0 init=/etc/init rw video=xbox:640x480 lang=uk utc frugal joyd eth0=192.168.1.60,255.255.255.0,192.168.1.1,192.168.1.1 quiet kbd-reset


Note you should use comma's to seperate each address and the append line should be on one line in linuxboot.cfg (ignore any word wrapping in my example config).

QUOTE
i keep getting the "Network settings are invalid" message on start

The startup script checks that each address is in the range 0.0.0.0 - 255.255.255.255 and prints "Network settings are invalid" if one of the addresses is invalid. This check might also fail is there is some problem parsing the settings. Are the settings you wrote in your post the same you are using on your Xbox or just example addresses?

Edited by friedgold, 26 October 2005 - 05:11 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users