Jump to content


Photo

007 Linux Tsop Flash W/out Compiling Or Mem Card


  • Please log in to reply
43 replies to this topic

#1 shr00m

shr00m

    X-S Enthusiast

  • Members
  • 28 posts

Posted 15 April 2003 - 09:57 AM

ok i am not going to go into every detail about this because there has already been a tut released on it, but i just wanted to confirm that it is possible, i will be a little more clear on the parts i was unsure about and explain how to do it without EVER compiling a linux kernel

ok first off get you a linux distro, i used mandrake 9.1 due to noobness and ease of installation.


second get you someones save game partition off there xbox (with raincoat/007 hack already on there) this is how you get around compiling...


the partition image i had was in this format "gamesaves.img.bz2" (if this was your save partition u know who you are thank you!!) this file is about 141 megs , it could vary depending on where you get it.... once again im just confirming that this method is possible without doing all the stuff that was listed in the previous tut



ok heres exactly what i did from start to finish


downloaded mandrake 9.1 installed on clean hd i had lying around


after it was installed and ready... i did the hot swap. the way way the guys have listed it b4 did not work so i will fill you in on a little secret i found that makes it work on pretty much any system.

hot swap method i used:

1. first unplug ide from xbox plug into secondary ide on pc (which should have NOTHING else on it!!!)

2. i used xbox power for xbox HD, turned on xbox and of course youll get the xbox needs service screen since the xbox ide cable is disconnected, but the important thing is the drive has juice... ok now turn on your pc with the 2ndary ide cable connected to xbox hd and power from xbox, (isnt necesary to use xbox power but i found its easier this way in the long run... )

3. let your pc bios detect the xbox HD, THEN pause it at LILO , or the mandrake loader... hit pause on the keyboard (i just paused at themandrake loader)

4.now turn off the xbox.... unplug ide cable from pc from xbox hd and plug in the ide cable from the xbox back into the xbox HD

5. turn on the xbox with no disc in it and let it boot to the menu

6. once at the menu and xbox is fully booted, unplug ide from back of xbox HD, but not power, plug up the secondary ide from the PC with linux on it, which is paused at lilo (or mandrake loader) after you have already let the pc bios detect the xbox HD. you should have plugged it back up to exactly where it was when the pc bios detected it, now hit enter let linux load up completely

7.voila, now your xbox hd is unlocked and loaded into linux


i wanted to clear up the hot swap because noone mentioned to let the PC bios detect the HD if you dont do this before unlocking with xbox then loading, 9 out of 10 PCs will not recognize the HD because it wasnt detected by the bios....


ok on to the loading of raincoat... the tricky part with this method is getting your hands on the partition image, instead of just the raincoat save but trust me if you can it MAKES this soooo easy, i dont know jack about compiling linux kernels and pulled this off in 2 hours, including time to install mandrake. maybe if you come to #linux-on-unmodded on efnet you will be able to find a friend who will send this jewel.... i have it and will be willing to donate it to someone who can host it somewhere, its 140 someodd megs... i do not take credit for creating it at all... but i do have it and it does WORK.

ok anyway on to the fun part, after hot swapping the unlocked drive by following my procedure if you used mandrake you should have had someting like disk drake detect it, just exit out of it, dont make any changes to the disk, it will ask to detect and thats fine, but after it does, just exit and boot into linux.... ok once in the gui of mandrake (im using this because its how i did it, sure you can do it with other distros, but remember im a linux noob and this is how i got through this).

ok you want to burn the image onto a cdr or rw from your windows pc (the .bz2 image that is gonna be tricky to find maybe) make you a dir in linux called xbox, i just made it on the root and then copied this gamesaves.img.bz2 into the xbox folder.... ok everyone recomends backing up all of your xbox hd, which is possible now with it unlocked and you can find a guide here http://xbox-linux.so...d=2002173055324 I totally recomend backing it up, i was too anxious and did not and everything turned out ok, thank god, but i would really recomend not doing that... sorry for trailing off but i promise im gonna try to include all the info needed.

ok once you've backed up or not, and you have your gamesaves.img.bz2 in your folder on linux in a place like xbox or wherever you know where its at now its time for business...

1. if running mandrake hit CTRL-ALT-F1 this will get you to a pure command prompt, you will need to log back onto your admin or root account under the cmd prompt , now cd to the xbox dir where the partition image is (the gamesaves image)

2.once in the dir type ls or dir to make sure your in the right dir and yo see gamesaves.img.bz2 (or whatever your bz2 file is called)

3. TYPE THIS COMMAND EXACTLY WITHOUT QUOTES "bzip2 -cdk gamesaves.img.bz2 | dd of=/dev/hdc seek=5501 bs=512k"

4.of course if your image wasnt named gamesaves.img.bz2 you will type your name, but the image i tested is probabally the one a noobish person will want to get seeing as it is tested.

5.this will take a little while approx 10-15 minutes for the image to extract onto the xbox harddrive, you are actually overwriting your game saves partition with another one that has the auf/007 raincoat save on it, so you can kiss your other saves goodbye but well worth it imo.

6.after its completed and back at prompt, PLEASE wait for it to finish and get back to prompt, you can hit ctrl -alt-del to shut down linux, what i did was unplug IDE first then shut down xbox, then pressed ctrl alt delete, this probabally isnt necesary but once again, is exactly how i did it.

7. plug xbox ide cable back up

8. boot xbox make sure it boots, check your saves, you should see 007 save there now, if you do WOOHOO its the raincoat hack with gui plugins and all.

9.now boot 007 like normal, load saved game and it will now boot to LINUX!!!!!!!!!!! WITH GUI FREAKING SWEET...



I just want to re-emphasize i am not trying to take credit for this, only trying to shed some info on a different way of doing it other than the complicated way released 4-14-03 which isnt really complicated if you know linux, and i still would have a unmodded box if it wasnt released but the other way is complicated if you dont know anything about compiling linux kernels, this way there IS no compiling , no mem card, just have to load up linux on a pc, hot swap the drive with the technique i gave. then extract the save game partition over. the hard part of this is gonna be getting the image... but if someone is willing to host it i will send it out... this way is pretty simple for semi-noobs so i think it would be benficial for the patition to be hosted, not any worse than hosting the 007 hacked save anyway.




some more info... i successfully flashed my tsop using this way via telnet... of course you have to have the jumpers soldered closed and if you have a sharp TSOP chip it is even more complicated i have a sharp chip and i want to include info on this since most brand new 1.1s come with the sharp.... i know this is a very long post, but I know i would have benefitted from it so screw it...



if you do not have a sharp chip and wish to flash the tsop you only need to short the two sets of jumpers, one set on top and one set on bottom, illustrated here http://xbox-scene.co...ix-fix-tsop.php

disregard the article and connect the two points that are illustrated in the pics by "jumper from MCPX RD# to flash OE#" there are 2 dots next to each other as you can see... just conect them together, a drop of solder works well, or a jumper wire if you cant handle getting a drop of solder, that point is on top the one on bottom is illustrated at the same URL by "MCPX WR# to FLASH WE#" once again just two dots do the same thing, its like a jumper you want to short them together... one on top and one on bottom and thats it... the purpose of this is to write enable your tsop, which will allow you to put modchip code Right on the xbox itsself via the auf/007 linux hack.

if you dont have sharp tsop and do this mod your xbox tsop is now permenantly writable, woohoo!

if you do have a sharp chip its a little more tricky but possible, i did it!

you want to pay attenion to the same two point illustrated above + one more.

1. for sharp chip connect the jumper on the bottom just like normal as described above

2. for the jumper on top you DO not connect it, solder a small wire (like ide ribbon cable) on each dot give yourself about 3 inches of wire on each dot... tape them down on the dots with electrical tape after soldering so they dont break off after youve soldered them, have the unsoldered tips of these wires bared and sticking up so you can pigtail them together later and connect the two points, but you do not want them permenantly connected!!!

3. you have to run a jumper wire like this one http://x.jonhammar.c.../rompinouts.jpg i hope that pic stays up because its a perfect illustration for the extra point you need for sharp tsop which is very nonpublished kinda, and if you dont do this link IT will not work, ive heard it will erase but not reprogram and wouldnt that just be lovely. incase this pic goes down since it isnt on here what it is doing is taking 5v from the lpc pads (or jtag port like its actually called) and connecting it to pin 11 of the tsop, which is where the dot is on the pic. if you dont understand that dont worry, just do whats in the pic and you will be fine.

ok the reason the top jumper is not permenantly connected is because the xbox will not boot if it is.

the way you flash your sharp tsop is as follows.... (btw you need to read the other tut that was released on this it explains how to flash the tsop via telnet, im just filling in some missing pieces for us noobs) here is that link http://xbox-scene.co...-no-memcard.php


if you follow this tech just go down to the section about tsop flashing and ignore the stuff about compiling and all that, its only to make the image that you hopefully have already found... exactly the same, the point of this psudo tut was to get around the linux compiling which makes this method actually pretty damn easy.


ok back to if you have a sharp, if you dont have a sharp and you have done the 2 jumper mods just follow the forementioned tut in order to flash, if you do have a sharp after connecting the jumper on the bottom, the other jumper wire on the bottom and the two wires on top,with bare ends this is how you flash (w/ sharp)


first boot up with dvd rom and hd sitting outside the xbox,but plugged in of course. with your two wires from the top jumper sticking up and not connected to each other, load 007 AUF, boot into linux by going into 007 load game and loading the save, it will go black then load into a linux GUI (sweet!) , once you have reached the linux desktop and its fully booted you want to twist your two wires together now(DONT CONNECT THEM BEFORE LOADED INTO LINUX, LINUX WONT EVEN LOAD IF YOU DO IT IN 007, I TRIED,so wait till your at the linux desktop on xbox) now you can flash the exact same way the tut before tells you to do.... by telneting into the xbox username/pw root:xbox then typing “cd ../../media/E/UDATA/4541000d/000000000000/raincoat” now type ls or dir make sure you see bios.bin and 2 other files. Once that is confirmed type: “./raincoat -p bios.bin” both commands without quotations of course.... it will erase the chip first then reprogram it with ev x modchip bios (MAKE FREAKING SURE NO CAT/PERSON/ANYTHING IS GONNA TOUCH THE NETWORK CABLE CONNECTING PC/XBOX OR xbox power cord, or router power cable.... this is critical).... VOILA modded XBOX with evox 2 bios now. no chip/no card/ no compiling.... ok if you have a sharp chip untwist the 2 jumper wires and tape them up so they dont short stuff out inside the xbox, or remove them, i left mine incase i ever wanna flash again.... then shut down xbox and turn back on, back together.. its modded now, i used slayers auto install on a cdrw and it booted up perfectly!

i wanna give a little info on the networking part of this because once again the info was there just VERY spread out and incomplete....

i dont know any other way since i did it on a linksys so thats how ill explain


first go to your browser on your windows pc... go to 192.168.1.1 that will take you to your linksys config on the first window setup, change the device ip to 192.168.0.1, apply this, now you should reboot the router reconnect to it by going to http://192.168.0.1

ok now go to the dhcp tab and disable dhcp, set the starting address to 192.168.0.1 and now apply, now to get internet access you will have to go into your network settings on your windows pc and set your ip to 192.168.0.anything but 1 or 64 , i used 3 and it worked fine..... make sure to set your gateway to 192.168.0.1 and the subnet mask will auto fill in, after doing this reboot pc, confirm you have internet access... you should already have the xbox booted to linux (as you can tell this is pre tsop flash info, but its vital) ok if you have internet go to http://192.168.0.64 you should get a page that was served by your xbox, if you do your ready to telnet in and flash.... remember to take care of the jumpers.... and ESP remember to do the extra steps if you have a sharp TSOP flashing is risky but i got through it ok.


OK finally.... now i know this is prolly a VERY hard to understand post since its late, and i just wanted to share the info i gathered from many different places and FINALLY got this working.... i want to THANK everyone on #linux-on-unmodded mbin1 linuxbox skinneh, and a few otheres THANK you all.... someone feel free to organise this info if you want but plese give me credit on the writeup and Testing... once again i didnt create this , just kinda made sense of lots of stuff that was out there just not together and wanted to help out some noobs like myself... if you have any questions or need the save head over to efnet linux-on-unmoddedd and maybe i can help, or post a reply, i know some of you will be needing the game save partition, so id like to find someon willing to host it, but once agian i didnt create it... HAPPY linux modding all... and to all a good night , morning... hehe

#2 shr00m

shr00m

    X-S Enthusiast

  • Members
  • 28 posts

Posted 15 April 2003 - 12:03 PM

^bump^

#3 drcyc

drcyc

    X-S Enthusiast

  • Members
  • 7 posts

Posted 15 April 2003 - 05:03 PM

Anybody (other than shr00m) able to reflash their TSOP using this tutorial???

I'm considering trying it and wondered if there's any hitches that weren't mentioned in the tut...

#4 shr00m

shr00m

    X-S Enthusiast

  • Members
  • 28 posts

Posted 15 April 2003 - 09:29 PM

bump... just wanted to give some more people a chance to see this

#5 PlagueViper

PlagueViper

    X-S Senior Member

  • Members
  • PipPip
  • 294 posts

Posted 15 April 2003 - 09:58 PM

ive odne this works fine

#6 krozor

krozor

    X-S Enthusiast

  • Members
  • 18 posts

Posted 16 April 2003 - 09:25 AM

Ok guys i think we need to give all the people who made the 007hack happen a big thank-you because i did it last night and it works perfect!

The hack is 100% real!!!!

Thanks to the all the people on #linux-on-unmodded for there help.

Thanks to shr00m for giving up his time to write an excellent tutorial wink.gif


#7 chuckfredgoose

chuckfredgoose

    X-S Member

  • Members
  • Pip
  • 65 posts

Posted 16 April 2003 - 09:30 AM

what bios can i use ? can it be 256 k


#8 shr00m

shr00m

    X-S Enthusiast

  • Members
  • 28 posts

Posted 17 April 2003 - 01:38 AM

bump

#9 shanafan

shanafan

    He Who Posts Alot...

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 11,527 posts
  • Location:Michigan, USA
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 17 April 2003 - 01:39 AM

QUOTE (shr00m @ Apr 16 2003, 09:38 PM)
bump

Just going to keep bumping without answering questions?

#10 shr00m

shr00m

    X-S Enthusiast

  • Members
  • 28 posts

Posted 17 April 2003 - 03:34 AM

the bios needed is 1 meg becasue the xbox bios is 1 meg, if you just follow the tut you wont have trouble the bios.bin which is included in the gamesave is evox d6 in 1 meg format... i have now reflashed with x2 but the bin in the game save works fine

#11 znark

znark

    X-S Enthusiast

  • Members
  • 1 posts

Posted 17 April 2003 - 04:46 AM

QUOTE (shr00m @ Apr 15 2003, 10:57 AM)
i will [...] explain how to do it without EVER compiling a linux kernel

Ok, nice tutorial! Let's take this a step further by adding in some hints on how to write the bzipped FATX gamesave partition image to your hot-swapped Xbox hard drive from Windows, without necessarily needing Linux on your PC.

It appears that this step...

QUOTE
3. TYPE THIS COMMAND EXACTLY WITHOUT QUOTES "bzip2 -cdk gamesaves.img.bz2 | dd of=/dev/hdc seek=5501 bs=512k"

...can be done from Windows, too - provided that you have the right tools at your disposal. In this case you would need the Windows versions of bzip2 and dd.

Just download the GNU utilities for Win32 package and extract the dd.exe and bzip2.exe command line tools - preferably to the same directory where your gamesaves.img.bz2 image file is already located.

The above Linux command line would then transmogrify to something like this for Windows:

bzip2 -cdk gamesaves.img.bz2 | dd of=\\.\PHYSICALDRIVE# seek=5501 bs=512k

The "#" character above should be replaced with the number of your hard drive: 0 is the first hard drive in the system, 1 is the second, 2 the third one and so on. If you are unsure about the correct drive number, try reading some blocks from the drive to a file and checking the resulting dumps with a hex editor. If you read from the correct offset - preferably from an offset where some of the FATX partitions begins - you should see some distinct FATX filesystem identifiers, and then you can be sure that you are accessing the correct drive.

#12 drcyc

drcyc

    X-S Enthusiast

  • Members
  • 7 posts

Posted 17 April 2003 - 01:20 PM

Great post, znark! Seems that most people are getting hung up on the linux portion of the tutorial. Seems that they're either not logged in as root, are missing some packages/binaries, or something silly like that. smile.gif

#13 shr00m

shr00m

    X-S Enthusiast

  • Members
  • 28 posts

Posted 17 April 2003 - 03:44 PM

id like to know if the windows way works, great tip znark.... id probabally still do it linux since thats tested... i dont see any reason why the windows way wouldnt work as long as you unlock the drive the same way. If your going to attempt this way i would definitley make sure you back up your drive.... i really think that what znark said should work.... but its untested ... hopefully someone will try it and if it works can come back and confirm it, it would definitley make it easier for people who dont have a clue about linux (which i basically didnt). a few comments i wanted to add

when hot swapping drive... LEAVE IT IN THE XBOX, dont just sling the drive around, remember its a running HD which can be very sensitive to quick movements, and older drives sometimes any movement, people will say that hot swapping is risky, but if you just leave the drive in the xbox and dont move it, and gently unplug and plug in the ide cable, also making sure to line up the ide dont just poke around till it plugs in. I tested the hot swap a lot, and did it numerous times the way i described; to back up, reimage and test some things, now if we were hot swapping the power cable that would be a different story, thats risky, but just swapping the ide cable isnt much of a risk if you just are gentle and make sure to plug it in right.



#14 Wong Hung Lo

Wong Hung Lo

    X-S Genius

  • Members
  • PipPipPipPip
  • 755 posts
  • Location:Way out in BFE
  • Interests:Modding my Sampo DVD players,Tivo, ReplayTV and my Xbox.<br /><br />Being a soldering elitists :)
  • Xbox Version:v1.1
  • 360 version:v4.0 (jasper)

Posted 17 April 2003 - 04:29 PM

QUOTE (shr00m @ Apr 16 2003, 11:34 PM)
the bios needed is 1 meg becasue the xbox bios is 1 meg, if you just follow the tut you wont have trouble the bios.bin which is included in the gamesave is evox d6 in 1 meg format... i have now reflashed with x2 but the bin in the game save works fine

But if a person has one of the new 1.2 Xbox's with the 2 meg (256K) TSOPS then you could only use a 256K bios.

#15 shr00m

shr00m

    X-S Enthusiast

  • Members
  • 28 posts

Posted 17 April 2003 - 04:43 PM

yea this tut doesnt really cover 1.2s seeing as the game save has the last version of raincoat and it doesnt support the chip, the new version of raincoat does, and i think the jumpers are the same, but we'll need to get some input from a 1.2 user for that, this method could easily be adopted to a 1.2, by getting the gamesave partition image off a xbox with the new raincoat and a 256k bios file because yes the 1.2 is 256k.... i just didnt put any nfo on 1.2s in here because it wasnt confirmed and i didnt test it. but with a partition image like the one were using only from a xbox with the newer version of raincoat (with winbond 1.2 support) and a 256k bios file it shouldnt be a problem, not sure if the jumpers are the same, but you can find info on jumpers pretty easily if you search the forums.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users