Jump to content


Photo

My Xbox Is Now Dead


  • Please log in to reply
1 reply to this topic

#1 helpanewb

helpanewb

    X-S Enthusiast

  • Members
  • 1 posts

Posted 21 April 2003 - 07:39 PM

Thanks in advance for any help you'll give me.

So I installed my modchip, and got it right on the first try. Installed my new hard drive, without actually screwing it in (just put it on top of the old drive to test) and everything worked.

I decided I needed to actually install the new hard drive into the case so that I can put the xbox back together. So I did. I took out the plastic DVD/Hard drive rig, seperated them, removed the old hard drive, put in the new hard drive, and put everything back together.

Now the Xbox doesn't power on. It doesn't do anything. I've tried 3 different electrical outlets: nothing. I've tried detatching and removing the DVD/HD carrying assembly, detatching the IDE and CD cables, and powering on. Nothing. It's dead.

I'm afraid I've ruined my 'Box. Is there ANYTHING else I can do? Please help; I can't afford to get a new Xbox.

Again, thank you in advance.

#2 FIREitUP

FIREitUP

    X-S Enthusiast

  • XS-BANNED
  • 2 posts
  • Xbox Version:unk

Posted 21 April 2003 - 09:37 PM

maybe your jumper set to the on button got removed, also what happens when u disable the mod?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users