Jump to content


Photo

xISO xFER FAQ


  • Please log in to reply
158 replies to this topic

#136 L!M!T

L!M!T

    X-S Senior Member

  • Members
  • PipPip
  • 228 posts
  • Xbox Version:v1.1
  • 360 version:v5.0 (360S - trinity)

Posted 19 May 2003 - 04:55 AM

The v2.0 is quite something extra, it is faster than previous versions made by myself (prolly because of the true on-the-fly xFER and the somewhat rewritten transfer code).

Regarding digiblur's error, please do as 1wolf1 suggested and please provide a little more information. I have not encountered any errors whatsoever with the released version.

...and keep xFERRiNG, fellas! smile.gif


Regards,
L!M!T

EDIT: spelling

Edited by L!M!T, 19 May 2003 - 04:56 AM.


#137 SillYcoNe

SillYcoNe

    X-S Senior Member

  • Members
  • PipPip
  • 291 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 19 May 2003 - 06:02 PM

I didn't have time until now so I just tested version 2.0, it's great !
I found a little issue: control-V doesn't work to paste a name in the dialog asking for a directory to put the game in (the one that defaults to the name found in .XBE). BTW right-click/paste works.
I hope you'll enable the shortcuts in next version....
Thank you for this great version ! keep up the good work !
beerchug.gif


#138 Devenic

Devenic

    Avalaunch Team

  • Moderator
  • PipPip
  • 394 posts
  • Xbox Version:v1.4
  • 360 version:none

Posted 20 May 2003 - 09:15 PM

I'm back. Digiblur...did you resolve your problem?

#139 Devenic

Devenic

    Avalaunch Team

  • Moderator
  • PipPip
  • 394 posts
  • Xbox Version:v1.4
  • 360 version:none

Posted 20 May 2003 - 09:20 PM

QUOTE (SillYcoNe @ May 19 2003, 03:02 PM)
I hope you'll enable the shortcuts in next version....
Thank you for this great version ! keep up the good work !
beerchug.gif

Thanks for the comments, and noticing the Ctrl+V problem. Fixed.

#140 SillYcoNe

SillYcoNe

    X-S Senior Member

  • Members
  • PipPip
  • 291 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 21 May 2003 - 07:32 AM

Thank you for the fix smile.gif Is it available somewhere ?
Just a quick suggestion: would it be possible to make a drop list for the name of the dir with those 2 choices:
- name found in XBE
- name of the directory containing the extracted .iso
This is a personal request as I use the second option on my box and this will save me a Ctrl-C Ctrl-V smile.gif
Keep up the good work !

edit: typo

Edited by SillYcoNe, 21 May 2003 - 07:33 AM.


#141 Devenic

Devenic

    Avalaunch Team

  • Moderator
  • PipPip
  • 394 posts
  • Xbox Version:v1.4
  • 360 version:none

Posted 21 May 2003 - 01:53 PM

QUOTE (SillYcoNe @ May 21 2003, 04:32 AM)
Thank you for the fix smile.gif Is it available somewhere ?

I'll wait to see if there's something I need to do for digiblur's problem before I release the fix, to keep version chaos to a minimum.

The next feature update (new features, not fixes) will have some enhancements to output directory naming, and will address your request and also do some other cool stuff.

#142 digiblur

digiblur

    X-S Enthusiast

  • Members
  • 23 posts

Posted 22 May 2003 - 03:10 AM

QUOTE (Devenic @ May 20 2003, 11:15 PM)
I'm back. Digiblur...did you resolve your problem?

No... I gave up and went back to 1.0. My new mobo and Athlon XP CPU is coming next week. Once I upgrade and rebuild I'll see if I still have the problem. I'll let you know... its weird that no one else is having this problem, yet this is the first piece of software I've had a problem with in the xbox scene on the PC.

#143 digiblur

digiblur

    X-S Enthusiast

  • Members
  • 23 posts

Posted 22 May 2003 - 03:13 AM

QUOTE (Devenic @ May 20 2003, 11:15 PM)
I'm back. Digiblur...did you resolve your problem?

Ok... just a few things I did try... Different Xbox...still no go... tried it on a different PC with a Windows 2000 instead of XP. The sucker works beautifully on both Xbox's. But when I go back to the XP pc, which I'm not having any problems whatsoever on, it connects to the xbox, makes the directory, and transfer the first file with a size of zero bytes then stops. The counter keeps ticking and I hit the abort button to cancel.

#144 Devenic

Devenic

    Avalaunch Team

  • Moderator
  • PipPip
  • 394 posts
  • Xbox Version:v1.4
  • 360 version:none

Posted 22 May 2003 - 03:28 AM

QUOTE (digiblur @ May 22 2003, 12:13 AM)
But when I go back to the XP pc, which I'm not having any problems whatsoever on, it connects to the xbox, makes the directory, and transfer the first file with a size of zero bytes then stops.

Are you using XP's firewall (or any other firewall software for that matter)? I haven't tested with it enabled, but I am on XP and have no problems when connecting to my Xbox. It has been tested with ZoneAlarm Pro without a problem.

And can you tell me if it creates an xfer20.elf file? Please PM me.

Edited by Devenic, 22 May 2003 - 03:53 AM.


#145 SillYcoNe

SillYcoNe

    X-S Senior Member

  • Members
  • PipPip
  • 291 posts
  • Xbox Version:v1.0
  • 360 version:none

Posted 22 May 2003 - 06:07 AM

Thank you for taking my request into account !

For digiblur's problem:
It seems to me that there is problem establishing the data socket when it comes to transfer files over FTP.
Directory and file creation are orders that go through the control connection so the 0byte file is normal. Then the xbox should connect to PC on port 20 (FTP-DATA) to receive the content of the file. If there is a problem establishing the socket, then the 0byte file will be there but nothing more.

digiblur: could you monitor the traffic on your network on ports 20 and 21 with a sniffer and post the result ? This way we can confirm my diag is correct or not. I think we'll see everything running smooth on port 21 then a SYN from Xbox to PC on port 20 and nothing more. (all ports here are TCP).


#146 L!M!T

L!M!T

    X-S Senior Member

  • Members
  • PipPip
  • 228 posts
  • Xbox Version:v1.1
  • 360 version:v5.0 (360S - trinity)

Posted 22 May 2003 - 06:45 AM


FYI:

v2.0 works fine here with XP Pro and XP Home. Both with Norton IS.


Regards,
L!M!T

#147 Devenic

Devenic

    Avalaunch Team

  • Moderator
  • PipPip
  • 394 posts
  • Xbox Version:v1.4
  • 360 version:none

Posted 22 May 2003 - 02:23 PM

The only other thing I can think of is if he's running into an error in the transfer thread. The user interface runs in the main thread, and the extraction/ftp stuff runs in a separate thread. The version of the error logging system I used had problems with threading, but has been fixed with a newer version. I've incorporated that into the latest internal build, and if digiblur PMs me I'll have him test it out.

#148 Biznaz

Biznaz

    X-S Senior Member

  • Members
  • PipPip
  • 186 posts

Posted 22 May 2003 - 07:11 PM

just wanted to say, great work L!M!T!! this is by far the sexiest looking xbox iso tool to date. And it cuts extraction/uploading time in half. Great work man, i appreciate it.

#149 digiblur

digiblur

    X-S Enthusiast

  • Members
  • 23 posts

Posted 23 May 2003 - 03:32 AM

QUOTE (SillYcoNe @ May 22 2003, 08:07 AM)
Thank you for taking my request into account !

For digiblur's problem:
It seems to me that there is problem establishing the data socket when it comes to transfer files over FTP.
Directory and file creation are orders that go through the control connection so the 0byte file is normal. Then the xbox should connect to PC on port 20 (FTP-DATA) to receive the content of the file. If there is a problem establishing the socket, then the 0byte file will be there but nothing more.

digiblur: could you monitor the traffic on your network on ports 20 and 21 with a sniffer and post the result ? This way we can confirm my diag is correct or not. I think we'll see everything running smooth on port 21 then a SYN from Xbox to PC on port 20 and nothing more. (all ports here are TCP).

Sure... I break out the hub (can't do much sniffing on the switch) and do some sniffing and let you know.

#150 L!M!T

L!M!T

    X-S Senior Member

  • Members
  • PipPip
  • 228 posts
  • Xbox Version:v1.1
  • 360 version:v5.0 (360S - trinity)

Posted 23 May 2003 - 06:35 AM

QUOTE (Biznaz @ May 22 2003, 09:11 PM)
just wanted to say, great work L!M!T!! this is by far the sexiest looking xbox iso tool to date. And it cuts extraction/uploading time in half. Great work man, i appreciate it.


Thanks man!

But the v2.0 is not made by me. That's Devenic's baby, so I guess I'll redirect that appreciation to him then. But then again, if you have been using the previous versions, then I guess I can have a slice of that 'thank you' as well wink.gif


Regards,
L!M!T




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users