Jump to content


Photo

Xbox Ftp Problem


  • Please log in to reply
13 replies to this topic

#1 aviynw

aviynw

    X-S Enthusiast

  • Members
  • 28 posts

Posted 16 January 2006 - 05:49 AM

Okay, from what I can tell there are two versions to how one should ftp their xbox, and I've tried both. I am connecting my xbox directly to my computer and not through a router and I am positive that I am using a crossover cable. I have evox installed so I go into the settings and set the xbox to this and restart.

SetupNetwork = Yes
StaticIP = Yes
Ip = 192.168.0.3
Subnetmask = 255.255.255.0
Defaultgateway = (now here is where some tutorials differ. Some say to set it at something like 192.168.0.1 and others say to leave it blank, I've tried both)
DNS1 =
DNS2 =

[FTP]
Enable = Yes
Password = xbox
IGR = No

Then I go into my network settings for my ethernet port and set the settings to this

IP Address: 192.168.0.2
Subnet Mask: 255.255.255.0
Gateway: (again, here is where some tutorials differ. Some say to set it at something like 192.168.0.1 and others say to leave it blank, I've tried both)
DNS:

I've tried flashxp some other program that I forget the name of and internet explorer and they all didn't work. (and passive mode is turned on for flash xp). It makes some connection because if I turn off the xbox while it's connected to my computer it says a network cable is unplugged. However when I use flash xp it says network connection timed out. If I look at what packets were sent/recieved, packets were in fact sent but none were recieved. Why is this? what are some possible problems and some possible solutions?

Thanks, I appreciate any help

Oh yeah, and when I try to connect to the xbox it's on port 21, password and username are both xbox and I type in the ip address of the xbox.

#2 MMXMonster

MMXMonster

    X-S Genius

  • Members
  • PipPipPipPip
  • 929 posts
  • Location:Latitude - 41 44' 00.21" N, Longitude 71 24' 25.37" W
  • Xbox Version:v1.0
  • 360 version:none

Posted 16 January 2006 - 06:51 AM

QUOTE(aviynw @ Jan 15 2006, 11:56 PM) View Post

I am positive that I am using a crossover cable.


Just for the heck of it... look at the ends of the cables your using. Are the colored wires in the same sequence on both ends?
If yes, then it's not a crossover cable.

Can you ping the xbox from your PC?


#3 xboxgamer733

xboxgamer733

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,803 posts
  • Location:Moscow, Idaho
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 16 January 2006 - 07:01 AM

Have you tried setting DNS 1 and 2, on the Xbox and computer, to '0.0.0.0'?

#4 aviynw

aviynw

    X-S Enthusiast

  • Members
  • 28 posts

Posted 16 January 2006 - 07:44 AM

yes the wires do crossover and are not in the same allignment and yes I've tried changing dns 1 and 2 to 0.0.0.0 but to no avail, but thanks for the help.

what do you mean ping my xbox from my pc? I'm pretty knew to this kind of stuff so I don't know what all the terms mean

Thanks!

#5 xboxgamer733

xboxgamer733

    X-S Messiah

  • Members
  • PipPipPipPipPipPipPip
  • 3,803 posts
  • Location:Moscow, Idaho
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 16 January 2006 - 07:52 AM

When your Xbox is connected to your computer, open Command Prompt, and type 'ping 192.168.0.3', without quotes, and push enter.

If there really is no connection to your Xbox, you'll receive 'Request timed out' after a few seconds. Hopefully, you won't encounter this.

But if a packet is sent to the Xbox, and a response is received, you'll see something like this:

CODE
Reply from 192.168.0.3: bytes=32 time=2ms TTL=64
Reply from 192.168.0.3: bytes=32 time<1ms TTL=64
Reply from 192.168.0.3: bytes=32 time=1ms TTL=64
Reply from 192.168.0.3: bytes=32 time<1ms TTL=64

Ping statistics for 192.168.0.3:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 2ms, Average = 0ms

Edited by xboxgamer733, 16 January 2006 - 07:52 AM.


#6 ItchyB

ItchyB

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,341 posts
  • Location:South Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 16 January 2006 - 07:53 AM

On your PC open a command promt ( start - run "cmd" - enter). At the prompt type Ping 192.168.0.3 (xbox ip) if the connection is correct you will get a reply if not it come up with response timed out.


If the pc says Network cable unplugged when you turn the xbox off then the physical connection is ok.

I have had probelms with some dashes and versions. Load a different dash to your apps like Avalaunch or unleashx, launch it from your apps menu in Evox and then adjust the network settings reboot go back into the dash and try FTP. This will tell you if it a problem in Evox.

#7 aviynw

aviynw

    X-S Enthusiast

  • Members
  • 28 posts

Posted 26 January 2006 - 09:39 AM

Okay, I think I understand what my problem is. When I use flash xp it doesn't try to connect through my ethernet port but tries to go through my wireless network. I disabled my wireless network and used flash xp and nothing even showed up in the little white box. This tells me that the whole it was it was trying to connect through the wireless network and not the ethernet port.. How do I change this so that it goes through the ethernet port?

Thanks! I appreciate any help!

#8 aviynw

aviynw

    X-S Enthusiast

  • Members
  • 28 posts

Posted 26 January 2006 - 09:42 PM

Any Suggestions?

#9 ItchyB

ItchyB

    X-S Hacker

  • Members
  • PipPipPipPipPipPip
  • 2,341 posts
  • Location:South Australia
  • Xbox Version:v1.1
  • 360 version:none

Posted 26 January 2006 - 09:50 PM

Try this,

Consider your wireless adaptor as a second NIC.

Taken from MrRobinsons guide. there is a link to the full tut in my sig.

Setting up Configuration 2

Configuration 2

The configuration 2 diagram above shows the most common setup you would have with 2 NICs in your PC. The only difference between this and configuration 1 is that the second NIC would have a connection to the internet for you. Chances are this NIC to the internet is getting a public DHCP address like 64.238.121.12, or any such number. If this NIC goes to a router, you may wish to read configuration 3 and you may not need your second NIC at all. So when the NIC gets DHCP like this it is automatically assigned an ip, subnet, gateway, dns, etc. so you don't need to do anything else to it. The only "gotcha" with this configuration is that when you configure your second NIC that goes direct to the Xbox you may configure it in such a way that your computer tries to access the internet through that NIC instead of the correct one with the public DHCP. This is a routing issue and one way to ensure this doesn't happen is to configure the NIC with the connection to your Xbox exactly as in configuration 1, specifically making note that you DO NOT enter a gateway address. Your Xbox itself can also be setup just as in configuration 1. Refer to the Troubleshooting section if you are having problems and yet are set up as I described.

So if you connect one of your NICs to a router in this configuration you may be getting an internal IP like 192.168.x.x instead of an external IP address. If this is the case make sure the NIC that goes out to the Xbox is not given an IP address on the same subnet as the NIC going to your router. For example, when the NIC going to your router and out to the internet is getting an IP of 192.168.1.x and has a subnet mask of 255.255.255.0 and the gateway on this NIC is the IP address of the router, then set the IP address of the NIC going to your Xbox to 192.168.0.x with a subnet of 255.255.255.0 and don't enter a gateway. Then make your Xbox have an IP address on the 192.168.0.x range, and again a gateway would not be needed.

**Advanced Option** If for some reason you would like both your NICs on the same subnet then you can still force the one going internet to be used by default for everything and the one going to the Xbox to only be used when connecting to the static IP of your Xbox. Open up a command prompt and type 'route print'. With route print you can see what route your data packets will take to try to access the internet or your Xbox. What you can do is manually add a route that tells your computer that anytime it tries sending anything to 192.168.0.3 it should use the NIC with the direct connection the Xbox, not the one that goes out to the internet. To do this run the route print command. The first thing you'll see is an interface list. It'll say something like:

Interface List 0x1 ........................... MS TCP Loopback interface 0x2 ...00 06 5b b8 e3 33 ...... 3Com 3C920 Integrated Fast Ethernet Controller 0x3 ...00 02 2d 26 2c 74 ...... Dell TrueMobile 1150 Series Wireless LAN Mini PCI Card

So in this case the NIC going to the Xbox is 0x2, which would be IF 2 in the command. To add the static route follow this pattern:

route ADD 157.0.0.0 MASK 255.0.0.0 157.55.80.1 METRIC 3 IF 2
destination^ ^mask ^gateway metric^ ^Interface

So in our example you would type:

route -p add 192.168.0.3 mask 255.255.255.255 192.168.0.2 METRIC 1 IF 2

to remove this at any time you would just type:

route delete 192.168.0.3

The other option you have if you want your Xbox to get out to the internet through your computerís internet connection is to set up Internet Connection Sharing (ICS) on your computer. How to set this is up a good thing to google search. You can also try this page: http://www.xbox.com/.../windowsics.htm for good details. Once set up the only thing to change is to put a gateway address in your evox.ini, avalaunch.xml, or mxm.xml file which should be your computerís IP address, so the gateway you would use is 192.168.1.1 since that is probably what ICS will set your NICs IP address to.

#10 mrRobinson

mrRobinson

    X-S Caffeinated Member

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,222 posts
  • Interests:Quantum Loop Theory
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 January 2006 - 10:44 PM

After going over the tutorial, if you are still stuck, from a command prompt on your computer type "ipconfig /all" without the quotes and paste the output of that here. Feel free to leave your wireless on if that is your connection to the internet and you'd like that active while being able to ftp to the xbox over the crossover cable.

#11 aviynw

aviynw

    X-S Enthusiast

  • Members
  • 28 posts

Posted 29 January 2006 - 03:26 AM

Okay, thanks for the help but it still didn't work. The ip address I am getting for my wireless connection is 192.168.0.3 so I went into the configurations for my ethernet connection to my xbox I set my computer to ip:192.168.1.2 and my xbox: 192.168.1.3 both without a gateway and with the subnet mask: 255.255.255.0 with no DNS servers sepcified. I used flash xp to try to connect to the xbox's ip address and it said the connection timed out. When that didn't work I tried the "advanced method" typing in the specifics for my computer (I typed in the ox that was appropiate for my connection) but I still got the same results. Here is what I got for ipconfig/all. Also, I tried using both evox and unleashx for this but they both didn't work. Any more help would be much appreciated

MS Windows XP [Version 5.1.2600]
© Copyright 1985-2001 MS Corp.

C:\Documents and Settings\avi>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : wamble-qto8x05e
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Linksys Wireless-G PCI Network Adapt
er with SpeedBooster
Physical Address. . . . . . . . . : 00-12-17-9D-9D-11
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 71.243.0.12
151.203.0.85
151.203.0.84
Lease Obtained. . . . . . . . . . : Saturday, January 28, 2006 6:12:57 P
M
Lease Expires . . . . . . . . . . : Tuesday, January 31, 2006 6:12:57 PM


Ethernet adapter Local Area Connection 3:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-09-6B-04-05-A0
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :


#12 aviynw

aviynw

    X-S Enthusiast

  • Members
  • 28 posts

Posted 29 January 2006 - 06:52 PM

I really don't know what to think, FTPing seems to go so smoothly for everybody else and I know I am doing it "correctly." Is it possible that my xbox is defective? And if so is there a way to check that?

#13 mrRobinson

mrRobinson

    X-S Caffeinated Member

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 5,222 posts
  • Interests:Quantum Loop Theory
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 29 January 2006 - 07:07 PM

can u ping your xbox at 1.3 now?

#14 BearFather

BearFather

    X-S Enthusiast

  • Members
  • 2 posts

Posted 29 January 2006 - 08:02 PM

Try setting your wired connection first in your network settings. That way it tries useing your wired before your wireless. Sometimes it will kill your net while this is on, if so just change it back after your done.


To do this...

goto your network control panel start/connet-to/show all connections (or start/settings/network conections)
goto advanced/advanced settings (file,edit,view,Favorites,tools,ADVANVCED,help)
In adapters and bindings, under connections. Highlight your "Local Area Connection 3"
Then click on teh green arrow to the right, do this till its at the top.
CLick Ok


Now see if that helps. Basiclly its telling your system to try that adapter first. Once you do this you can try pings and so forth.

To reverse it just go back in and hightlight "Wireless Network Connection" instead.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users