Jump to content


Photo

M$ Controller Type S Problems


  • Please log in to reply
1 reply to this topic

#1 x_quest

x_quest

    X-S Young Member

  • Members
  • Pip
  • 52 posts
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 13 February 2006 - 06:46 PM

I have about 4 Type S controllers, only one of them work. The Newest one. I also have about 4 other non MS controllers and only one works.

Keep in mind I do have kids and the controllers do get banged up sometimes. I'm pretty sure that's the reason they don't work. But......

My problem is that they just stop working, First thing I notice is that during a game the left thumbstick doesn't go all the way to the left. The character walks instead of running. Then they just stops working completely, I plug it in and nothing. I'm forced to buy more controllers and the type s controllers ain't cheap.

I opened the contoller and everything seems to be intact. Is there somewhere in particular I should be looking?
Does it have to do with the controller not getting power? is there any test points I could check with my multi-meter?

Does anyone else have this problem?

Thanks in advance.


#2 xman954

xman954

    X-S Messiah

  • Dev/Contributor
  • PipPipPipPipPipPipPip
  • 3,028 posts
  • Location:the bottom of Tampa Bay
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 13 February 2006 - 07:18 PM

QUOTE
I'm forced to buy more controllers and the type s controllers ain't cheap.
$19.99 at circuit this week (bestbuy will price match)
http://weeklyad.circ...&go.x=21&go.y=6




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users