Jump to content


Photo

Working Nes Emulator Through Mce! (no Sound)


  • Please log in to reply
220 replies to this topic

#1 Xexter

Xexter

    X-S Young Member

  • Members
  • Pip
  • 31 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 March 2006 - 12:25 AM

I've attached a link to a version of NESCafe that works through Media Center on the Xbox 360. This is currently setup to run at 480p (Widescreen). You can edit the nes.htm file if it does not fit correctly on your screen. I haven't found a way to add a menu for the roms list so you will have to edit the nes.htm and change <param name="ROMFILE" value="/roms/whateverrom.zip" /> to whatever Nes rom you want to play. I've included a Public Domain rom for testing but have verified Zelda1-2, Excitebike, and TecmoBowl and all worked.
Please do not ask for ROMs as they are quite easy to find (Google - "Nes Roms"). dry.gif

DOWNLOAD RAR: http://www.yourfilel...t.php?fid=58730


INSTALL:
You will need to extract the rar into C:Documents and Settings\All Users\Start Menu\Programs\Accessories\Media Center\Media Center Programs\ on your media center box. It took a bit for the icon to show up under More Programs but it finally will.

NOTES: Sound is not functioning, Media Center 2005 is required. If it locks up you will need to run something that warns you that it is a web page and check the box that says "Donít show this again". Once you do that it should run fine. I created an MCL that just went to Google and then checked that box. I've also attached an image with the mapping of the Xbox Controller to the corresponding keyboard keys.

-X
IPB Image


#2 Xexter

Xexter

    X-S Young Member

  • Members
  • Pip
  • 31 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 March 2006 - 12:43 AM

It seems that it will run with sound through a normal browser but not through MCE. Anyone have ideas on that?

I think I can get a GEN and TG16 version of PotatoEmu working as well if I can figure out how to not have the splash screen (It requires a left mouse click to start)

Edited by Xexter, 26 March 2006 - 12:43 AM.


#3 Unlimited

Unlimited

    X-S Member

  • Members
  • Pip
  • 72 posts

Posted 26 March 2006 - 02:31 AM

Gen would rock so hard, please get that working!
Thanks for the NES emulator, about to try it...

#4 Xexter

Xexter

    X-S Young Member

  • Members
  • Pip
  • 31 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 March 2006 - 06:21 PM

VIDEO:

#5 BoomDivX

BoomDivX

    X-S Member

  • Members
  • Pip
  • 90 posts
  • Location:Montreal, QC, CA
  • Xbox Version:v1.1
  • 360 version:v1 (xenon)

Posted 26 March 2006 - 11:19 PM

This is awesome! Great work! I'll have to install MCE again but I don't care XD NES wireless... *drools* XD

Thx for the hard work!

#6 yankefish

yankefish

    X-S Member

  • Members
  • Pip
  • 64 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 March 2006 - 11:43 PM

Works real good, hopefully the sound will be in the next version. keep up the good work, hopefully this plus the firmware hack will enable users to play roms from other systems, and someday homebrew (LOL)

#7 thomasmac3490

thomasmac3490

    X-S Member

  • Members
  • Pip
  • 69 posts
  • Xbox Version:v1.0

Posted 26 March 2006 - 11:48 PM

nice, this is amazing work, currently playing super mario bros. biggrin.gif, kinda hard tho since run+jump+side = reset button >< ill have to change the controls around. other than that it works great, nice job again

#8 yankefish

yankefish

    X-S Member

  • Members
  • Pip
  • 64 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 26 March 2006 - 11:55 PM

?? wierd was wonking not getting error about my nes.htm file i havent touched it at all can anybody help

#9 quall

quall

    X-S Genius

  • Members
  • PipPipPipPip
  • 903 posts
  • Location:OHIO
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 27 March 2006 - 12:02 AM

lol, That is quite the java application.

#10 yankefish

yankefish

    X-S Member

  • Members
  • Pip
  • 64 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 27 March 2006 - 12:23 AM

i have complete sets on public ftp.... i dont support piraacy though

#11 nmf4505

nmf4505

    X-S Enthusiast

  • Members
  • 28 posts
  • Xbox Version:v1.6b
  • 360 version:v1 (xenon)

Posted 27 March 2006 - 12:23 AM

is anyone else lagging realy bad or is it just my wireless connection

#12 onlyme

onlyme

    X-S Expert

  • Members
  • PipPipPip
  • 543 posts
  • Location:UK
  • Xbox Version:v1.6b
  • 360 version:v1 (xenon)

Posted 27 March 2006 - 12:24 AM

just dug this out of an old favs backup and thought it might be of interest

http://www.davidwinc...GameBoyEmu.html

its a java gameboy emu with rom menu

#13 yankefish

yankefish

    X-S Member

  • Members
  • Pip
  • 64 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 27 March 2006 - 12:25 AM

i am mine hasnt loaded yet been waiting like 10 minutes

http://www.monstarcade.com/index.asp

a legal way of getting roms for every system.

#14 DaddyO21

DaddyO21

    X-S X-perience

  • Members
  • PipPip
  • 321 posts
  • Xbox Version:v1.0
  • 360 version:v1 (xenon)

Posted 27 March 2006 - 12:35 AM

hmm , experiencing framerate problems , but you cant have perfection on the first try.

QUOTE(yankefish @ Mar 27 2006, 12:32 AM)  

i am mine hasnt loaded yet been waiting like 10 minutes

http://www.monstarcade.com/index.asp

a legal way of getting roms for every system.


there's no legal way to get roms , so if you didnt pay for them at the store youre stealing.

#15 nmf4505

nmf4505

    X-S Enthusiast

  • Members
  • 28 posts
  • Xbox Version:v1.6b
  • 360 version:v1 (xenon)

Posted 27 March 2006 - 12:57 AM

QUOTE(yankefish @ Mar 27 2006, 12:32 AM)  

i am mine hasnt loaded yet been waiting like 10 minutes

http://www.monstarcade.com/index.asp

a legal way of getting roms for every system.



i had the same problem
you have to select the menu more programs by pressing (A) in the main menu
and it should appear
but when it loads it runs slow and sometimes i get a connection failure so im guessing it is wireless
im going to hardwire and try see if it improves

and it isnt legal after 24 hours of having the rom

Edited by nmf4505, 27 March 2006 - 12:58 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users