Jump to content


Photo

Itunes Daap Streaming Not Working


  • Please log in to reply
26 replies to this topic

#1 LaMuerteNYC

LaMuerteNYC

    X-S Enthusiast

  • Members
  • 17 posts

Posted 28 March 2006 - 12:54 AM

My setup:

Xbox v 1.4
Xenium Gold Solderless Install
EvoX M8 Plus Bios
250 GB Maxtor HD
Unleash X as main dash
XBMC as an App (DHCP)
PC and Xbox share connection through router

Anyway,

Here is my issue. I cant seem to connect to my I tunes network from my PC to XBMC. I was able to connect SMB network and it has no issues whatsoever, however, Itunes DAAP doesnt work. I edited the config.xml to make sure my IP settings were correct (both on PC and Xbox) and they are. Lastly, Windows Firewall is disabled.

I tried searching for others with similar problems, but I didnt find anything. Any suggestions or a link to a tutorial would be greatly appreciated!! biggrin.gif

Edited by LaMuerteNYC, 28 March 2006 - 01:00 AM.


#2 imamafackinhokie

imamafackinhokie

    X-S Freak

  • Members
  • PipPipPipPipPip
  • 1,452 posts
  • Location:Pittsburgh
  • Xbox Version:v1.6
  • 360 version:v4.0 (jasper)

Posted 28 March 2006 - 03:07 AM

what config.xml???? do you mean xboxmediacenter.xml????

#3 LaMuerteNYC

LaMuerteNYC

    X-S Enthusiast

  • Members
  • 17 posts

Posted 28 March 2006 - 03:32 AM

QUOTE(imamafackinhokie @ Mar 27 2006, 09:14 PM) View Post

what config.xml???? do you mean xboxmediacenter.xml????


My bad,

Yes I mean xboxmediacenter.xml




#4 jdoggvt

jdoggvt

    X-S Young Member

  • Members
  • Pip
  • 55 posts

Posted 28 March 2006 - 03:22 PM

welcome to the club, my friend. i've been having a problem over the last few builds. the log file (which I don't have access to atm) says 'connection timed out' or something to that effect. I'm just guessing, but you can see the files/folders over the daap share, but when you try to access them the box hangs, right?

#5 LaMuerteNYC

LaMuerteNYC

    X-S Enthusiast

  • Members
  • 17 posts

Posted 28 March 2006 - 05:30 PM

welcome to the club, my friend. i\'ve been having a problem over the last few builds. the log file (which I don\'t have access to atm) says \'connection timed out\' or something to that effect. I\'m just guessing, but you can see the files/folders over the daap share, but when you try to access them the box hangs, right?

I dont know what the error message is...Ill get back to you on that when I check my box tonight. However, I cannot even see the files/folders over the DAAP whatsoever. I can only see them from the SMB network.

#6 jdoggvt

jdoggvt

    X-S Young Member

  • Members
  • Pip
  • 55 posts

Posted 28 March 2006 - 09:54 PM

xjc posted this log file from the March 06th 2006 T3CH CVS Build. the problem is persisting for me.

02-03-2006 16:25:05 DEBUG CPlayerCoreFactor::GetPlayers(daap://192.168.0.100/301.mp3)
02-03-2006 16:25:05 WARNING kernel32.dll fake function DisableThreadLibraryCalls called
02-03-2006 16:25:05 INFO MP3Codec: Loaded decoder at 00C2F5F0
02-03-2006 16:25:05 WARNING kernel32.dll fake function DisableThreadLibraryCalls called
02-03-2006 16:25:05 DEBUG CFileDAAP::Open(301.mp3)
02-03-2006 16:25:10 ERROR CFileDAAP::Open - Timeout waiting for stream to stop.
02-03-2006 16:25:18 ERROR CFileDAAP::Open - Timeout waiting for stream to stop.

I can browse through the directly structure (slowly), but this is what I get when I try to play an mp3 as well. After I try, iTunes still thinks there's a user connected even after I cycle the xbox. does your log file look anything like this?

#7 LaMuerteNYC

LaMuerteNYC

    X-S Enthusiast

  • Members
  • 17 posts

Posted 29 March 2006 - 02:58 AM

Okay,

I got home and I tried to reconnect and the error message I got was "Could not connect to the network sever."

I dont know how to do that log that you posted up, but I am really surprised that its not working!

Any ideas would be greatly appreciated.

PS I forgot to state that I am using XBMC from AID (Not sure which version it is)

Edited by LaMuerteNYC, 29 March 2006 - 03:03 AM.


#8 LaMuerteNYC

LaMuerteNYC

    X-S Enthusiast

  • Members
  • 17 posts

Posted 30 March 2006 - 01:58 AM

bump sad.gif

#9 macrobat

macrobat

    X-S Senior Member

  • Members
  • PipPip
  • 169 posts

Posted 30 March 2006 - 03:52 AM

A couple of things you should check as obvious as they are I will mention them
1. make sure sharing is enabled in the iTunes Pref
2. itunes is open when you try to connect
3. your ip address etc is all to order in you .xml

Other then that I cant think of anything else. Question are you able to connect to your movie shares or pictures?

#10 LaMuerteNYC

LaMuerteNYC

    X-S Enthusiast

  • Members
  • 17 posts

Posted 01 April 2006 - 01:39 AM

QUOTE(macrobat @ Mar 29 2006, 09:59 PM) View Post

A couple of things you should check as obvious as they are I will mention them
1. make sure sharing is enabled in the iTunes Pref
2. itunes is open when you try to connect
3. your ip address etc is all to order in you .xml

Other then that I cant think of anything else. Question are you able to connect to your movie shares or pictures?


Ive done all of the three things you stated...sorry I didnt make myself clear. Any other suggestions.

#11 kics

kics

    X-S Genius

  • Members
  • PipPipPipPip
  • 807 posts
  • Location:borderland
  • Xbox Version:v1.4
  • 360 version:unknown

Posted 01 April 2006 - 10:23 AM

what i can see the ip on your computer is not right...

it looks like this

<bookmark>
<name>iTunes Network Share (DAAP)</name>
<!-- only use an IP address here !-->
<path>daap://HEREGOESYOURITUNESIP</path>
</bookmark>

did that work ?

#12 Deathlok

Deathlok

    X-S Enthusiast

  • Members
  • 8 posts

Posted 03 April 2006 - 03:55 PM

QUOTE(kics @ Apr 1 2006, 10:30 AM) View Post

what i can see the ip on your computer is not right...

it looks like this

<bookmark>
<name>iTunes Network Share (DAAP)</name>
<!-- only use an IP address here !-->
<path>daap://HEREGOESYOURITUNESIP</path>
</bookmark>

did that work ?


I've got the same problem as above and I have my DAAP IP set up properly as well
I can listen to music fine through SMB but iTunes doesn't work. Is it just broken in the latest builds or what?

I've got an old xbox v1.0 with the xodus matrix modchip (i think!)

#13 jdoggvt

jdoggvt

    X-S Young Member

  • Members
  • Pip
  • 55 posts

Posted 03 April 2006 - 09:42 PM

same problem here: smb is good to go, daap times out. itunes thinks someone's still connected even after i turn the xbox off. unsure.gif

#14 elupus

elupus

    X-S X-perience

  • Members
  • PipPip
  • 480 posts

Posted 04 April 2006 - 02:09 AM

as soon as cvs is back.. (hopefully wednesday).. i'm putting in a new code for itunes streaming wich should be way faster + switch it back to paplayer for crossfading and such..

#15 nuka1195

nuka1195

    X-S Expert

  • Members
  • PipPipPip
  • 639 posts

Posted 04 April 2006 - 02:20 AM

elupus, will your changes bring back album art?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users